none
Visual studio 2013/windows 8.1 messed up forms.

    Question

  • I recently moved to 8.1 but i can't draw applications. Here is an example. This was drawn in vs 2010 on xp. How ever if i draw a new form with VS on 8.1 the same effect happens. The form is crunched. Is this a VS2013 issue or my windows 8.1? It should also be noted i am using a lenovo yoga pro 2 where the screen size is 3200x1800

    Ok it appears i can not upload images being new. But does any one have any idea

    Wednesday, September 24, 2014 8:19 PM

All replies

  • Hi Sam J Clarke,

    >>How ever if i draw a new form with VS on 8.1 the same effect happens. The form is crunched.

    Could you please provide us with the steps to reproduce this issue? I can help check if it is VS issue or your OS issue.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 25, 2014 9:32 AM
    Moderator
  • To be able to help you please upload the screenshot to a public link.

    Have you changed display from default to medium or large fonts (from Control Panel -> Display) or put a custom DPI setting (Control Panel - >Display -> Set custom text size (DPI)) ?


    "If there's nothing wrong with me, maybe there's something wrong with the universe!"

    Thursday, September 25, 2014 9:46 AM
  • There are no real steps. It's any project.

    • Create a new project in VS 2013
    • Drop a button on the form
    • press start

    The form will not show as displayed in the designer. If i backup the old files it will for a short time display correctly. Then the same again.

    Here is an example

    http://i.imgur.com/IMn80s5.png

    Thursday, September 25, 2014 10:23 AM
  • No not change any thing since had the laptop.

    Picture as requested http://i.imgur.com/IMn80s5.png

    Thursday, September 25, 2014 10:25 AM
  • I have just backed up from an old back up and it's working as expected. When i say old i mean few months before i moved to windows 8.1, i have done this on a number of occasions and after a few changes to the ui in design mode it will go back to the picture above.
    Thursday, September 25, 2014 11:38 AM
  • Hi Sam J Clarke,

    From your picture, I see your problem. But it seems that I can't reproduce this issue. I don't know what kind of project you create. Since you mean any project, I create a WinForm app. You can check from the picture below.

    The left picture is in the design mode. And the right is the running one. 

    Please feel free to let me know if I have any misunderstanding. Or provide us with the sample project.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 25, 2014 12:10 PM
    Moderator
  • Ok i will design a small application, a standard windows form and upload it removing all exe's. The project created is 500,520 in size.

    http://imgur.com/J9fHNyU.png

    http://imgur.com/Q8uQ0c5.png

    file http://www.filedropper.com/showdownload.php/windowsapplication1_1

    Thursday, September 25, 2014 2:43 PM
  • Hi Sam J Clarke,

    I got your sample project. However, it can work fine in my machine. My test environment is win8.1. And I use Visual Studio 2013 to run your sample project. I don't have any change to this sample. Please check the following 2 pictures.

    The first one is in the design mode.

    The second one is the comparison between the design mode and the debug mode. We can find that they are the same.

    I guess it may be related with the settings of your VS. Please reset your compiler first to see if this issue will miss.

    Here is a document about how to reset it for your reference.

    http://msdn.microsoft.com/en-us/library/ms247075(v=vs.90).aspx

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, September 26, 2014 9:04 AM
    Moderator
  • I will try resetting the compiler now. But if you notice my designer picture is different to how yours is displayed in the designer.
    Friday, September 26, 2014 12:34 PM
  • Hi Sam J Clarke,

    In fact, I saw it. Just because I saw the difference, I guess maybe you need to reset your compiler.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, September 26, 2014 12:38 PM
    Moderator
  • Unfortunately the same still happens.
    Tuesday, September 30, 2014 10:40 AM
  • I installed an old copy of 2010 and the same applied. I guess it's an OS issue.
    Tuesday, September 30, 2014 11:00 AM
  • You have probably disabled "Enable XP Styles" in your project or change the DPI Settings in your OS.



    "If there's nothing wrong with me, maybe there's something wrong with the universe!"

    Tuesday, September 30, 2014 5:47 PM
  • Already checked that buddy and rechecked it was still checked. It is. Thank you for the suggestion though.
    Thursday, October 02, 2014 9:41 AM
  • This is due to the high DPI settings when Windows 8 and 8.1 have the scaling set at anything other than 100%.

    One solution is to "troubleshoot" the application from the shortcut to Visual Studio like this:

    Go to your Visual Studio Shortcut/app launcher
    Right Click and Troubleshoot Compatibility
    Continue Troubleshooting Program
    Troubleshoot Program
    Tick: Program opens but doesn't display correctly
    Test Program..
    Yes, Save Changes

    The above instructions were provided as an answer to someone else's question and seemed to work for a few people.  Worth a shot.  (source: http://superuser.com/questions/509766/cannot-disable-dpi-scaling-for-visual-studio-2012)  

    On that same page, a way of changing the scaling for specific applications using a registry entry (http://blogs.technet.com/b/mspfe/archive/2013/11/22/disabling-dpi-scaling-on-windows-8-1-the-enterprise-way.aspx)

    I have a partial summery of those ways plus my solution, which isn't ideal (turn off scaling for everything) at my blog:

    http://thealbuquerqueleftturn.blogspot.com/2015/06/visual-studio-2013-windows-81-preview.html

    Tuesday, June 30, 2015 10:58 PM