none
Configuration BASIC to SERVERLESS RRS feed

  • Question

  • I am trying to reconfigure my basic database to a configuration using Serverless.  I am getting the following error each time:  

    Failed to scale from Basic: 2 GB storage to General Purpose: Serverless, Gen5, 16 vCores, 74 GB storage for database: RaaS. Error code: . Error message: An unexpected error occured while processing the request. Tracking ID: 'c6b13272-e576-4c16-bb4d-8a030b6e1e43'


    Asad Khan

    Thursday, November 28, 2019 8:24 PM

Answers

  • Community:

    This has been resolved and unfortunate documentation/error message is not very clean.    If your Azure SQL has LTR (Long Term Retention) policy defined, then it will fail.  If during the Serverless set-up you have opted for Aut-Pause, than LTR can not be enabled.   If you dont need Auto-Pause (guess that defeats the purpose) then, you can de-select and will migrate to serverless. 

    In short, to use auto-pause remove the LTR policy of f of the database.

    The unexpected error message is a very poorly written error message. 


     


    Asad Khan

    • Marked as answer by ipulsetv Monday, December 2, 2019 3:31 PM
    Monday, December 2, 2019 3:31 PM

All replies

  • It seems like an intermittent issue. Please try after a while and see if that helps.

    Could you try moving to a V-core based pricing tier first and then to Serverless?

    If this issue needs immediate attention, please reach out to Azure support.

    Friday, November 29, 2019 3:25 AM
    Moderator
  • Hi Ipulsetv,

    Did you try moving first to standard (like S1) model tier? Maybe changing directly from basic to Vcore is causing issues.

    hope this helps.

    Friday, November 29, 2019 1:05 PM
  • Hi Kalyan:

    I have tried all various approaches of trying to get serverless.  I have gone to S0 ==> S1 the to Server Serverless

    have tried to going to s1 ==> vCore Pre-allocated then to server less failed.  

    YOu can see that in the communication messages from Portal


    Asad Khan

    Monday, December 2, 2019 12:29 AM
  • Community:

    This has been resolved and unfortunate documentation/error message is not very clean.    If your Azure SQL has LTR (Long Term Retention) policy defined, then it will fail.  If during the Serverless set-up you have opted for Aut-Pause, than LTR can not be enabled.   If you dont need Auto-Pause (guess that defeats the purpose) then, you can de-select and will migrate to serverless. 

    In short, to use auto-pause remove the LTR policy of f of the database.

    The unexpected error message is a very poorly written error message. 


     


    Asad Khan

    • Marked as answer by ipulsetv Monday, December 2, 2019 3:31 PM
    Monday, December 2, 2019 3:31 PM