Skip to main content

 none
Unable to purchase a service plan of an SaaS app offer on Azure Marketplace through Azure Portal RRS feed

  • Question

  • We have a problem with purchasing an app on Azure Portal. Here are the steps that we take. We load the profile page of our app on the Azure Marketplace, then we click on the "Get It Now" button. We are redirected to the corresponding page for the app on Azure Portal. We then select one of the service plans and try to make a purchase by clicking on "Subscribe". This fails for us with a generic error message saying "Deployment failed".

    We have tried different service plan options and the same happened. We have also tried different Microsoft AD accounts. When we did that, the purchasing worked for 3 accounts and didn't work for 2 others. However, for one of the accounts that did work, the same kind of purchase attempt did not work the next day.

    Where are not sure why this happens and the error does not provide a great deal of specific information to understand what could be done to fix this. What we did manage to gather are data from the HTTP requests sent to the Microsoft servers when these attempts were made. Here is that which relates to one of the most relevant in our view requests:

    [URL]
    https://management.azure.com/providers/microsoft.saas/saasresources?api-version=2018-03-01-beta

    [Request headers]

    [POST data]
    {"Properties":{"PublisherId":"volumeltd","OfferId":"qbox_transact","SaasResourceName":"[REDACTED OUT]","SKUId":"startup","PaymentChannelType":"SubscriptionDelegated","TermId":"hjdtn7tfnxcy","PaymentChannelMetadata":{"AzureSubscriptionId":"[REDACTED OUT]"},"quantity":1}}

    [Response headers]
    access-control-allow-origin: *
    access-control-expose-headers: x-content-type-options,X-XSS-Protection,x-ms-version,x-ms-failure-cause,Date,Set-Cookie,Server,X-AspNet-Version,X-Powered-By,x-ms-ratelimit-remaining-tenant-writes,x-ms-request-id,x-ms-correlation-request-id,Connection,x-ms-routing-request-id,Content-Length
    cache-control: no-cache
    content-length: 104
    content-type: application/json; charset=utf-8
    date: Thu, 24 Oct 2019 15:18:18 GMT
    expires: -1
    pragma: no-cache
    server: Microsoft-IIS/10.0
    status: 502
    strict-transport-security: max-age=31536000; includeSubDomains
    x-aspnet-version: 4.0.30319
    x-content-type-options: nosniff
    x-ms-failure-cause: service
    x-ms-ratelimit-remaining-tenant-writes: 1199
    x-ms-version: 1.0.0.577 (AzureUX-MarketPlaceRP:master.1053fa5d.191013-0851)
    x-powered-by: ASP.NET
    x-xss-protection: 1; mode=block

    [Response data]
    {"error":{"code":"InternalServerError","message":"An invalid response code was detected.","details":[]}}

    [Other]
    Remote Address: 51.140.203.121:443

    We would appreciate it if anyone could offer ideas about where to look for potential causes.

    Thanks,

    Gus



    • Edited by Gus1969 Monday, October 28, 2019 10:59 AM
    Friday, October 25, 2019 3:24 PM

All replies