USB CDC Serial Emulation Driver Problems


  • Hello,

    We have a .INF file that works with XP x86 machines.  It uses the usbser.sys to do serial emulation over USB.  I added the amd64 sectionts to the .INF and it seemed like it would work for x64 machines.  It's also listed as a modem, if that helps.  However, now that I have the USB connected, I get 2 different types of responses, none of them successfull.

    Response type 1: USB Device Not Recognized: I get a note that the device has malfunctioned and it doesn't recognize it.  Windows then stops the device

    Response type 2: The device is recognized and the name of the device shows up, but windows 'can't start' the device, so it still doesn't work.


    Has this happened to anyone else.  Is there a trick.  Or does the usbsys no longer work in windows 7 64-bit?

    Wednesday, December 14, 2011 3:07 AM

All replies

  • the windows usb stack is much more strict on win7 than in XP. response 1 has nothing to do with CDC, it has to do with your device not enumerating properly at the bus level.
    d -- This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, December 14, 2011 6:42 AM
  • Can you go into more detail?  What kinds of things should it be doing that might have worked with XP but won't afterwards.  I don't know much about the code, so anything you could tell me would be helpful.
    Wednesday, December 14, 2011 5:10 PM
  • timing requirements are stricter, as is compliance to the usb spec.  for problem number one, it is not your driver that is causing the failure. it is the device itsefl
    d -- This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, December 14, 2011 5:33 PM
  • Here is some new information.  It works properly on an AMD64 laptop, but not an intel i7 64-bit processor.  Both running windows 7 64-bit.
    Wednesday, December 14, 2011 5:35 PM
  • To find out why your device is sometimes not recognized, you'll need to take and parse a USB ETW trace on Win7.  However, be aware that there may not be a software fix.

    The same tracing may also help you figure out why the device can't start in your second case.

    Friday, December 16, 2011 7:46 PM