Skip to main content

 none
Windows Vista - LAN working properly, but Vista says I'm not connected RRS feed

  • Question

  • I use the wireless adapter of my laptop to connect to my company's LAN everyday. Today, I decided to connect using my wired LAN instead. And my problem began: I can connect just fine, whether I use the wireless or the wired adapter. I can connect to Exchange, I can browse the Internet and use Skype and Messenger. It connects just fine and works flawlessly. Nonetheles, Windows says that I'm not connected. When I go to the Network and Sharing Center, it shows me no map and says "You're not currently connected to any networks".

    This wouldn't be a problem if I would just need to browse the Internet, but the fact is that I need to connect to a client's VPN. And since Windows reports that I'm not connected (though I am) it won't let me event try to connect to the VPN.

     

    The problem is, then, that I have no problem at all... ¡but Windows Vista thinks I do!

     

    Details:

    Soft: Windows Vista Business, SP1
    Hard: Dell Latitude D830, with a Broadcom NetXtrem 57XX Gigabit adapter and an Intel Wireless WiFi Link 4965AGN.

     

    I have all the required network-related services running and I always disable the Firewall service.

    Any ideas? Why would Windows use one system to connect and another diferent system to detect if I'm connected? How can Windows connect just fine and not be aware of that?

     

    Thanks to every clue you may provide.

    Wednesday, March 26, 2008 12:50 PM

All replies

  • I have this identical problem. I could have written it almost word for word as in the original post. It's happening through my wired connection. Just started happening, I've connected to the VPN successfully many times before.

     

    I'm using:

    Windows Vista Ultimate SP1

    Dell Vostro, BroadComm 440x 10/100

     

    Wednesday, April 2, 2008 3:40 AM
  • Same problem. Same hardware and software. Cannot connect VPN. Big problem.

    Thursday, April 3, 2008 1:37 PM
  • I have the same problem, and found a long thread about it.
    http://forums.techarena.in/windows-vista-network/986895.htm
    As you can see, there is no solution.
    The problem appears to interfere with VPN access also, which makes life quite difficult.
    It may be something to do with Vista SP1, but Microsoft have not addressed the issue.
    Monday, October 13, 2008 2:59 PM
  • This happened to my bosses boss while on a road trip...  Of course he just noticed it as his VPN not connecting any more.  This affects all network adapters.  I've tried resetting my winsock, system restore to a few weeks ago, updating bios, drivers, etc...  no luck.

     

    Running Vista Ultimate 32 SP1 on a Dell Latitude D630 fully loaded

     

    Made sure it wasn't a hardware issue by moving users HD over to an identicle dell that wasn't having the problem.  I've isolated and uninstalled all MS Vista and Office updates for the past month.  Removed all programs installed on the laptop to ensure something funky wasn't happening there.

     

    This problem would be fine BUT as the user can still access his network even though Vista says it's not connected the blasted VPN won't configure, in fact after setting up the VPN over and over, it tries to set the IP address as a phone number for a modem that I have disabled anyway.  Pretty nifty...

     

    I've migrated the user over to another laptop (Which is fully updated as well...) and the problem went away.  So I know it's not a hardware nor is it a profile issue nor is it a driver issue.

     

    I guess my bosses boss is right when he says he hates Vista with a passion...  Ya know, it's so hard to keep people happy with the products we buy from MS when issues don't get addressed or theyhave unexplained bugs that no amount of working with it will solve.

     

    Time to format the drive...  wish me luck!

     

    Sunday, January 11, 2009 10:00 PM
  • Could someone please help!!!!!!!!! I have the same problem and its ridiculously frustrating.  My Network and Sharing says I'm "Not Connected" but clearly I am as I'm posting here...

    I can use my browser, SmartFTP, iTunes store.. the list goes on.  I'm clearly connected, and have no problem with those programs.  People in various posts keep saying to just deal with it.  But since Vista thinks I'm not connected it leads to various problems.  Like the post above, I can't use VPN.  Exact same thing happens to me, it gets converted to a dialup connection for some reason and won't try to connect because it says a I have a network problem.  Various other annoyances have popped up (I can browse iTunes but I can't buy anything - it can't establish a secure connection with the iTunes app).

    If this is a such a widespread issue (google it - it is) - you'd think Microsoft would address it.

    CG

    Friday, March 6, 2009 11:44 PM
  • I also have this problem. Using Vista Home Premium edition. Additionally, I recently found that Windows Updater is not able to check for updates. I suspect the two issues are connected in some way. There are numerous threads on forums about the "unable to check for updates" problem, but no real solutions.

    Bill
    Sunday, April 5, 2009 1:29 AM
  • Count me in as another victim: I didn't develop this symptom until after installing Vista SP2, however. I can see and interact with all LAN resources, access the Internet just fine, and use RDP without difficulty. I certainly hope somebody comes up with a fix for this: it's quite galling!
    Another crazed Vista User,
    --Ed--
    Friday, May 29, 2009 6:56 PM
  • Count me in as another user with the same problem.  I can't connect to PPTP VPNs set up with the Microsoft client and have all they symptomps where Vista thinks I'm not connected to the Internet when I am.  It started happening to me about three or four weeks ago, just prior to when I installed SP2.

    Vista Enterprise SP2
    Dell Latitude D531 (Broadcom NetXtreme 57xx gigabit adapter, Dell wireless 1490 dual-band WLAN mini-card)

    • Proposed as answer by GuitarAlf Tuesday, October 20, 2009 3:14 PM
    Thursday, July 16, 2009 6:12 PM
  • Hi. Same problem for me. It seems to be caused by a required update from HP relating to network and usb issues. Once this installed, the problem seems to have corrected itself.

    Regards

    Sorry folks. Scrub this post. Problem is back.
    Tuesday, October 20, 2009 3:14 PM
  • I have the same problem.  I don't know exactly when it began, but the network and Sharing Center says I'm not connected to a network, yet I can browse, receive email, and see other systems on the network, including my WHS.

    I've searched everywhere but haven't found any good suggestions.  I've tried all the obvious.  I replaced my router.  I've uninstalled and reinstalled NIC drivers.  Checked all the relevant services.  Tried static IP. Tried all the auto troubleshooters.

    It's not critical, just annoying.  I'll be replacing this system shortly, which will probably fix the problem, but it would be nice to know what's going on in case I run into it again.

    Core i7 950 system
    Win 7 Ultimate 64 bit
    Gigabit LAN wired connection

    All other computers on the network work fine and generate accurate network map in the network/sharing center.
    Gary M Johnson
    • Proposed as answer by No_Regrets Tuesday, June 22, 2010 2:03 PM
    Thursday, November 12, 2009 5:31 AM
  • Gary:

    When I updated my system from Vista to Windows 7 RC the problem went away. I'm now running the final version of Win7 (Ultimate) and no longer have this problem: same hardware, same networking environment, but no "missing network." Is your Win7 system likewise afflicted? If so, first I've heard of this...

    Best wishes,
    --Ed--

    QX9650 X38 DDR 3 mobo
    Win 7 Ultimate 32-bit
    Gigabit LAN wired connections
    • Proposed as answer by No_Regrets Tuesday, June 22, 2010 2:03 PM
    Thursday, November 12, 2009 7:07 PM
  • Sorry for being equally unproductive but to the 11 people who posted above me here's a tip for you.  Don't clutter someone else's attempt at getting a problem solved by saying you have the same problem with various different software.  I mean seriously what should be common sense has seemed to escape you all.  What you should do is wait for an answer not give someone who may have a fix 11 other problems to handle at the same time.  One topic per question.  This should be cluttered with 11 different possible answers not 11 more questions.  How you think that someone will come to this Topic and answer the guy 5 posts down but no one else is beyond me.
    Tuesday, June 22, 2010 2:08 PM
  • Hi

    This problem occurs when people are connecting to a collection of Private Networks, Public Networks, Domain Networks, RADIUS Networks, without proper configuration to match each Network.

    If the variety of conncetions works and it only the Cosmetic part that bother you, then ignore it.

    However, if it does not working smoothly, or and the "Cosmetic" aspect is Not tolerable, it can be avoided by perdioticaly cleaning the Connetions and logging correctly to each Network.   3rd party connetion manger like this can help too.

    Example, http://www.netsetman.com/index.php?s=nsm


    :cool:

     


    Jack, MVP-Networking. EZLAN.NET
    Tuesday, June 22, 2010 6:52 PM