Microsoft Teredo Tunneling Adapter not working Code10 Win7


  • I too just discovered my Teredo Tunneling Adapter is now defunct.  Shows a code 10.  I run Windows 7 Ultimate. I have tried the reinstall and/or upgrade of new driver and it will not install successfully.  The "Fix It" routine only says it found there is a problem with the adapter, but there is no fix.  Troubleshooters unable to fix.  Device manager shows the "Warning" triangle.  Last I checked, this was working and I have been running Norton 360 for over a year.  I do know there were just recently 4 or 5 windows updates and I wonder how far back one has to roll the computer to catch whatever update may be the culprit - if indeed that is the problem.  Device manager does not show this as a 'psuedo interface', but the teredo tunneling adapter.  Suggestions to check with the manufacturer have me stumped since mine says Microsoft, yet i don't have $59 for customer service support for something I should be able to fix.  Since it is network related however, I am hesitant to troubleshoot beyond what instructions I have seen so far - I don't want to lose IPV4 AND IPV6 both!  Any advice is appreciated.  I am stumped and very, very frustrated.

    FWIW - ran every troubleshooter there is to determine if there were any related errors.  All report everything is well - except the teredo. 


    • Edited by BlueBoxBlonde Wednesday, September 29, 2010 6:45 PM spelling
    • Moved by Sheng Jiang 蒋晟MVP Sunday, July 20, 2014 5:59 AM Not dev related. Windows user forum is at
    Wednesday, September 29, 2010 6:43 PM

All replies

  • Try the Windows 7 forums on Microsoft Forums. It does not look like you need help in writing software.

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Wednesday, September 29, 2010 7:51 PM