Exception when trying to receive messages from remote computer private queue RRS feed

  • Question

  • I have 2 VMs, 1 VM is the 'central' MSMQ (server). The other VM (client) just has a Windows Service that tries to read / write messages to that queue.

    What happens is, when I try to receive messages from the remote MSMQ, I get an error "Cannot import transaction"

    I have MSMQ also installed on the client VM since it said to me prior an exception "Message Queueing is not installed on this machine". I have installed the MSMQ in domain mode (I have confirmed it by checking regedit).

    So is this due to a permissions issue? When I looked in Services, they are both using NETWORK SERVICE account, but I think just using the local account, as when I tried to browse for the NETWORK SERVICE from the domain directory (rather than local), it cannot find any user of that name. I tried using a domain admin account but I couldn't start the service after since it said the account did not have the proper permissions to start the service.

    Am I right to assume that its due to permissions issue? If so, should I create a dedicated service account? What permissions do I need to give it so that I can start the MSMQ?

    Thursday, May 30, 2019 3:04 PM