The requested operation could not be completed due to a file system limitation


  • Hi,

    I'm getting this error while dowbloaidng large files(7-8 GB): "The requested operation could not be completed due to a file system limitation". I have Vista premium and 40 GB free space on my notebook. I get the same error when I try to copy the file to another folder. I have googled a lot but have not found any solution.
    Need your help in resolving this issue.

    Tuesday, November 06, 2007 9:47 PM

All replies


    Hi vedvyas,



    I have also started receiving this exact same error.


    I am currently trying to copy a 12GB file across my network from a server to a desktop. The error that Filezilla is throwing up (copying via Windows Share's produced no error after 20mins.


    The Error reads: "can’t write to file descriptor 4 (error 665: the request operation could not be completed due to a file system limitation)".


    My Desktop stats are:


    Intel Core 2 Duo E6600

    4GB DDR2 RAM

    1 x 36GB WD Raptor

    1 x 500GB WD (Target Drive for the copy)


    Operating System: Windows Vista Ultimate - Service Pack 1 RC1


    No other error messages appear anywhere and the event log is empty of anything related to the file system.


    However, when I did do a chkdsk on the drive AFTER I received this error, chkdsk report that the drive was type RAW and could not continue.... Yet Windows was able to access the drive fine, via Windows Explorer and such (please note that the drive is indeed formatted NTFS) and after a reboot, chkdsk would work.


    Has anyone encountered this before or have a resolution?


    Unsure if it helps or not, but the file size is 12.6GB (Virtual Hard Disk .vhd file)




    Daniel Brown

    Monday, December 17, 2007 6:05 AM
  • Hi Daniel,

    Nice to see your detailed response. I was able to run chkdsk after booting in safe mode, though it did not help me. The system will schedule the chkdsk to run when you restart the comp next time. I did a system restore but still having the same problem. The last option is to fomat the disk and reinstall vista.....I am yet to try that.

    This thanks giving I bought a lenovo notebook with vista home premium. I was able to copy each of the problematic large files(8-13gb) on this system. That tells me something is wrong with my VIAO configuration. May be because I removed most of the *** programs that comes free with the notebook and unfortnatly, is also part of the recovery disk.

    Happy Christmas & Happy New Year,

    Tuesday, December 25, 2007 4:54 AM
  • I just got a similar problem with Windows 2008 RC1.  In a compressed folder, when writing more than 40 GB of data to a file, WriteFile() will fail with "The requested operation could not be completed due to a file system limitation" error, even though the volume still have plenty of free space.  Does anyone has any clue about the problem?


    Thursday, January 10, 2008 9:41 PM
  • This appears to be a bug in Vista and Windows 2008. If the number of allocated regions in a sparse or compressed file exceeds a threshold, the OS refuses to allocate additional regions. If the operations that will fail with ERROR_FILE_SYSTEM_LIMITATION were submitted with file buffering on (thus postponing this error until they are flushed) this can cause major issues including completely preventing the OS from writing to disk in any buffered file.


    It seems like sparse and compressed files should be avoided on Vista and Windows 2008 until this is fixed.

    Wednesday, February 20, 2008 7:42 PM
  • Thanks for the info, it does bring some light on the subject.


    However, Neither volume I copy from or copy to are compress.


    I'm not sure on sparse as I've never heard of it before. Is there away to disable this?





    Wednesday, February 20, 2008 11:01 PM
  • Guys, if you have the  file system limitation error, i think I have just overcome it by going into Bittorrent or Utorrent Preferences->Advanced->Dsik Cache->Disable caching both read and write as Windows has a limitation in Vista 08 (all editions I believe) that for some reason cus out the ability to cache and write past a certain size limit. I don't know how, why or when, but it works.

    Hope this helps
    Tuesday, August 05, 2008 2:14 PM
  • Worked for me once, but the torrent came corrupted, even after I make it recheck the hashes and redownload the corrupted parts. Then, when I redownloaded it, got the same problem with the caching disabled.

    I had a similar issue copying a 7GB ISO from my external HD to my HDD, when it went past 5,2 Gb or something like that, the copy crashed displaying a 'file destiny not found' error, and the file was really gone. But the file system did not crash, it registered as NTFS in chkdsk. I then disabled the caching in the HD configurations, on windows, then the copy worked (at awful 3,02 Mb/s).

    The weirdness is that I tested copying some 5,5 gb AVI and it worked perfectly with caching active. I recall copying 20~30gb uncompressed AVI files to my HD and it never crashed. Must be something specific to compressed files. Anyone has anything from Microsoft on this subject?

    (By the way, sorry if I brought the thread back from the dead, google found it for me and it was the most reliable one)

    Monday, October 13, 2008 8:05 PM
  • uTorrent 1.8.1 WS 2K8 with all service.  uTorrent configured as mentioned above. Problem persists.
    Tuesday, November 04, 2008 6:32 PM
  • This may help guys:

    Your HD may need deframentation.
    Friday, April 03, 2009 6:43 AM