Windows 7 Installation failed because of Error 0x80070017. Error Message: Windows cannot install required files, they may be corrupt or missing.


  • I recently burned the Windows 7 iso file to a dvd and attempted to use it to install windows 7. unfortunately in the process, it brought up this error: 0x80070017. Error Message: Windows cannot install required files, they may be corrupt or missing. I was wondering if anybody could help enlighten me on this situation, thank you.
    Monday, August 17, 2009 11:47 PM

All replies

  • IF you are using a DVD +R try a DVD -R and burn it at a slower speed say 2X or 3X. Also check your drive to make sure it is working properly. I had a bad DVD drive initially and replacing it solved my issue. Hope this helps.

    Hubble IT Guy
    • Proposed as answer by Russmcintire Friday, June 25, 2010 8:14 PM
    Tuesday, August 18, 2009 4:00 PM
  • I was plagued with this problem as well and wasted so many DVD's reburning the ISO at slower speeds on multiple PC's only to have the same results. Some people will suggest running from a USB stick to avoid potential problems with the DVD drive and increase intsall speeds. I tried doing this and had reformatted and partitioned my USB stick but was always unable to transfer one file install.wim which would never transfer no matter which PC I used.

    Finally I had the idea to try using a Mac to transfer the files since this computer will not recognize the file whatsoever and put no effort into identifying its purpose and simply move the file over. It worked like a charm and the install worked perfectly after that.

    The simplest way to overcome the 0x0070017 error and/or the missing install.wim file is to transfer the files over to to a USB stick, 4 GB should work. Just drag the files over from the Disc to the USB stick. Mac's can be found at many public libraries and virtually every college university, even community colleges. Just find a friend or make a connection so that you can transfer the files using a Mac.

    • Proposed as answer by Chris,,, Friday, February 11, 2011 9:59 AM
    Friday, February 11, 2011 9:58 AM
  • I had this problem when I was trying to install Windows 8 via a usb jump drive.  

    I was using Virtual Clonedrive and copying the install files from the jump drive from a downloaded .iso file.  

    I deleted the install.wim file from the "sources" directory on the thumb drive.  I opened a command prompt and used xcopy/j to copy the file from the virtual drive of the .iso file to the thumb drive.  Xcopy-help suggests using the "/j" switch when copying very large files.

    I tried the installation again and it worked great.

    If this works for you, please pass it on.


    • Proposed as answer by Andrew Westphal Thursday, February 02, 2012 7:45 AM
    Thursday, February 02, 2012 7:45 AM