none
Configuration Parser Error RRS feed

  • Question

  • Just installed Windows 7 on a box to test our app in the Windows 7 environment, when trying to launch the app I am seeing this error:

    Error parsing
    c:\Windows\Microsoft.NET\Framework\v2.0.50727\config\machine.config
    Parser returned error 0x80070005


    I am aware of the 'Troubleshoot compatibility' wizard when you right click on the executable, and it will run properly when I set it as a Windows XP SP2 app, but how do I get the app to run natively without having to run the compatibility wizard? Is there some option that has to be set before compiling the application?

    Cheers, Andrew

    Monday, November 9, 2009 4:40 PM

Answers

  • Hi Andrew,

     

    The error code 0x80070005 means “Access is denied” here.  Could you try to run the application as Administrator and tell me the testing result?  

     

    Besides, would you minding providing us with more detailed information about your application?  Which operation or which line of codes that raise the error?  

     

    Have a nice day!

     

     

    Best Regards,
    Lingzhi Sun


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, November 10, 2009 10:04 AM
    Moderator

All replies

  • Hi Andrew,

     

    The error code 0x80070005 means “Access is denied” here.  Could you try to run the application as Administrator and tell me the testing result?  

     

    Besides, would you minding providing us with more detailed information about your application?  Which operation or which line of codes that raise the error?  

     

    Have a nice day!

     

     

    Best Regards,
    Lingzhi Sun


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, November 10, 2009 10:04 AM
    Moderator
  • Hi Andrew,

     

    How is the problem now?   If you need any further assistance, please feel free to let me know.

     

     

    Have a nice day!

     

     

    Best Regards,
    Lingzhi Sun


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, November 19, 2009 2:14 AM
    Moderator
  • Hi - I think my information can help:

    I agree with Lingzhi Sun, the error deals with security as it tells 0x80070005 "Access is denied".
    A great tool that Windows 7 has is Problem Steps Recorder (PSR),
    which allows you to record and capture data and make screen dumps (Step-by-Step).

    With this feature developers will be able to very easy fix bugs and other application
    problems.

    You can use PSR and make some screen dumps and gen-data,
    paste it here so we can see it.

    Thanks...

    Read more here:
    http://technet.microsoft.com/en-us/windows/dd320286.aspx

    Have a nice day...

    Best regards,
    Fisnik
    Coder24.com
    Wednesday, December 9, 2009 10:21 AM
  • I ran into this problem after installing the Intel A03_R267591 multi device video driver on a Dell Latitude E5510.  This error only showed up when I was logged in on an account with administrator privileges.  If I was logged in as the 'Administrator' account, or as a standard user, the error did not occur.

    If you go to the \%root%\Windows\Microsoft.NET\Framework\v2.0.50727 directory and RC on the Config folder, then select Security, you will likely find out that the administrators group has no rights to the folder, and Users have Read & execute rights.  This is where the access denied error comes from.

    In order to fix this, you will need to log in using the default 'Administrator' account, navigate to the \..\V2.0.50727 directory, RC on the Config folder and select Properties, select the Security tab, click Advanced, select the Owner tab, and transfer ownership of the folder from 'Trusted Installer' to the 'Administrator' account.  Be sure to select the check box to include subfolders and files.  Then, close the Advanced window, and while still in the Security window, click Edit.  Add 'Administrator' to the list (if in a network, make sure you use the local machine instead of the network domain), and give the Administrator account Full Control.  Now click on the administrators group and give them Read & execute rights to the folder.  This should take care of the problem, or at least it used to work...more on this later.

    Now log back in on a user account with administrator privileges and ensure the error message no longer shows.  Be sure to disable the Administrator account again once you are done (for security purposes).

    As I mentioned, this USED to work.  As of this morning, after downloading the latest round of updates from Microsoft's website, I am now getting this error again, unable to parse the machine.config file.  I have checked the permissions and those are set as they should be to correct the problem.  I have tried uninstalling the A03 video driver, downloading a fresh version from Dell's website, and reinstalling, but I still have the problem.  the file \%root%\Windows\System32\GfxUI.exe seems to be having the issue.

    If you look at the GfxUI.exe file, under Properties\Compatability, there is an option to Run as Windows XP SP3.  This might fix the problem, but then disables the Aero interface.  I will continue to troubleshoot, but if any of you have run across this and have found a fix, please let me know.

     <<edited 12 Oct 10 - see my reply below for the resolution to the latest problem>>
    • Proposed as answer by MarkT94 Tuesday, October 12, 2010 7:57 PM
    • Edited by MarkT94 Tuesday, October 12, 2010 8:07 PM
    Tuesday, October 12, 2010 7:33 PM
  • I figured out the fix for the new issue I developed.  I am guessing that somewhere in the latest round of updates (published 12 Oct 10), Microsoft made changes to the way the GfxUI.exe file operatores, thus bringing back my parsing error on all accounts except the default Administrator account.  As this account has Full access to the \%root%\Windows\Microsoft.NET\Framework\v2.0.50727\Config folder, I gave the same level of access to the administrators group and to the users group.  The problem has gone away again....at least for now.  I will wait to see what Microsoft throws at me next.

    One thing I did discover in my trials, with just Read & execute permissions for the administrators and users accounts, if you go to the GfxUI.exe file and set it to Run as Administrator, you get a UAC pop-up when it runs under standard or administrative user accounts (not as Administrator).  If you use the credentials for any local administrator account, the file runs fine and generates no errors.  This tells me there is a problem with the way the GfxUI.exe file verifies permissions when parsing the machine.config file.  Thanks Microsoft/Dell/Intel.  Please fix this.  The need to allow full control to the Config folder likely opens up a security holw, although for the moment, this security issue is preferable to running the machine without a video driver or receiving that annoying error every time a user logs on.

    • Proposed as answer by MarkT94 Tuesday, October 12, 2010 8:06 PM
    Tuesday, October 12, 2010 8:06 PM
  • Just installed Windows 7 on a box to test our app in the Windows 7 environment, when trying to launch the app I am seeing this error:

    Error parsing
    c:\Windows\Microsoft.NET\Framework\v2.0.50727\config\machine.config
    Parser returned error 0x80070005


    I am aware of the 'Troubleshoot compatibility' wizard when you right click on the executable, and it will run properly when I set it as a Windows XP SP2 app, but how do I get the app to run natively without having to run the compatibility wizard? Is there some option that has to be set before


    choo
    Tuesday, November 9, 2010 12:37 AM
  • Here's how you fix it:

    Start-->My Computer-->C: Drive-->Windows-->Microsoft.NET-->Framework-->V2.0.50727-->Config

    Within the CONFIG file, Right-Click the 'machine' XML Conf file, go to Properties. Go to 'Security' -->'Edit'-->'Add'-->type in "EVERYONE' (this gives everyone on the computer permissions) after you add this, check the FULL CONTROL box under "Allow" and then APPLY, then OK. This fixes the problem.

    • Proposed as answer by kevakapob Wednesday, October 2, 2013 10:07 AM
    Wednesday, February 9, 2011 3:54 PM
  • I wouldn't suggest using EVERYONE/Full Control.

    This happened with some HP laptops (Probook 4525s) after uninstalling all the HP crapware.  Logged in as administrator, I did not get any errors, but as limited account user, I would.

     As an administrator, go to the machine.config file in the path specified.  During the uninstalls, the permissions on that file got messed up, and <localmachine>\users group did not have any permissions on the file.  Right-click the filename, go to security --> Advanced Security and check 'Include inheritable permissions from this object's parent'.  Apply to see changes (<localmachine>\users should now have read and execute permissions), then 'OK'.

    Monday, August 29, 2011 7:48 PM
  • I wouldn't suggest using EVERYONE/Full Control.

    This happened with some HP laptops (Probook 4525s) after uninstalling all the HP crapware.  Logged in as administrator, I did not get any errors, but as limited account user, I would.

     As an administrator, go to the machine.config file in the path specified.  During the uninstalls, the permissions on that file got messed up, and <localmachine>\users group did not have any permissions on the file.  Right-click the filename, go to security --> Advanced Security and check 'Include inheritable permissions from this object's parent'.  Apply to see changes (<localmachine>\users should now have read and execute permissions), then 'OK'.


    Applying inheritable permissions to the machine.config file did the trick for me on this error.  Thanks!
    Thursday, January 3, 2013 1:21 PM
  • Thanks this worked for me.  I just gave my self full control instead of everyone. 
    Thursday, November 21, 2013 2:57 PM
  • Better answer of all.... That solves the problem!!!
    Friday, July 31, 2015 9:15 PM
  • Hey Lingzhi

    Thanx, this helped for me!!

    Tuesday, March 14, 2017 8:31 AM
  • Hello Rybread

    Thanks a lot it worked like charm. Keep up the good work.

    Thursday, January 25, 2018 6:16 PM
  • Thanks buddy. It worked for me.
    Friday, January 31, 2020 2:42 PM
  • Thanks. It worked for me for two different laptops.

    Wednesday, February 12, 2020 9:08 PM