none
Using ICertRequest2 and Windows 8 RRS feed

  • Question

  • Hi all,

    we are using a self made application to request certificates for smartcard logon (OID 1.3.6.1.4.1.311.20.2.2).

    Using Windows XP or Windows 7 it works perfect, but when tried it with Windows 8 we always got '0x80090006'
    We are using the same ca with Windows XP, Windows 7 (64Bit) and Windows 8 (64Bit)

    We also tried this example:

    http://msdn.microsoft.com/en-us/library/windows/desktop/aa387670(v=vs.85).aspx

    But the output is 'Failed CoCreateInstance - pEnroll [80040154]'.

    Any ideas how to solve that?

    Thanks for Help
    Aendrew

    Friday, July 20, 2012 5:20 AM

All replies

  • The code from the link you supplied uses the XEnroll component via the ICEnroll4 interface. This component does not exist on Vista and up. This is why you may be seeing the failure to create an instance.

    Can you share a s small snippet of code that demonstrates the '0x80090006' error on Win8?

    Andrew

    Friday, July 20, 2012 5:27 PM
  • Sorry for my late answer.

    The source is very complex.

    At the moment i try to create a small snippet.

    Monday, July 23, 2012 4:55 PM