Skip to main content

 none
Lost "Access" to Azure Sphere RRS feed

  • Question

  • Hey,

    I own an Azure Sphere MT3620 Starter Kit and I have used it a couple of months ago, however, now once I want to use it again, for some reason I can't.

    Just tried to login with my used MS emails through the  Sphere Developer Console, however, it says I don't have any tenant, neither I can't migrate, as I have tried.

    The errors were:
    warn: You don't have access to any Azure Sphere tenants. warn: Type 'azsphere tenant create --name <name>' or, if you have used Azure Sphere before, type 'azsphere tenant migrate'. warn: No tenants found. Use 'azsphere login' to change AAD user, or create a new Azure Sphere tenant using 'azsphere tenant create'. error: You do not have access to any Azure Sphere tenants

    Other than that, I doesn't seems to have any Azure subscription though, it seems I have used the Trial option as well. Does the Sphere requires an active subscription, too? 

    If that's the case, at the moment, I can't afford, even if it's pay2go.

    Monday, November 11, 2019 1:52 PM

All replies

  • @sqpp

    Please use the below command and see it helps to resolve your issue.

    azsphere login --newuser <email-address>


    After successful login:

    i) If you have access to a single tenant, it will be selected by default, and you can proceed to the next step.

    ii) If you don't have access to any tenants, you'll need to create a tenant.

    iii) If you previously used Azure Sphere with the 19.09 SDK (or an earlier release), you might need to migrate a tenant.

    iv) If you have access to multiple tenants, you'll need to select one. See azsphere tenant select for details. 

    Please note that, The Azure Sphere public preview, version 19.10, is now available via the Retail feed. The 19.10 release includes a quality release of the OS along with a new Azure Sphere SDK that includes significant enhancements. The Azure Sphere 19.10 SDK introduces two important changes to user authentication and cloud management.

    Starting with this release, Azure Sphere supports role-based user authentication. This authentication method supports login with any Microsoft or work/school account and enables you to assign specific roles to individual users.

    Changes to cloud management make it easier to group your devices and to deploy applications.

    As a result of these changes, you'll be required to migrate your Azure Sphere tenant and users to a new authentication and cloud management environment. Migration is a one-time, irreversible action. This topic describes the changes to authentication and cloud management and provides guidance on how to plan your migration.

    For more details, please check the documentation and migrate your Azure Sphere Device to 19.10.

    P.S: Regarding your subscription query, please refer FAQ's for more details.

    Let us know if you need further help.

    Tuesday, November 12, 2019 10:42 AM
    Moderator
  • Hey,

    Unfortunely, my issue is a bit different, in case I wish to create a tenant or something

    azsphere tenant create --name marcell

    for example the command above.

    I get this error:

    error: Could not connect to an Azure Sphere device. Please check the device is correctly connected.
    error: An attached device is needed to create a new Azure Sphere tenant. This device must not have been used for this purpose before. Please connect a device and execute the command again.

    Wednesday, November 13, 2019 12:09 AM
  • Okay, I was able to fix it, now I just can't create a new tenant, it just throws this error

    F:\Documents>azsphere tenant create --name marcell
    warn: You have logged in with the following account:
    warn: sqpp15@gmail.com (6ae5d51e-6924-4787-b6c7-46a06c6dc451)
    warn: Do you want to use this account to create a new Azure Sphere tenant using the attached device?
    warn: Enter 'yes' to continue. Enter anything else to exit.
    > yes
    error: Failed to create an Azure Sphere tenant with name 'marcell'.
    error: Trace ID: 84b38f7c-919f-4b87-b4ff-6c20636c5546

    Wednesday, November 13, 2019 1:07 AM
  • Just to confirm, Have you updated the SDK to 19.10 version? 
    As per the error, it appears to the that device is not connected correctly.

    Ensure that device is connected, connected to Wifi and updated to 19.10. 

    Please review the documentation to create a tenant.

    Thursday, November 14, 2019 12:02 PM
    Moderator
  • Yes, it is the latest, I have checked in the Developer Commandline.

    It also connected just fine, as seems it reacts to all the check commands, before it had issues, but now it works, also the error doesn't say anything regards the conneciton, it seems to be a different issue.

    Thursday, November 14, 2019 1:56 PM
  • BroHosting

    Currently the tenant creation is a one time operation for a device. Once the device has been used to create a tenant you won't be able to do this again. 

    Have you or someone else created a tenant before with this device? If the answer is yes, you just need to login to the right account and then list the tenants under the account by using 

    azsphere tenant list 

     

    If the answer is no, can you please file a support request @ https://aka.ms/azsupt? If you do not have access to a support plan, please reach out @ AZCommunity@microsoft.com with a link to this Doc/Issue as well as your subscription ID and we can help get the support ticket opened for this issue.

     
    Thursday, November 14, 2019 8:32 PM
    Owner
  • Hi sqpp


    Does the Sphere requires an active subscription, too? 

    Short answer is No. You can use a Microsoft account that is not an Azure Account: To use Azure Sphere, you must have a Microsoft account. see One account for all things Microsoft

    With that said. It sounds like you already used this device and that you claimed it with an Azure account? A device can be claimed only once. Once claimed, the device is permanently associated with the Azure Sphere tenant and the tenant lives in the
    Microsoft account, so you need to login and search for this device's tenant in the same Microsoft account that you originally used for tenant creation, otherwise you can't see it.

    Thursday, November 14, 2019 9:14 PM
    Owner
  • Hey,

    Yes, I have claimed and I am aware of the situation, but the point is, I have two Microsoft accounts only and neither of them had the tenant, I have no idea what happened.

    The only thing I think might affected it, was that I have cancelled my subscription a while ago.

    Other than that, I don't think anything else happened.
    Friday, November 15, 2019 10:30 PM
  • @BroHosting

    This would require further troubleshooting to find out the root cause. Please send an email @ AZCommunity@microsoft.com with a link to this Doc/Issue we can help get the support ticket opened for this issue.

    Wednesday, November 20, 2019 5:41 PM
    Moderator