Windows Dev Center

WDS Fatal Error


  • Whenever my machine is actively indexing my machine i get

    "Fatal error"

    "DBX CAS 4"

    i click ok and it keeps indexing but this box will also keep popping up. Any ideas?


    Thursday, November 02, 2006 8:06 PM


All replies

  • Mike,

    Could you provide a bit more information? 

    What OS are you using?  What version of WDS are you using?  What other additional applications are installed (especially any CAD programs)? 

    Thanks for the additional info,

    Paul Nystrom - MSFT

    Monday, November 06, 2006 11:37 PM
  • Windows XP SP2, WDS version 02.06.5000.5378, We are using Autodesk Building Systems 2007 SP1



    Tuesday, November 07, 2006 1:05 PM
  • Mike,

    You're probably wondering how I guessed that you were using a CAD program eh?  The DBX CAS 4 problem is fairly common among Autodesk products.  Here are a few forums that discuss the issue:

    You might also try a search on the Autodesk forum: 

    Unfortunately, that's the extent of my knowledge regarding Autodesk.  I don't know that I'll be able to help beyond what's above.

    Paul Nystrom - MSFT

    Tuesday, November 07, 2006 9:05 PM
  • Just as an FYI when i close WDS i do not get this error. My cad propgram runs perfectly even when WDS is loaded.



    Wednesday, November 08, 2006 1:13 PM
  • I'm getting this anytime I search with Windows Explorer.......................I had WDS installed but didn't like how it worked so I uninstalled it.........................can't say for sure it the DBX CAS4 error was happening before WDS but I don't think so. 


    I'm running AutoCAD Map 2007.


    Any new info?


    Monday, May 21, 2007 8:27 PM
  • I do not get this error anymore. I do not remember what i did to make it go away, we just got a couple of new machines. We are now running Windows XP Pro x64 and AutoCAD MEP 2008 with no issues in regards to WDS.
    Tuesday, May 22, 2007 12:24 PM
  • We just started getting this error on an a spare machine with AutoCAD 2006, which also runs AutoDesk Vault.  No one uses the CAD software, just the Vault across the network connection.


    It only occurs when we are backing up files, and we do occasionally the previously cited Indexer Service errors.  The same messages also occur on the machines that are connecting to the suspect PC when backup are performed, or just sometimes copying with Windows Explorer.




    Tuesday, July 15, 2008 6:04 PM
  • Follow up.  Related fix on the AutoDesk web site.  Here's another diagnosis


    Error DBX CAS 4
    (or DBX CAS 0, DBX CAS 6)
    DBX error-types are reported by the ObjectDBX library. They often come from 3rd party add-on applications, especially from LT applications.

    Always apply tha latest Service Packs for your Autodesk CAD application (and possibly also for the add-on). This error can be also caused by a HW problem or collision with another running application or driver.
    Author: CAD Forum -






    CURED!  I think.


    The suspect PC was no longer able to connect to the internet.  Our cable provider had changed the DNS IP address at the remote site.  Email and other stuff still worked because that software did not need name resolution. 


    Once we corrected the DNS address, the problem has not reappeared.  Just got a call from my tech at the remote site, who was checking up on the address change he performed yesterday.  He reported no errors over the last 24 hours.



    Tuesday, July 15, 2008 6:16 PM
  • Hello Does any body know the answer or no its all junk kept here and there redirecting to the same scrap links with out any info...  can any one pls provide the solution.

    I am using windows XP sp2, with Autocad 2007 in it and keep on getting this error all the time.

    many thanks in advance.

    Tuesday, October 05, 2010 7:47 PM