Skip to main content


  • Question

  • I think I'm having the same problem as every one else, But this is a map program that wil give a 3D image of the lay of the land. I'll try the manufacturer, sounds like a shot. Microsoft should have a fix, but they didn't break it. It's not thier problem that what they used to supply is now, not needed by them. Who cares if you need it they don't, and it should be supplied by the software in question. Make a patch and make it happen!


    Maybe I should have bought a MAC!

    Sunday, April 22, 2007 5:04 PM

All replies

  • This Windows Vista system is driving me nuts.  I'm sooooo tired of compatibility issues.  Anyway - I just bought a game - Crime Stores from the Files of Martin Mystere and of course if won't play.  Indicates it need d3drm.dll.  Which from what I can find online was something Microsoft  (MS)  removed from Vista.  So I found it on the net and installed - game still won't play.  I've spent hours on the MS so-called support/help pages and read through so many messages I can't see straight any more.  AND I'M NOT PAYING $59 TO EMAIL, CHAT OR PHONE SOMEONE AT MS.  That is outrageous!  To bring this long, sad story to an end  - I STILL CAN'T PLAY MY GAME!  As you say - can't they just fix it or tell us how to get d3drm.dll back. 

    Saturday, September 15, 2007 12:39 AM
  • Hi there,

    I know vista drive all of us crazy sometimes, but this time i've actually find the way on how to fix D3DRM.DLL on vista system dowload the file from hundreds of provider and then install the file on c:\windows\system32 folder on your computer and that,s all is done and you can start to play games on vista. 

    Sunday, September 16, 2007 8:45 PM
  • Please please please, help. how can I re-install this item??????????
    I am going insane with the backwards and forwards,
    Many thanks.
    Monday, October 15, 2007 11:23 AM
  • Is this lost forever?  Has a solution been found by anyone?  I have read multiple forums and tried multiple different ways to install EQ, all have failed.  The bottom line is..... I need d3drm.dll.  please advise



    Sunday, October 21, 2007 10:12 AM
  • hey guys, i was having the same problem with the d3drm.dll program on my new notebook as well. when i downloaded the file to C:windows/system32 though it did not work....i had to download the program from an older computer to a flashdrive then download that onto my my games work fine....hope this was your problem too

    Friday, October 26, 2007 3:41 PM
  • Place the D3DRM.DLL file in the same folder as the Game EXE file.. or try placing it with other files that the Game uses.. I got this to work for me... Good Luck.




    Wednesday, November 7, 2007 10:48 AM
  • Copied DLL to windows system32 and worked. Now I can play my games thanx!!! No thanks to windows vista!!!!

    Saturday, December 1, 2007 5:31 PM
  • arrrrrrggggghhhhh!you two! boy oh boy i guess windows Vista(r) disincludes things like hlp32.dll and also my favBig Smile3drm.dll i need a solution plz someone i just downloaded motocross madness 2 and 1 but the same problem: d3drm.dll i needed plz someone help!!!!!!!!!!! 


    Thursday, December 27, 2007 2:01 AM
  • Just so you guys know, there is a website that has like all of the .dll software. Here is the link for d3drm.dll:




    When you start, just download it to the desktop (this is what I did), then open my computer, and type

    C:\Windows\System32, and press enter. The screen may display a different address, that is ok. If you are in the right place, if you scrol down a little you should see several other files ending in .dll. If you do, then just drag and drop the file you just downloaded onto the desktop anywhere in this folder. Now try the game.

    Sunday, January 20, 2008 2:35 AM
  • It probally is old problem solved already. But, if you still have the problem, may be this will help.

    1.  Make sure you do have the d3drm file downloaded to your computer.

     2.  Bring up that file to the desktop, right click on the file, choose Copy

     3.  Bring up System32 .( If you don`t know how to do that --   click Start button. In the Search box type   system32. It will appear at the top. Click that and system32 is staring at you.

      4. Curser on the system , right click , choose Paste. You should be in. You should see the d3drm.dll file inside the system Highlighted.( If you don`t , you have another problem )

     Good luck !  ( The method mentioned , Copy and Paste , can be used on almost any file to almost anywhere. )


    Friday, February 8, 2008 6:24 PM
  • I copied d3drm.dll into the same directory that my game installed into and I now get past the intro.  However, after I select the players, the game errors when it starts to run.  I am trying to run Boggle by Hasbro Interactive.  It is about 10 yrs. old, but it runs fine on an XP machine.  I think there is still a directX issue.  If I copy all the directX files from the cd into the game directory, I get the error "The procedure entry point MapLS could not be located in the dynamic link library KERNEL32.dll."  The most frustrating thin is that Scrabble and Clue! work and they are also from Hasbro Interactive and the same age.


    Saturday, February 9, 2008 6:15 PM
  • Geolll, from what I know, your game was installed into a directory named   Control Panel\Programs\Programs and Features .  Your d3drm file is supposed to be installed into   System32  directory. not the same directory. Please read the reply I wrote above yours.  You ARE using Windows Vista op. system , yes?


    Saturday, February 9, 2008 9:39 PM
  • I did what you suggested. But the game won't start (Obscura). The screen flickers a bit, then turns black and I end up with the desktop again. Can you help?


    Friday, February 22, 2008 10:12 PM
  • I tried copying to System32 but that didn't work.


    On 64bit Vista at least, copying it to C:\Windows\SysWOW64 was where I needed to put the .dll.


    For anyone that tried the first suggestion and didn't have success, you may want to try that.

    • Proposed as answer by Rennhack Friday, June 17, 2011 7:48 PM
    Sunday, February 24, 2008 7:35 PM
  • That worked for me!!! I was forever trying to play EQ and I wasn't able to, but now I put the d3drm.dll on the Sys32 folder and the game ran fine!

    Tuesday, May 13, 2008 2:18 AM
  • Hello,


    Had the same issue.  Unable to play certain games on Vista 64. 

    Error message:  Cannot find the file d3drm.dll


    Discovered this DirectX file d3drm.dll has been deprecated in Vista. 

    Download the file from the following link:


    If using vista 32bit ( x86 ) place the file in the following path:  C:/windows/system32

    If using vista 64bit (x64) place the file in the following path:  C:/windows/sysWOW64


    Should resolve the issue, although there are other deprecated DirectX files as well.

    NOTE:  This means of adding the required dll is not supported by microsoft.  dll files are only licensed when installed by an appropriate redistributle.




    • Proposed as answer by Rennhack Friday, June 17, 2011 7:49 PM
    Thursday, July 24, 2008 9:19 PM
  • This is BRILLIANT!  I've been holding off on going to Vista because I still use Microsoft PhotoDraw v2 and I heard horror stories.  Well, using 64bit home premium it worked...but not 3D.  The solution in this thread solved the 3D issue!  PhotoDraw DOES work with vista now.  The only problem is you cannot see 'previews' as you view your .mix files in a folder like you did in XP...oh well.


    Wednesday, August 13, 2008 2:35 AM
  • i have a problem which you have mentioned in point (4)........i cant see the file in the system,


    what do i do?







    please reply asap as i have a driving test in a week and need this cd to work


    kind regards


    Sunday, August 17, 2008 12:27 AM
  • Hi! If you're running Vista 32-bit, there is a solution. 

    1. Firstly, click here and download the file.
    2. Once downloaded, put it in the Windows Folder, in your computer.
    3. Run your map program and see if it works.

    Not many people know this yet, so tell your friends! 
    Sunday, September 21, 2008 4:23 PM
  • Hello. i am going slowly insane. If anyone can tell me why my DARKbasic/DARKmatter CD that just came with my how to book is asking for D3drm.dll, and i have been trouble shooting it for close to five hours, and it STILL hates me, isn't working, you will be my best friend. thank you.


    Friday, October 17, 2008 3:19 AM
  • Thank you, my 3d home Architect program is now working. Compared to newer programs I like the way the old one works better. it is easier to create spacial relationships. And even children can create drawings in minutes.

    Thanks again.


    Thursday, November 6, 2008 4:08 PM
  • I am trying to get a game called F1 manager working on my new laptop. I have the same error everyone else seems to be getting. I have followed your instructions but the game still will not work, it just loads the frontscreen and freezes.

    I also have an old game I used to love called 'Star Trek : Birth of the Federation' but that doesn't work either, no error message comes up but it does the game, freezes on the load up screen, any suggestion will be most gratefully recieved.
    Monday, April 6, 2009 2:13 PM
  • Got F1 manager working, thanks for the help.

    Birth of the federation will not work still though. Just checked it on some old systems in my mates shop and it only works on 98 second edition, it doesn't even work on XP. Any suggestions anyone?
    • Proposed as answer by birdman86 Monday, May 25, 2009 4:10 PM
    Monday, April 6, 2009 2:51 PM
  • Thank you all guys! It works for me just fine! Love my new 3D Screensaver!
    Thursday, April 9, 2009 11:03 PM
  • hey how did u get f1 manager working, i have tried all of the above solutions but it will now only opens to the ea sports first page then says its stopped working, please help?
    Monday, May 25, 2009 4:12 PM
  • I tried this but Ulead Dvd Movie Factory 3 still won't work. Must be something else missing.

    Strange but positive side effect, my machine seems a bit faster. Not sure if or how this is possible. Need to do more testing.

    Friday, July 3, 2009 1:07 PM
  • Hey there,  I ran into this as well.  Here's the other Direct3D dlls you might be missing as well: d3dx9_32.dll and d3dx9_30.dll   There's a download of d3drm.dll here as well
    Monday, July 6, 2009 7:57 PM
  • hey umm i was wondering if you could help me i was trying to play a game that i downloaded on my windows vista hp laptop and a message popped up saying that i needed d3drm.ll but when i downloaded d3drm.ll it said that "this file does not have a program associated with it  for preforming this action. Create an association in the set associations control panel." so i was hoping that you could tell me how to create an association.
    thank you
    Friday, August 7, 2009 12:21 AM
  • i had this exact problem; but with windows 7--somehow i'd figured it out for Vista (i think the d3drm.dll--->system32 folder)...

    but then when installed to 7 i had the exact issue you described...  i looked at the error report and the issue was with mcicda.dll--so, i googled it, found one and switched it w/the one in sys32.  (you can take control w/this file w/winbubble--google it.)

    this fixed the problem!  and made my wife happy!
    Sunday, October 25, 2009 2:12 PM
  • Thanks Swarms! That's what worked for me, here's what I did.

    I'm running Windows 7 on a laptop by the way

    1. Put in the disc of the program ypu're trying to run
    2. Go to Computer, right click on the disc in the DVD drive, and press Open
    3. There was a folder called DirectX6 that contained files for DirectX for me, open that folder; otherwise find the D3DRM.DLL file online
    4. Find the D3DRM.DLL file, copy, and paste to C/Windows/SysWOW64

    The biggest thing here is that it worked for me putting the file in the SysWOW64 folder, not System32

    I tried opening the program, and it worked!

    I'm sure if your disc doesn't have a DirectX folder, or contains D3DRM.DLL, you can probably download it and it will work the same way.

    Tuesday, January 26, 2010 6:18 PM

    Thankyou so much kingsapo i did everything you said and my flight simulator works perfect, THANKS again!!!!

    Tuesday, April 6, 2010 1:34 PM
  • We had a similar issue and solved it by copying the appropriate *.dll file found on the games CD into C://Windows/system32 directory. we laughed when it worked, was pretty unexpected. email me at for any further assistance
    • Proposed as answer by RandL Sunday, September 5, 2010 5:11 AM
    Sunday, September 5, 2010 5:11 AM
  • Quick and simple, all three possibles can work. However the dll file is found, as long as the file found is not corrupt or changed by third parties.

    It depends a little on how the program is built as to whether putting it in the root folder with the executable will work or not. Some programs will actually search their own folder first before looking into the path. If you want it to be available for other programs that might use the same file somewhere down the line use the other two methods depending on your system. Not all programs will be written in such a manner that the search will happen in the root first so that one is a hit and miss solution.

    If using the 32 bit version of windows vista or 7 it should be placed in the system32 folder.

    If using the 64 bit version it will need to go into the sysWOW64 folder.

    Be certain that the security setting are including inheritable permissions so that all users have access to it.

    Wednesday, September 8, 2010 9:41 AM
  • no sillyness or guessing where to click. Just download d3drm.dll from my site and place in c:\windows\system32 here: - IT Consulting. Providing IT services to SF Bay Area and Abroad.
    Saturday, April 23, 2011 4:03 AM
  • Thanks!

    I experienced this problem after installing a new game on my system running Windows 7.  I chose to download d3drm.dll from Bill Speers, below, then pasted it in both folders mentioned to make it available to 32 and 64 bit programs.  The program started right up (I just need to check back with the publisher to find out how to start the game, now.  Its styled as a cabinet arcade game and keeps playing the intro screens while prompting me to "INSERT COIN").

    Tuesday, August 13, 2013 5:10 PM