Ad Hoc Wireless Connection problem (I don't have Internet Access)


  • Hi to all..

    I don't have Internet Access (Ad Hoc Wirelles Connection) i have only local Access..
    With windows xp with the same configuration i don't have problems..
    My config is...

    My network:

    ADSL Router (Speedtouch 510) (Vista recognizes as internet gateway device )

    My Personal Computer includes : 1 lan with cord (Wired to:ADSL Router) & a wifi card (Wireless to: Laptop)

    My Laptop (Wireless to: Personal Computer via wifi card )

    My goal:

    Connecting the laptop to the rest of the network and internet via my perconal computer wireless card .

    My settings:

    Standard ad hoc (peer to peer) connection.

    Wep shared with key

    Establish Connection to my Wireless Network

    I can ping and i have ONLY local access

    I have enable internet sharing to my adsl router and local network

    I have make private my network

    Snapshot with my Network and Sharing Center

    My problem:

    I have only Local access but i don' t have internet access at all in my laptop ..

    Any idea how i can solve my problem

    Please help me
    Wednesday, November 15, 2006 6:12 PM

All replies

  • Try the TechNet forums at This forum is for Vista development topics.
    Wednesday, November 15, 2006 11:43 PM
  • i'm sorry ..
    Thursday, November 16, 2006 6:42 PM
  • I have the same issue.  The same computer was working fine on the network prior to the Vista installation.

    I put Vista on and now only have local internet access.  I reset the adapter and rebooted my gateway and it worked...but after each reboot, I only have local access.

    I'm looking for the solution, because now the reboot of the router and the card aren't working.

    Monday, January 01, 2007 11:51 PM
  • Has anyone found a solution to this? I am having the same problem and there does not apprear to be a clear remedy.

    Any help is greatly appreciated.


    Friday, September 28, 2007 3:01 PM
  • Hi

    The problem is that Vista is using the new IPv6 protocol, the replacement of the older tcp/ip protocol.
    So you need to add this protocol to be able to share the services.
    Go to the host computer (xp)
    And go to
    --> properties of your wireless connection
    --> Add protocol
    --> Microsoft TCP/IP v6.
    Sharing and internet should work now.

    Also see this post for ref.

    good luck

    Sunday, November 11, 2007 11:18 AM
  • So i had the problem but i worked out a solution with first making the wired connection and wireless connection working seperately


    Go to the manage network connections and see that none of the two wireless or wired adapter is being shared


    then select both these and rightclick and select bridge connections


    Your internet will start to work on your laptop


    but  onemore advice set the ip of the network wireless adapter in desktop pc as bridging) and let the it be automatic in your laptop. this will connect the network fast.



    I have successfully ran internet on my laptop with this way but i cant see on laptop the files that i have shared on my desktop pc    but i can access my laptop shared files on desktop easily  (i m working on this, this isnt a big problem as this has occurred to me while connecting vista and xp via wire)



    Well before applying the above procedures make sure you havent made and abnormal changes regarding your wireless adapter settings if you have done make them to defaults


    And if this wont work try to turn off firewall on both the computers (widows firewall + external e.g mcafee)


    Note my scenario is like this


    Desktop Pc = XP = Connected to internet via broadband router + ethernet modem (both in one)

    laptop = vista = connected to desktop via ad-hoc wireless connection
    Monday, May 12, 2008 12:26 PM

    hello, I get this question all the time at work, ICS is the problem not solution


    ok setup your ad hoc and your internet as 2 seperate connections when you can see the other computers or ping them go to your server computer(desktop) take ICS(internet connection sharing) off all connections (untick were it says allow other users to share this internet connection.


    now highlight both connections wireless and modem and bridge connections after a minute or so the connections will be bridged


    now go back to your client(laptop) and set the IP to auto


    dlllliiiing should work now


    I know its stupid that you need to specify IP to make the initial connection and that if you did it on your eithernet card it would probably d/c but that is the opperating system we choose to use.


    aslong as there are no specified IP's after you successfully bridge you will have no problems

    Monday, June 30, 2008 10:47 AM
  • I have similar problem. I am trying to share the internet connection of a laptop with another laptop and a wireless device, but even though the ad-hoc network I create is recognised by the both the laptop and the other device, none of them can successfully connect to it. I am connecting to the Internet with a wireless 3 USB modem, and that may perhaps be part of the problem. I was trying to bridge the ad-hoc wireless network with the "remote connection" USB Modem, but that was not allowed. I can only bridge the wireless network with a LAN connection, and I don't have any LAN connected since I use a wireless USB modem.

    I have allowed ICS for first the USB modem, but also for the wireless network, with no success. It is unlikely to be a firewall issue, because I have tried disabling all firewalls, and I also replaced my previous firewall application. The problem is still the same. Furthermore, I tried both WEP and WPA2 Personal as encryption types, none made a difference, and it seems it wasn't a problem of encryption because I could not connect the other devices even without encryption altogether.

    In order to connect to an ad-hoc network, regardless of the Internet Connection Sharing, is there any need for specific IP address or subnet masks etcetera for the client computer? It seems I cannot connect to the host regardless of whether the Internet can be connected or not.

    Any ideas are appreciated.
    Saturday, August 09, 2008 11:31 PM
  • I have the same problem. It really makes me want to go back to XP.
    I have an internet connection on my computer and i can't share that connection to my laptop using ad-hoc.
    All I can establish is a local area connection. A asked for solutions and nothing worked.
    ICS + Ad-hoc + Vista = failure. And I see that even microsoft support can't help!
    Sunday, August 17, 2008 9:23 AM
  • Connect an ethernet cable to your modem


    Oh Seriousely Every one loves there ICS(internet connection sharing) .... IT IS YOUR PROBLEM.


    I get this every day like 20 times a day its extremely simple, If you can create an AD-HOC and you have Local connection your done you did the rite thing it is all working 100% you have just not changed your settings back ok.


    Verry Simple Highlight your Ad-hoc and Your internet or ethernet connection BOTH at the same time right click with your mouse go Bridge connections


    it will say turn off internet connection sharing before you can bridge so do!


    Make sure all the IP config's are set to Auto no IP's should be specified and make sure ICS is off


    every one thinks ICS is the solution it only causes further problems.


    also Grzesiek Sw if you read my post's on practically any Microsoft forum or rang us we would have sorted your problem out in less than 1/10th of a second.


    The reason you have these problems is because Ad-hoc is meant to be temporary and it had been made apparent prior to Vista that AD-HOC Servers were being used as a permanent solution for network issues.


    Vista has been modified purposely to prevent this as you will need to Connect to the AD-HOC eveytime you reboot.


    you are not alone I get this exact question all day every day Thank you for choosing microsoft.

    Thursday, September 18, 2008 6:07 AM
  • You da man pollymorphic, that totally worked for me.
    Thursday, April 02, 2009 5:22 AM
  • Having the exact same problem and yea, the ICS seems to be the problem, I can get it working in ad-hoc only if I create a new ad-hoc everytime. Otherwise the connection works just fine.

    The problem with bridging is that I can't seem to bridge my wlan and internet-access which is PPPoE connection.
    Wednesday, July 29, 2009 6:03 AM