none
Desktop Window Manager causing ASIO audio dropouts on hybrid graphics systems RRS feed

  • Question

  • Hi,

    I have had nothing but problems for several months trying to get professional USB audio interfaces (I tested RME Babyface Pro, Focusrite Scarlett 2i2 2nd Gen, NI Komplete Audio 6) working at low latencies on my Windows 10 laptop with Intel Core i7-7700HQ CPU and hybrid graphics (Intel HD Graphics 630 + NVIDIA GeForce GTX 1050 Ti). I opened a Feedback Hub issue here and there has been no response for a month: https://aka.ms/P1qbak.

    It seems that any 3D graphics activity on the Intel GPU causes audio dropouts to occur on my USB audio interface. I tested this using following steps on my laptop with hybrid graphics:

    1. Install and run Ableton Live 10 trial (www.ableton.com)
    2. Configure Live to use ASIO driver, 44100 Hz, 64 samples buffer size
    3. Open demo song located at C:\ProgramData\Ableton\Live 10 Trial\Resources\Core Library\Lessons\Demo Songs\Live 10 Suite Demo Song.als
    4. Enable loop switch in Live
    5. Press Play
    6. Install Blender (www.blender.org)
    7. Right-click Blender in Start Menu > Run with graphics processor > Integrated graphics
    8. Left-click on startup splash to close it. Middle-click drag and move quickly to rotate 3D view around and put load on the GPU
    9. Notice there are massive audio dropouts while rotating the 3D view
    10. Close Blender
    11. Right-click Blender in Start Menu > Run with graphics processor >  High-performance NVIDIA processor (Default)
    12. Left-click on startup splash to close it. Middle-click drag and move quickly to rotate 3D view around and put load on the GPU
    13. Notice there are no longer massive audio dropouts while rotating the 3D view
    14. But notice you can also still get audio dropouts if you have multiple windows open and you do press Win+Tab several times or doing other things like snapping Windows side-by-side. This is because the following processes always use the Intel GPU for 3D - "System", "Client Server Runtime Process" and "Desktop Window Manager" as shown by the GPU Engine column of Processes tab in Task Manager. There is no way to get the Desktop Window Manager and all the other processes to do 3D rendering on the NVIDIA GPU instead of the Intel GPU. NVIDIA Control Panel has Preferred Graphics Processor grayed out when you try to add dwm.exe. I even tried Windows 10 RS4 Build 17101 which has "Graphics performance preference" - adding dwm.exe there, setting to the high performance and restarting the computer had no effect - it still used GPU 0 which is Intel GPU as shown in Task Manager.

    Please provide the ability to move all processes (even dwm.exe and Windows system processes) to use the NVIDIA GPU and have the NVIDIA graphics output copy to the Intel GPU to send to monitor. I can't work properly with all this audio crackling when the Intel GPU is being used - I tried every single version of the Intel graphics driver on the Intel website on a clean install of Windows 10 and it always gave the same problem.

    Thanks.

    Regards,
    Jonathan

    Monday, February 19, 2018 11:12 AM

All replies

  • Thanks for filing the problem report in Feedback Hub. Can you add "audio glitches" logs of the problem in action and then ping me at (mateer at microsoft dot com)?

    https://blogs.msdn.microsoft.com/matthew_van_eerde/2016/09/30/adding-logs-to-a-reported-problem-in-feedback-hub/

    If you can get the problem to repro in WASAPI, we have in-the-moment glitch logs which would simplify analysis.


    Matthew van Eerde

    Monday, February 19, 2018 3:45 PM
    Moderator
  • Thanks for sending the trace. Since you're using ASIO instead of WASAPI, we don't have in-the-moment glitch logging, so it is difficult to analyze.

    Please take a second trace using the steps here - https://blogs.msdn.microsoft.com/matthew_van_eerde/2017/01/09/collecting-audio-logs-the-old-fashioned-way/

    This has some improvements that haven't made their way into the Feedback Hub yet.


    Matthew van Eerde

    Tuesday, February 20, 2018 5:06 PM
    Moderator
  • Hi,

    64 samples is a pretty small buffer size.  Do you need to go that low?

    Also, ASIO runs in the context of the calling process so you could try increasing the priority of that process in Task Manager (may destabilise your system, blah blah).  Bit of a long shot though, that.

    Also maybe complain to Intel.  Could be their bug.  I can't see Microsoft ever using the driver for one graphics chip to talk to another.


    Paul Sanders

    Tuesday, May 8, 2018 7:58 AM
  • I Have the same issue. ill try to test disable the integrated graphics by bios and try if this work for me. this is so weird.
    Saturday, April 20, 2019 5:59 PM