Skip to main content

 none
Azure Site Recovery Network Issues RRS feed

  • Question

  • Hello Everyone,

        I am using the evaluation version of Windows Azure in order to test the Azure Site Recovery Feature.

    Scenario: I am using Server 2012 Datacenter w/ Hyper V. I have created a VM (evaluation vhd which has the SQL and VMM software prepackaged), which hosts the SQL Database and VMM software. In the VMM Fabric have created a test cloud, Host Group, and have added a primary host (original Hyper-V Server). I have also configured an Azure Virtual Network and Under Recovery Vault -> Resources -> Networking I have mapped the local network (NIC Card) to the Azure Virtual Network. The VM I am trying to use in the failover test is a Windows Server 2012 VM with single processor, 1GB RAM, 128GB Hard Drive. I have enabled the remote desktop connection and can connect to it while it is on my local network.

    Problem: When I run a test failover everything shows it is completed successfully. The problem is when is do a planned failover. I cannot connect to the machine nor can I even ping the machine. I believe the issue is in the network mapping, perhaps something to do with the DNS.

    I have read many msdn and technet tutorials on this matter but unfortunately I cannot post their links until my account is verified.

    I am so close to getting this running and would really appreciate some help resolving this issue. Thank you.

    Wednesday, September 17, 2014 6:22 PM

Answers

  • Just wanted to update people having the same problem. I am still having issues connecting to the machine over my site-to-site but I can at least now connect using the "connect" button as well as using terminal services via the virtual public ip address. Thanks to Ruturaj Dhekane for his persistence in helping me to solve this.

    Solution: Completely disable the BFE service on the virtual machine. To do this I spun up the vm locally and had to use the Windows Powershell and type Net stop BFE. Once this was done all I had to do was create the RDP endpoint on the failover machine residing in azure and I was able to connect.

    Now to solve this Site-To-Site issue.

    • Marked as answer by DCJohnson1988 Wednesday, September 24, 2014 11:59 PM
    Wednesday, September 24, 2014 11:39 PM

All replies

  • When you do a test failover or a planned failover a virtual machine is created in Azure.

    If it is a Test Failover, it is created in the network that you input and in case of a planned failover it is based on the network that is provided in network mapping.

    This network is a different network from your network on-premises.

    Can you explain how are you trying to connect/ping to machine?

    There are two ways in which you can connect to the virtual machine after failover. Either you can create a S2S VPN between the Azure virtual network and your network on-premises and then connect to the virtual machine using the new internal ip that it gets on Azure.

    Otherwise you can open an RDP endpoint on the virtual machine using Azure management portal and then do remote desktop by clicking on the 'Connect' button. Note that for this to work, Remote Desktop should have been enabled in the virtual machine before the failover was done.


    This posting is provided "AS IS" with no warranties, and confers no rights

    Friday, September 19, 2014 5:59 AM
    Moderator
  • Hello Prateek,

        Thank you very much for the reply. I have tried to ping the machine a couple different ways. First, when it is on premise, I ping it using the local IP as well as the NetBIOS name. After I commit the planned failover I have tried pinging it using the NetBIOS name as well as the Azure IP it gets through my Site-To-Site.

    I have also tried using the RDP endpoint by pressing the connect button but it is unable to connect to the machine. I have verified that RDP was enabled and even connected to it via RDP when it was on my local network. What is interesting to note however is that the connect button as greyed out until I configured the RDP endpoint in the azure management console.

    I feel like I've configured everything properly as all the failovers (test and planned) show nothing but green check marks. And my Site-To-Site shows both networks are connectec and generating traffic, but for some reason connecting to this machine is just not working. Eventually Id like to deploy this to my file server.

    Friday, September 19, 2014 5:36 PM
  • We need a little more information regarding your setup.

    1. Did you complete network mapping and did the VM come up in the required Network and get the IP address from the specified subnet? You can check this information by looking at the VMs dashboard or by going to the networks extension on the left navigation bar.

    2. Is the VMs firewall on? While on-premises, was the BFE service running on the VM?

    3. How did you try to ping the VM? Over the site to site network or via another VM that has failed over in the Azure?

    4. Did any VM succeed ping? or all the VMs that you failed over are not responding for RDP?

    Would it be possible to reach out to us over email? Kindly email me at ruturajd@microsoft.com.

    Monday, September 22, 2014 5:32 PM
  • No problem.

    1. Yes, I completed the network mapping. I mapped the local NIC to the Site-To-Site connection. And yes, the VM pulled an IP from the Azure Network.

    2. The VM's firewall is on but the the RDP is enabled and works fine while on premise.

    3. There is only one VM set to failover so the ping was done over the site-to-site connection.

    4. None of the VM's succeeded in the ping

    Absolutely I will send you an email now. Thank You.

    Monday, September 22, 2014 5:46 PM
  • Just wanted to update people having the same problem. I am still having issues connecting to the machine over my site-to-site but I can at least now connect using the "connect" button as well as using terminal services via the virtual public ip address. Thanks to Ruturaj Dhekane for his persistence in helping me to solve this.

    Solution: Completely disable the BFE service on the virtual machine. To do this I spun up the vm locally and had to use the Windows Powershell and type Net stop BFE. Once this was done all I had to do was create the RDP endpoint on the failover machine residing in azure and I was able to connect.

    Now to solve this Site-To-Site issue.

    • Marked as answer by DCJohnson1988 Wednesday, September 24, 2014 11:59 PM
    Wednesday, September 24, 2014 11:39 PM
  • I have disabled the BFE service on the virutal machine OnPremises, and I try to failover again. In Azure VM, boot diagnostic show the OS Ctrl+Alt+Supr correctly, but the network icon as unavailable.


    Tuesday, September 18, 2018 7:23 AM
  • Hi Victor Rodilla,

    How did you manage to solve network issue in your boot diagnostics screenshot. I do face the similar issue but didn't find any solution.


    shravani

    Wednesday, October 30, 2019 3:47 AM