Vista - Mouse stopped working



    I need very urgent help.


    When I came in to work this morning my mouse was not working. It was OK yesterday, but this morning it is a No Go.


    I have tried many different types of mouse (PS2, USB, Wireless). No mice work, no matter what type of mouse is connected to the system.


    The system is Vista Ultimate 64bit.


    I have tried many things to get it working:


    I have tried restinstalling/refreshing the drivers

    I have removed the mouse device from the device manager and rebooted (I have tried this several times)


    In device manager - the system states that the mouse device is working correctly. There are no errors shown in device manager.


    There is a mouse pointer in the center of the screen, but it does not move, and the system is not responsive to mouse clicks.


    I suspect the problem was caused by some downloaded update from MS, there is nothing else that would change the system. No other software has been installed.


    How do I correct this situation without formating the C: drive and reloading the system from scratch?


    Many thanks


    Thursday, October 25, 2007 11:02 AM

All replies

  • i have exactly the same problem...i can work for about 5 - 10 minutes - then the mouse is stopping...i press ctrl-alt-del and do several stupid things (press some keys on keyboard...) - suddenly the mouse i working finde...but only for some minutes...


    i read a kb from microsoft (932653) - maybe they send me a patch...


    if you find the solution, i would be very happy!!!


    my pc: intel quad core 2.8, 4gb ram, asus nvidia gts8800, vista x64 ultimate, logitech laser mouse mx400


    Thursday, November 01, 2007 12:32 PM
  • I was having a similar problem.  I have a USB mouse, and when I unplug it and then plug it back in (which I do all of the time since I have a laptop) eventually it stopped being recognized by the system (always an unknown device type) but would work on another USB port.  Eventually, I ran out of functional ports and spent the last week being very frustrated. I finally found the solution tonight, and since I have seen many posts on many forums with the same or similar problems, I thought I might share the answer.  There are instructions on this page:

    for removing unused device drivers.  The top of the page indicates that these are instructions for XP, but it works the exact same way for vista.  Be careful, however, when following the final step.  You need only to remove all of the pointing device drivers that are in gray, especially those associated with the device that is no longer recognized, as well as any generic ones.  If you have a touchpad, be sure not to remove its driver!  Anyway, after doing this, my mouse is now recognized and installed again. I have the feeling that I may have to do this several more times until Microsoft fixes the problem, but it works for now.
    Monday, November 19, 2007 1:35 AM
  • i could solve my problem: it was the wireless keyboard...i replaced it with a logitech keyboard (modell g11, usb). Crazy: the "mouse-problems" are solved with a new keyboard....

    Monday, November 19, 2007 6:03 AM
  • I have tried new mice, keyboards, both wired nad non-wired. I have tried new drivers. I have tried deleting the devices from the  device manager and letting Windows reconfigure them. All to no effect. Still no mouse.


    In the end I formated the hard drive and reinstalled all software from scratch!!


    Flaky systems??





    Monday, November 19, 2007 9:43 AM
  • I am seeing similar issues with the mouse. I am using a Lenovo X61S with lenovo wireless USB mouse & Vista Business ver 6.


    Mouse pointer moves, but the buttons on the mouse don't respond. I bring up task manager and switch explicitly to the application that is running and this problem goes away sometimes and re-appears when I switch to different applications (like reading PDF files)


    I am seeing these issues at least once a day. This seems to have started after some automatic downloads from MS or Adobe sites. Hope MS is working on this and will send additional automatic downloads.





    Sunday, December 16, 2007 10:06 PM
  • I had the same problems on two different computers. In the end I was able to use a system restore point to get back to a point that worked.

    Frankly I think that its pretty poor that this sort of problem should be happening to so many people more than 12 months after Vista has been released. I think that its even worse that none of the Microsoft people who presumably moderate these forums have been bothered to join the conversation.

    Tuesday, February 26, 2008 6:32 AM
  • I have the same issue on a Dell e1405 inspiron . .it's intermittent .. works, then does not work.  help!

    Sunday, March 16, 2008 1:24 PM
  • I had the exact same issue.

    Mouse consistently stopping to work, alt tabbing, windows key pushing, restarting and of course cursing under my breath... it always stops responding to any clicking whatsoever.

    Before restoring or having to yet again reformat due to a Vista specific issue... which makes me wonder why i never see any Microsoft staff answering these questions... /sigh. i decided to stop and think about how come i was having this issue. Then i realize that i had a Synaptics Pointing Device that had been installed when i borrowed my friends wireless mouse.

    Disabling the Synaptics Pointing Device solved my issue as it was continuing to function even though i was no longer using the mouse and was causing conflict with my current plugged in mouse.
    Wednesday, October 01, 2008 11:35 PM