none
windows 8 - can't load my own driver RRS feed

  • Question

  • Hey,

    So I'm using Windows 8.1 Pro as my virtual machine and have downloaded WDK 7.1 for my driver development purposes. I build my drivers with Win7 ia-64 checked build environment from WDK BuildEnvironment directory.

    My driver code consists of 3 files: main.c, functions.c and example.h. I have created additional files: "makefile" and "sources" in the same directory as above files.

    Makefile:

    !INCLUDE $(NTMAKEENV)\makefile.def

    Sources:

    TARGETNAME=testdrv

    TARGETTYPE=DRIVER

    SOURCES=main.c functions.c

    Then I run Win7 ia-64 checked build environment, set the path to my project's folder and type "build". Everything seems to work well so far. This command has created additional folders in my project's folder: objchk_win7_ia64\ia64 and inside ia64 I have these files:

    _objects.mac

    functions.obj

    main.obj

    testdrv.pdb

    testdrv.sys - my driver

    vc90.pdb

    Now as I tried to start the driver using StartService Windows API I keep getting the same error message: "This driver has been blocked from loading" - error 1275. I read that on windows vista and higher all drivers need to be signed. Otherwise windows won't let them run. Alright... I followed this tut: How to Test-Sign a Driver Package. I managed to create my own certificate and sign my driver without errors using embedded signature method since my built driver doesn't come with any .inf file or .cat file. I've also enabled TESTSIGNING boot option and enabled Code Integrity Event Logging and System Auditing but still getting the same error and can't run my driver by any means... sc.exe doesn't work either. I tried loading it with some programs like OSR Driver laoder but it gives me the same error as StartService function gives...

    Why can I still not run one damned driver? I already spent 2 days on searching only and trying to run my first driver... I would be really extremaly grateful for any help or tips in this matter! I really wanted to learn driver development...

    Wednesday, September 18, 2013 4:01 PM

Answers

  • You definitely do not want to build for IA-64 target. You want x64, a.k.a AMD-64.

    -- pa

    • Marked as answer by Savail Thursday, September 19, 2013 8:15 AM
    Wednesday, September 18, 2013 9:32 PM