none
64-bit Unix subsystem and SDK support missing from Windows 7? RRS feed

  • Question

  • While I like working with the Windows command prompt and working on Windows command scripts, this, to be honest, can be quite limited to what I'd prefer to do (code with the Unix subsystem) on Windows 7.

    Recently, I switched over to a 64-bit system, in preparation for the Windows 8 beta--I'm anxiously awaiting when Microsoft Developer Network members can test it out. :) Understanding that Windows allows the Unix subsystem (with the Software Development Kit) to run on Windows in 32 and 64-bit, I went to grab a copy of the package to install it on Windows 7 64-bit. When the file finally downloaded (I verified it made it successfully--though I didn't do a file hash check), I launched it, only to get an error that my processor was not supported by the package. I then tried the 32-bit version, which did not install as well, returning the same error when unpacked. I tried the Server 2008 version and tried the package for Windows 7, testing compatibility mode with the package, but to no avail.

    To add technical specifications, I'm running an Intel Pentium P6100 64-bit dual-core CPU. Hardware virtualization is disabled, as anything I work with in Virtual PC or VMWare Player does not require this feature to be enabled at this point.

    I actively work with Unix tools, being familiar with the Linux shell, including the gcc compiler, make, automake, jam, and other commands used for programming. On Windows Server 2008 SP1 32-bit, I had successfully installed the Unix Subsystem and SDK. Is Microsoft dropping support for the Unix subsystem? Is this being actively replaced by another package? Most importantly, how can I debug this issue?

    I would like to resume working with the computer the right way, rather than idly using it--if any help could be provided in this situation, I'd highly appreciate it.

    Tuesday, March 1, 2011 5:22 AM

Answers

  • Thank you for the reply.

    I didn't start a new thread, but instead, I did try the "try here" link. Upon looking around from there in the MSDN forums, I did find a similar problem/question, which interestingly enough, did not need debugging. I thought maybe the setup file would have needed to opened with HxD for Windows 7. :)

    For anyone else reading this post, download the AMD64 file, according to the other post that I read. I had not downloaded this file as I also thought it was for AMDs only--apparently, the amd64 version works.

    For Unix coders lost where the Windows 7 Unix subsystem is at, it's here:

    http://www.microsoft.com/downloads/en/details.aspx?familyId=DC03485B-629B-49A6-B5EF-18617D1A9804&hash=%2fdM%2bvtIDcwjci12jcXGwMCM4ZL7GbRSHMD%2bNy%2b05jOnuQpoGHgrc3DPNsmdnE47M4bSv3msQ0zrbP29EriklPg%3d%3d

    I definitely give credit to the other thread for these details. Thank you for your assistance.

    • Marked as answer by agreimann Tuesday, March 29, 2011 3:41 AM
    Tuesday, March 1, 2011 5:29 PM