Skip to main content

 none
OWE (Open With Explorer) only usable after logging-in with another method RRS feed

  • Question

  • In our environment, when OWE is clicked for a document library, it throw the following error:

    "We're having a problem opening this location in File Explorer. Add this web site to your Trusted Sites list and try again."


    It has been found, however, that the issue has nothing to do with "adding this to trusted sites". Because it is found that the OWE button/function will actually work AFTER either of the following is performed:

    1) If I copy and paste the doc library URL/Path to a generic window file explorer and open it, a prompt would pop up, after logging in with my SharePoint account, the files are shown. (Now if I go back to SharePoint and hit OWE, it will actually work).

    2) If I publish a form using InfoPath... Again this will prompt me for the credentials to SharePoint, after logging in, the form is published. (then again, if I go back to SharePoint and hit OWE to open files for a doc lib, it will also work.)

    So, with that being said, it is almost like SharePoint needs a way to trigger the prompt so that IE? knows I'm logged in, But IE itself is incapable of making the connection and prompting me to go through the logging process? It feels like IE needs some power to be able to to do what the generic explorer or InfoPath is capable of doing.

    Please advise.

    Environment: SharePoint 2013 On-Premise


    • Edited by PCHS007 Wednesday, October 9, 2019 8:57 PM update
    Wednesday, October 9, 2019 8:56 PM

All replies

  • Hi,

    Per my test in my sharepoint 2013 environment, I can not reproduce the same problem as yours.

    I suggest that when you log in the sharepoint 2013, click the box “remember my credentials” to check if it works.

    Besides, Make sure "Desktop experience feature' is  installed and Web client service is started:

    • Open Server Manager –> Manage –> Add Roles and Features.
    • Select Features from the left step navigation –> User Interfaces and Infrastructure –> Desktop Experience.
    • Install the feature and restart the server.
    • Go to services. Start WebClient Service.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, October 10, 2019 9:22 AM
  • Hi,

    How are things going? Is there any update on your issue?

    Please remember to mark the reply as an answer if it helps you.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, October 18, 2019 9:11 AM
  • Hi Michael,

    Sorry for the late reply. But the suggestion your provided did not really apply to our environment. As for SharePoint login, instead of through a login box, we have SharePoint use windows credentials (NTLM) so there isn't really a place to check "remember my credentials".

    As for the desktop experience, I'm sure it is not the problem because it is not like we cannot use OWE at all, but if we go though those special steps I mentioned in my previous post. They actually work. I would assume things would not work at all if Desktop Experience is not enabled.

    So it is still bizarre to me. I think those two special route I mentioned in the previous post are the keys, they somehow triggered a login and the credentials from there are then being memorized by IE, but not sure what's going on on the back-end.

    Friday, October 18, 2019 8:10 PM