none
MQ Fails to Install HTTP Support RRS feed

  • Question

  • [This post has been moved from the MSMQ Newsgroups]

    How do I troubleshoot this?

    Windows 7 Professional. I am unable to install HTTP Support for MQ because
    it fails with the message "An error occurred. Not all changes were made....".

    I have tried uninstalling and reinstalling IIS and MQ completely, but no joy.

    Please point me in the right direction, thanks.

    Rich
    Wednesday, March 17, 2010 10:28 PM
    Moderator

Answers

  • [This post has been moved from the MSMQ Newsgroups]

    Hi Rich,

    Could be this:
    http://blogs.msdn.com/johnbreakwell/archive/2009/01/20/unable-to-install-msmq-http-support-0x80070003.aspx

    Basically something wrong with the default website.

    Cheers
    John Breakwell (MSFT)


    "Rich S." <RichS@discussions.microsoft.com> wrote in message
    news:32AA06DE-4E79-40B3-A53F-4E1D87FB29DB@microsoft.com...
    >
    >
    > "John Breakwell" wrote:
    >
    >> Hi Rich,
    >>
    >> Best place to start looking is probably C:\Windows\Logs\CBS\cbs.log.
    >>
    >> Cheers
    >> John Breakwell
    >>
    >> "Rich S." <RichS@discussions.microsoft.com> wrote in message
    >> news:AB3A20E9-33F7-4DAD-8350-3EBA0E27E28F@microsoft.com...
    >> > How do I troubleshoot this?
    >> >
    >> > Windows 7 Professional. I am unable to install HTTP Support for MQ
    >> > because
    >> > it fails with the message "An error occurred. Not all changes were
    >> > made....".
    >> >
    >> > I have tried uninstalling and reinstalling IIS and MQ completely, but
    >> > no
    >> > joy.
    >> >
    >> > Please point me in the right direction, thanks.
    >> >
    >> > Rich
    >>
    >
    > Hi John,
    >
    > I examined the CBS log and found where the install is failing. These are
    > the relevant entries:
    >
    > : [ml:64{32},l:62{31}]"Creating the msmq web directory"
    > : [ml:96{48},l:94{47}]"IMSAdminBase::GetData() failed. hr = 0x8009000f"
    > : [ml:162{81},l:160{80}]"The physical path of the virtual directory
    > /LM/W3Svc/1/Root/ could not obtained."
    > : [ml:92{46},l:90{45}]"Cleaning up the Message Queuing IIS extension"
    > : [ml:146{73},l:144{72}]"IWamAdmin::AppUnLoad() for /LM/W3Svc/1/Root/MSMQ
    > failed. hr = 0x80070003"
    >
    > Apparently, it's failing when trying to install the MQ ISAPI filter in
    > IIS.
    > How can I troubleshoot this further?
    >
    > Thanks,
    > Rich S.
    >
    >
    Wednesday, March 17, 2010 10:31 PM
    Moderator

All replies

  • [This post has been moved from the MSMQ Newsgroups]

    Hi Rich,

    Best place to start looking is probably C:\Windows\Logs\CBS\cbs.log.

    Cheers
    John Breakwell

    "Rich S." <RichS@discussions.microsoft.com> wrote in message
    news:AB3A20E9-33F7-4DAD-8350-3EBA0E27E28F@microsoft.com...
    > How do I troubleshoot this?
    >
    > Windows 7 Professional. I am unable to install HTTP Support for MQ
    > because
    > it fails with the message "An error occurred. Not all changes were
    > made....".
    >
    > I have tried uninstalling and reinstalling IIS and MQ completely, but no
    > joy.
    >
    > Please point me in the right direction, thanks.
    >
    > Rich

    Wednesday, March 17, 2010 10:30 PM
    Moderator
  • [This post has been moved from the MSMQ Newsgroups]



    "John Breakwell" wrote:

    > Hi Rich,
    >
    > Best place to start looking is probably C:\Windows\Logs\CBS\cbs.log.
    >
    > Cheers
    > John Breakwell
    >
    > "Rich S." <RichS@discussions.microsoft.com> wrote in message
    > news:AB3A20E9-33F7-4DAD-8350-3EBA0E27E28F@microsoft.com...
    > > How do I troubleshoot this?
    > >
    > > Windows 7 Professional. I am unable to install HTTP Support for MQ
    > > because
    > > it fails with the message "An error occurred. Not all changes were
    > > made....".
    > >
    > > I have tried uninstalling and reinstalling IIS and MQ completely, but no
    > > joy.
    > >
    > > Please point me in the right direction, thanks.
    > >
    > > Rich
    >

    Hi John,

    I examined the CBS log and found where the install is failing. These are
    the relevant entries:

    : [ml:64{32},l:62{31}]"Creating the msmq web directory"
    : [ml:96{48},l:94{47}]"IMSAdminBase::GetData() failed. hr = 0x8009000f"
    : [ml:162{81},l:160{80}]"The physical path of the virtual directory
    /LM/W3Svc/1/Root/ could not obtained."
    : [ml:92{46},l:90{45}]"Cleaning up the Message Queuing IIS extension"
    : [ml:146{73},l:144{72}]"IWamAdmin::AppUnLoad() for /LM/W3Svc/1/Root/MSMQ
    failed. hr = 0x80070003"

    Apparently, it's failing when trying to install the MQ ISAPI filter in IIS.
    How can I troubleshoot this further?

    Thanks,
    Rich S.


    Wednesday, March 17, 2010 10:31 PM
    Moderator
  • [This post has been moved from the MSMQ Newsgroups]

    Hi Rich,

    Could be this:
    http://blogs.msdn.com/johnbreakwell/archive/2009/01/20/unable-to-install-msmq-http-support-0x80070003.aspx

    Basically something wrong with the default website.

    Cheers
    John Breakwell (MSFT)


    "Rich S." <RichS@discussions.microsoft.com> wrote in message
    news:32AA06DE-4E79-40B3-A53F-4E1D87FB29DB@microsoft.com...
    >
    >
    > "John Breakwell" wrote:
    >
    >> Hi Rich,
    >>
    >> Best place to start looking is probably C:\Windows\Logs\CBS\cbs.log.
    >>
    >> Cheers
    >> John Breakwell
    >>
    >> "Rich S." <RichS@discussions.microsoft.com> wrote in message
    >> news:AB3A20E9-33F7-4DAD-8350-3EBA0E27E28F@microsoft.com...
    >> > How do I troubleshoot this?
    >> >
    >> > Windows 7 Professional. I am unable to install HTTP Support for MQ
    >> > because
    >> > it fails with the message "An error occurred. Not all changes were
    >> > made....".
    >> >
    >> > I have tried uninstalling and reinstalling IIS and MQ completely, but
    >> > no
    >> > joy.
    >> >
    >> > Please point me in the right direction, thanks.
    >> >
    >> > Rich
    >>
    >
    > Hi John,
    >
    > I examined the CBS log and found where the install is failing. These are
    > the relevant entries:
    >
    > : [ml:64{32},l:62{31}]"Creating the msmq web directory"
    > : [ml:96{48},l:94{47}]"IMSAdminBase::GetData() failed. hr = 0x8009000f"
    > : [ml:162{81},l:160{80}]"The physical path of the virtual directory
    > /LM/W3Svc/1/Root/ could not obtained."
    > : [ml:92{46},l:90{45}]"Cleaning up the Message Queuing IIS extension"
    > : [ml:146{73},l:144{72}]"IWamAdmin::AppUnLoad() for /LM/W3Svc/1/Root/MSMQ
    > failed. hr = 0x80070003"
    >
    > Apparently, it's failing when trying to install the MQ ISAPI filter in
    > IIS.
    > How can I troubleshoot this further?
    >
    > Thanks,
    > Rich S.
    >
    >
    Wednesday, March 17, 2010 10:31 PM
    Moderator
  • Thank you, John Breakwell!

    I was having the same issue on Windows Server 2012 R2. Searched high and low for days.

    Add-WindowsFeature : The request to add or remove features on the specified server failed.

    Installation of one or more roles, role services, or features failed. Error: 0x800f0922

    At line:1 char:1

    + Add-WindowsFeature MSMQ-Http-Suppor

    CBS.log said:

    Error                 CSI    00000009 (F) Logged @2019/9/22:19:29:02.527 : [ml:162{81},l:160{80}]"The physical path of the virtual directory /LM/W3Svc/1/Root/ could not obtained."
    For whatever reason, an unused site in IIS that happened to be #1 was missing it's physical path setting. Providing a setting allowed the installer to succeed.
    Sunday, September 22, 2019 7:52 PM