none
Microsoft.ACE.OLEDB.12.0 is not registered RRS feed

  • Question

  • Dear All

    I know this issue has been discussed many times, however I went through many of them and it still does not work. 

    I am trying to create package in SSDT to import Excel file (tries xls and xlsx)  however in Connection Manager "No tables or Views could be loaded" and when trying to use SQL Command I can see following error: 

    "Exception from HRESULT: 0xC020801C
    Error at Package [Connection manager "Excel Connection Manager"]: The requested OLE DB provider Microsoft.ACE.OLEDB.12.0 is not registered. If the 32-bit driver is not installed, run the package in 64-bit mode. Error code: 0x00000000.
    An OLE DB record is available.  Source: "Microsoft OLE DB Service Components"  Hresult: 0x80040154  Description: "Class not registered".

    Error at Package [Connection manager "Excel Connection Manager"]: The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine. For more information, see http://go.microsoft.com/fwlink/?LinkId=219816

    Error at Data Flow Task [Excel Source [1]]: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER.  The AcquireConnection method call to the connection manager "Excel Connection Manager 1" failed with error code 0xC0209302.  There may be error messages posted before this with more information on why the AcquireConnection method call failed."

    I have installed Microsoft Access Database Engine 2016 32 bit on my local Machine (the same as SSFT tools). 

    I was trying to change Run64BitRuntime to False in SSIS project.

    I have Office 365 32 bit installed.

    Can you please help what can be the issue here? 

    Sunday, October 6, 2019 5:49 PM

Answers

  • Hi John8522,

    I recently answered a similar question.

    Check it out: Excel Source stopped working in SSIS

    >> "...I have installed Microsoft Access Database Engine 2016 32 bit on my local Machine..."

    And make sure that the Excel connection string shows 'Microsoft.ACE.OLEDB.16.0' on your machine.

    Please see a screen shot below, showing 'Microsoft.ACE.OLEDB.12.0' for my machine.



    Sunday, October 6, 2019 9:19 PM

All replies

  • Hi John8522,

    I recently answered a similar question.

    Check it out: Excel Source stopped working in SSIS

    >> "...I have installed Microsoft Access Database Engine 2016 32 bit on my local Machine..."

    And make sure that the Excel connection string shows 'Microsoft.ACE.OLEDB.16.0' on your machine.

    Please see a screen shot below, showing 'Microsoft.ACE.OLEDB.12.0' for my machine.



    Sunday, October 6, 2019 9:19 PM
  • Hi John8522,

    The following link will be helpful.

    Installing the Microsoft.ACE.OLEDB.12.0 Provider for Both 64-bit and 32-bit Processing

    Best Regards,

    Mona


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, October 7, 2019 1:42 AM
  • Thank you Yitzhak,

    The following which was under your link helped:

    • Set the SSIS project in 32-bit mode via Run64BitRuntime to false.

    Especially I had to change Data access mode to SQL command as described by you below

    • In Excel Source Adapter, specify SQL statement instead of referring to Excel's sheet name only:
      - SELECT * FROM [SheetName$A1:B3], by specifying a certain range
      - SELECT * FROM [SheetName$], whole sheet

    One additional thing, I had excel file name with spaces (e.g. "File Name"), I had to remove spaces from the File Name and it worked!

    Thank you!

    Monday, October 7, 2019 5:49 PM
  • Hi All,

    I was facing same issue today on a new Azure VM which has SQL Server 2016 installed. After installing AccessDatabaseEngine_X64, It worked for me.

    If you install 32 bit then make sure to check this option in Job-->Step-->Configuration-->Advance. 


    Thanks Shiven:) If Answer is Helpful, Please Vote

    Wednesday, July 1, 2020 6:23 AM