Questions on certifying Windows 7 app with new Windows App Certification Kit

    General discussion

  • I have previously certified this application using the Windows 7 software certification toolkit from 2009.  I am still able to download and successfully execute this toolkit against our app.  And it passes.  However, the xml file it outputs is no longer valid.  I am told we must use the new Windows App Certification Kit.  I've downloaded and installed it.  The first page asks for our app installer and a command line.  I have tried with and without a command line entry and nothing happens.  The app cert tool spins for a while and eventually says it could not detect an installed app.  In the old toolkit, it told me to "install your app now" and waited for me to click the next button after I installed my app.  The new toolkit does not prompt me to install my app.  I've read the "prerelease" documentation and it doesn't say much about Windows 7.  I've tried installing my app when the toolkit says it's looking for the installed app just to see if I could get it to detect it.  That didn't work.

    Please help!


    • Changed type Bob_BaoModerator Monday, June 25, 2012 6:13 AM new ACK discussion
    Saturday, June 23, 2012 1:42 AM

All replies

  • Hi rgrimard,

    The Windows ACK from ?

    Based on the publiced document, now we do not filnal release this ACK, please discuss this issue via the Partner Feedback tool at

    Bob Bao [MSFT]
    MSDN Community Support | Feedback to us

    Monday, June 25, 2012 6:12 AM
  • I don't know if that's the exact link I used to download the tool.  I will try this download.

    That is the document I read, which has very little information on Windows 7.

    I will use the partner site for future questions.



    Monday, June 25, 2012 7:01 PM
  • I've downloaded and installed the kit from the link you sent.  It now launches my app installer.  Thanks!!
    Monday, June 25, 2012 7:18 PM
  • It seems my app is not applicable.  The app cert utility needs to see that a shortcut is placed in the start menu.  My application is a security product and there is no associated start menu entry.  In fact, customers can run this application in a mode where it can not be detected by an end user.  Again, this app was certified with the previous Windows 7 app cert toolkit.  Where should I go at this point?



    Monday, June 25, 2012 7:40 PM
  • I now have access to the sysdev dashboard but I don't see where I would ask questions about my particular question.  I also don't see a "Partner Feedback tool".

    Please help



    Tuesday, June 26, 2012 3:47 AM
  • Hi rgrimard,

    Yes, I just create an empty Winform Application with one simple setup. Do the App Cert testing, same issue,  

    Windows App Certification Kit
    Windows App Certification Kit did not detect any new start menu shortcuts as a result of your installation. 

    Add-ons are not eligible for the Windows Desktop App Certification Program. Please refer to the Windows Desktop App Certification Requirements for more information. 

    Testing cannot continue unless an application is successfully installed, including start menu shortcuts which are necessary to launch the application.

    I will invove others to check this error, and you also could try to visite site.


    Bob Bao [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, June 26, 2012 8:32 AM
  • Hi there.

    I am having the same problem with a ClickOnce app. The problem is not ClickOnce itself, but the ACK not recognizing the shortcuts.
    However, i think you should (as i do) try to work around it creating the shortcuts so that at least ACK can continue the validation.

    Create a .lnk type shortcut, and put something in ProgramFiles if you didn't do it already, could be a link that also.


    .: Stefano Baraldi, Ph.D.

    Tuesday, June 26, 2012 2:37 PM
  • I created a shortcut in the start menu as a workaround.  However, the cert tool then tries to use the shortcut in another session and my guess is it is not found in that session (different user?).  My app is a security product which is actually started via a windows service.  It is not an app that a user would start and interact with.  The cert tool won't let me proceed at this point....
    Tuesday, June 26, 2012 5:28 PM
  • Hi rgrimard,

    A workaround that you could have a try,

    Delete everything under \Users\[YOUR_USERNAME]\AppData\Local\Microsoft\AppCertKit and re-run the WACK tool again.

    From the doucument Windows App Certification Kit it says" Desktop, desktop device, and Metro style apps can be certified; however, plug-in, ActiveX, and other web apps cannot be certified. "

    You could try to do the certification process following below steps,

    • Install the latest Windows 8 build.
    • Review the certification requirements.
    • On a clean system, run the Windows App Certification Kit that is included in the Windows SDK and follow the instructions on the screen.
    • Review certification report and fix issues.
    • Complete the process:
      1. If this is a desktop app, submit the report at the Partner Portal.
      2. If this is a Metro style app, start the Windows Store onboarding process.

    some information for your refference,

    Best Regards,


    Tuesday, July 03, 2012 2:06 AM
  • For enterprise applications, the server certification would be the recommended path:

    Friday, July 13, 2012 12:24 PM
  • Not sure I agree with that.  This "application" I'm trying to certify on Windows 7 is anti-virus-like.  It has user mode processes, and kernel level drivers.  It has no user-interface components and in many cases is hidden from the end-user purposefully by the company deploying it.

    The old toolkit did look for start menu shortcuts and warned when they weren't there, but it did not completely fail the process when they were missing.  This application that I'm certifying passed the old toolkit and we were certified on Windows 7 using it.  I was able to use the old toolkit to produce a passing report, but I can't upload it anywhere for certification.  I'm at a loss at this point as to where to go.  Certifying it on Windows 8 is not an option for us at this time.


    Friday, July 13, 2012 4:28 PM
  • Hi Ryan,

    Thank you for the post.   I have discussed with the team here on the recommended feedback and given the feedback above on kernel level drivers with no user interface too, we definitely advise that you go the route of a server certification for Server 2012 for this configuration:

    The WSLK toolkit was less stringent on the user interface client application requirement with producing a warning on missing shortcuts.   The Windows ACK for client certification will require the shortcuts to be created and also files installed into ProgramFiles directory.   Without that, the tool will not pass and would not receive a Windows 8 client certification.   Again, we are advising the server certification for enterprise applications.


    Nathan Manis

    Microsoft Developer Support

    Thursday, July 19, 2012 2:47 PM
  • I'll give that a shot.  Thanks!
    Thursday, July 19, 2012 3:37 PM
  • Hi Nathan,

    This is Ed Henley.  I'm part of Ryan's team.  Will there be any special handling required to insure that as a partner and developer we can show that this app is certified for Windows 7, when using the server certification for enterprise applications?  How can we post this to meet our partner requirements (they require windows 7 app. certification)?

    Thursday, July 19, 2012 4:05 PM
  • Hi Ed,

    Thank you for the e-mail.   For the Windows 7 certification, the WSLK still covers that program:

    The Windows 7 logo certification is independent of the Windows 8 or Server certification.   I had verified with the product team a couple weeks ago on the feedback on ensuring that the programs are being communicated to be not all emcompassing  (ie, a server certification pass would not mean that Windows 7 logo is granted).



    Wednesday, July 25, 2012 2:44 AM
  • Fantastic!  We've already done that (see my original post) and I have a passing report.  However, I am unable to submit it anywhere!  So, where shall I submit the xml file?

    Thanks again,


    Wednesday, July 25, 2012 3:59 PM
  • Great.

    If you're going for the Logo then the Dev Center - Desktop Dashboard should be the place.
    You have to sign the agreements in order to get the option to submit under the App Certification panel.


    .: Stefano Baraldi, Ph.D. Director @ Featuring TouchTop, accelerated multi-touch document and media management for Windows 7 and 8.

    Wednesday, July 25, 2012 4:44 PM
  • That site doesn't accept the Windows 7 WSLK report.xml.  It says it's an invalid file.  As described in my first post.


    Wednesday, July 25, 2012 5:09 PM
  • This is the error I get when I attempt to upload the file.  * The submission package is invalid (schema). Please make sure you are using the latest version of the Windows App Certification Kit UI to create the final package.
    Thursday, July 26, 2012 1:29 AM
  • So per Ryan and my submissions we can't do Windows 8 ACK, there is no longer in place a Windows 7 WSLK and you're saying that the server logo is for server and not Windows 7 application.  Do you have any suggestions on what to communicate with the Partner Program people saying that they require a logo application from us but we have no means by which Microsoft supports qualifying a windows 7 application for certification anymore?  Is there some other recourse than these forums to get help from Microsoft on this?
    Friday, July 27, 2012 1:41 AM
  • If no one can provide solution here, how about open a case to Microsoft? With a support case, a support engineer will request to check Inspect source code, and assist you to find the solution. I believe you can do what Inspect has implemented after having someone check the source code.

    Please visit the below link to see the various paid support options that are available to better meet your needs.

    Tuesday, July 31, 2012 1:31 AM
  • I am newer of this topic and also puzzled about this questions. I have read the white paper of "Windows ACK". It says by submission.


    Submission for Windows 7 Logo certification

    Don’t submit results from the WindowsACKfor Windows 7 Apps until final release of the Windows ACK and notification that submissions are being accepted.We strongly encourage testing your Windows 7 apps with the Windows ACK,but official Windows 7 Software Logo program submissions must continue to use the WSLK and the new portal submission process (


    That means, if I want to get certification of my windows 7 programm. Which tools should I use? WSLK or ACK? I have just used WSLK.

    Wednesday, August 08, 2012 8:53 PM
  • Hi all,

    we develop a security product with no user interface, not startup shortcut.

    We passed the wslk but can't pass the new ACK because of the shortcut issue.

    Anyone knows what to do? I'm jumping around from sysdev to microsoftplatformready, and don't know what to do.

    On microsoftplatformready we are Windows 2008 R2 ready, but on sysdev there is no more an option to get that. Only certified which I need to shed several K$ to get. On microsoftplatformready we are "compatible with windows 7" but on sysdev we can't get it because of shortcut menu.

    This is absurd.

    Not to mention that the new ACK is not user friendly at all. It is installing, uninstalling for god knows why. With WSLK you got prompt for the phase your in.

    As mentioned before the report.xml generated by WSLK is not accepted by the new sysdev site, so this route is blocked.

    Anyone from Microsoft? What do I need to do?

    • Edited by TzachK Wednesday, October 03, 2012 12:37 PM
    Wednesday, October 03, 2012 12:22 PM
  • Hi,

    Did you find the solution?

    I'm facing the same issue now. Yes, I am using the latest ACK from the latest Win8SDK downloaded from here.

    After testing I am able to save a file (e.g. report.xml) but I cannot upload it through SysDev dashboard. It gives me the "The submission package is invalid (schema). Please make sure you are using the latest version of the Windows App Certification Kit UI to create the final package. error. 

    Maybe there is another tool for "patching" or converting this file to appropriate format?



    Tuesday, November 27, 2012 7:23 AM
  • Hi,

    No solution.

    Microsoft accepted the testing we've done with WSLK for the competency we needed, so I stopped trying to understand the logic of things.



    Tuesday, November 27, 2012 9:15 AM
  • T,

    it's unbelievable but yesterday Microsoft has fixed something and I have successfully submitted my report.xml !

    So now I can see that my application is listed in Manage Client Certification. It has Windows Certification Program set to Windows 7 Logo.

    Now, when I go to appdev (DevCenter - Desktop Apps) there are no applications under "Certified Apps". According to the article my app should be shown there, so I could submit it to store.

    Maybe Windows 7 logo is not what I should have for that? Weird ..



    Friday, November 30, 2012 3:26 AM