Microphone 'currently unavailable', but sound is playing through headset


  • I have the x12 Turtle Beach's and they used to work perfectly on everything on my pc. However, I went to use them today and my pc is not picking up the mic. When i go into recording devices the mic is shown but it says it is 'currently unavailable'. But in playback devices it is showing my headset it working. Sound plays fine through them and i can her the mic on through the headset and it works on my xbox, so it is on. My laptop is a hp pavilion and only has one jack for headphones so i use a splitter for the green and pink jacks. the set also needs usb to power it, but that isn't a problem. please help... i don't know why they're not working anymore. 
    Wednesday, November 06, 2013 5:44 PM

All replies

  • "Currently unavailable" means that the Sound control panel can't record from it to show the meter.

    How many recording devices show up in the Sound control panel, and which is the default? Some systems have more than one recording device, and due to hardware limitations you can't record from them all at the same time.

    (That is, it might only be "currently available" when the Sound control panel is open.)

    Matthew van Eerde

    Wednesday, November 06, 2013 7:57 PM
  • Hi, Thanks for helping me.

    So, on my sound panel under the recording tab there is my headset mic which is "currently unavailable". Then an internal mic, which is just the laptops built in one. That is set as default communications device. Then there is Stereo Mix and that is set as default device. Both are showing a meter as well. 

    Is there a way to change it so it will let my headset mic work?

    Thursday, November 07, 2013 2:22 PM
  • What application are you using to try to record from the headset mic? Does it allow you to choose a non-default device to record from?

    If so, make sure nothing else is recording audio at the time, and make sure the Sound control panel is not open, and recording from the headset mic should work.

    If not, you will need to change the default device and the default communications device to the headset mic. Then it should work even with the Sound control panel open.

    Matthew van Eerde

    Monday, November 18, 2013 6:44 PM
  • I am actually having that exact same problem right now, being that this thread is 3 years old if you ever solved it could you please tell me how to do it?? it randomly stopped working today and I cant seem to figure out why?
    Sunday, December 27, 2015 5:34 AM
  • I was having the same problem, I fixed it by closing the application where I was trying to use it and reopening it. As soon as I closed the program, the microphone started working.
    Monday, January 04, 2016 2:30 AM