none
Coded UI is failing after Aniversary Update RRS feed

  • Question

  • Hi All,

    We have developed UWP application and automated using coded UI and The automation runs daily in VM.

    Everything is working fine till the aniversary update. We have added new API's from Aniversary update, So we re-targeted app version to Aniversary update. After upgrading OS to aniversary the VM is failed to run the automation(Coded UI).

    What is Working in Old Version:

    1. Created app in my machine and Automated using Coded UI. : No Prblem.

    2. Running Coded UI in my Machine. Working fine.

    3. Running Automation in VM. : No Problem.

    What is Working and Not Working in Aniversary:

    1. Created app in my machine and Automated using Coded UI. : No Prblem.

    2. Running Coded UI in my Machine. Working fine.

    3. Running Automation in VM. : Failing (Error: Can not find the control...).

    Please tell us how to solve this? and let me know if you need more information.

    Note: I could not found any Coded UI forums, please mark this as Coded UI issue, and route appropriately.

    Thanks,


    Pallam Madhukar Windows Phone Developer



    Wednesday, March 1, 2017 6:38 AM

All replies

  • Hi Pallam Madhukar,

    According to your description, whether you have created a Coded UI Test project for UWP?

    You could use the following code to see the results.

    yourControl.TryFind();

    If it does not work for you, please use Coded UI Test builder to re-identify this control, and add it to UIMap. Then call it in Test Method to see whether has the same issue.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 2, 2017 6:48 AM
    Moderator
  • Thank you Oscar, we will try your solution and update you.


    Pallam Madhukar Windows Phone Developer

    Thursday, March 2, 2017 8:29 AM
  • Hi friend,

    If my reply help you resolved your issue, would you please mark it as answer, if not, please feel free to let me know. Thank you very much.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, March 3, 2017 6:13 AM
    Moderator