locked
Emulator: window phone OS is starting RRS feed

  • Question

  • I want to learn window phone 8.1 app developing.
    My System Configuration:
    OS : Window 7 Ultimate 64-bit
    Processor : Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
    Ram : 6GB
     
    I installed VMware Workstation 10.0.1 and then inside Workstation i installed Window 8.1 Enterprise 64-bit. Then inside window 8.1, i installed Visual Studio 2013 Update 3 for windows.
     
    My Problem is when i try to debug the project in visual studio, the emulator opens and show "window phone OS is starting..." and when i use my phone for debug then it tells "you need a developer unlocked phone" but my phone is already developer unlocked.
     
    My Virtual Machine Configuration for Window 8.1 Enterprise:
    Ram : 2GB
    Processors : 2
    Hard Disk : 30GB
    Sunday, August 10, 2014 8:56 AM

Answers

  • i changed my window from 8.1 Enterprise to 8.1 pro 64bit, register my phone again using window phone developer registration.

    and now my emulation and phone is working fine.


    • Edited by rajnegi.it Sunday, August 17, 2014 11:22 AM
    • Marked as answer by rajnegi.it Sunday, August 17, 2014 11:23 AM
    Sunday, August 17, 2014 11:19 AM

All replies

  • If you are having issues trying to debug with your Windows Phone device, try running the Windows Phone Developer Registration (8.1) application and attempt to developer unlock your device again. This worked for me when I had issues when I upgraded my phone to the 8.1 developer preview.

    JCroft Applications

    Sunday, August 10, 2014 9:08 AM
  • As for running the Emulator - the Emulator itself is using Hyper-V virtualization to run. While this is possible with certain Virtualization products inside a VM it quite often has issues. So the best advice I can give you is to install Windows 8.1 directly on your system (perhaps in a dual boot configuration if you don't want to move your whole OS forward from Windows 7) instead of running it inside a VM.
    Monday, August 11, 2014 12:30 PM
  • i changed my window from 8.1 Enterprise to 8.1 pro 64bit, register my phone again using window phone developer registration.

    and now my emulation and phone is working fine.


    • Edited by rajnegi.it Sunday, August 17, 2014 11:22 AM
    • Marked as answer by rajnegi.it Sunday, August 17, 2014 11:23 AM
    Sunday, August 17, 2014 11:19 AM