none
App bundle gets version 2014 RRS feed

  • Question

  • I've created a beta app (Windows Phone 8.1 universal) that I've been pushing to the Store for Beta testing. It's been v0.1, 0.2 and so on.

    When I created different assets for different resolutions the "auto"-settings for App Bundles wanted to create App Bundle.
    Now when I upload the app to the store it gets version 2014.1018.1615.534 (the date it was created I guess) even if I specify 0.7.0.0 in appxmanifest and in the "Create app package.."-dialog. Why is it this way?

    • Moved by Jamles Hez Tuesday, October 21, 2014 8:48 AM
    Saturday, October 18, 2014 5:50 PM

Answers

  • This is expected behavior for app bundle packages. They are always versioned based on date.

    The code package will have its set version information.

    If you list the packages on your Windows system in \Program Files\WindowsApps you'll see this is the case for all app bundle packages.

    --Rob

    Sunday, October 26, 2014 10:59 PM

All replies

  • On my universal app, I've set my package version to say, 2.0.1.0. When I use Windows.ApplicationModel.Package.Current.Id.Version, it returns the correct version number. However, on the Windows Phone store, the version number that shows up on the store page looks more like the date than the version number on my package.

    How can I get the Windows Phone store to use the package version number? The Windows Store doesn't have this issue.

    Sunday, June 1, 2014 3:01 AM
  • I have created a Windows Phone 8.1 XAML version of one of my existing app (guid: 2e7c49ff-c165-4f94-a6a5-7473774f4a1f). I set the package version to 1.5.0.0, the created file is called SlovakApps.WindowsPhone_1.5.0.0_AnyCPU_bundle.appxupload. When I upload the file to Dev Center, a strange version is shown:

    Is this normal? Seems very strange to me.

    Here is the appxbundle file: https://dl.dropboxusercontent.com/u/73642/SlovakApps.WindowsPhone_1.5.0.0_AnyCPU_bundle.appxupload

    Sunday, June 1, 2014 10:30 AM
  • Hah, I just asked this question too. I see the same thing on my universal apps. Hoping for a response...
    Monday, June 2, 2014 1:14 AM
  • Support is telling my that it is ok, but it does not seem right ...
    Tuesday, June 3, 2014 6:16 AM
  • I have the exact same problem with my Universal App (currently only WP).

    I started of with a "Blank Universal App" project template. I am using VS Express for Windows.

    I am wondering if I can Publish or not and if it will affect anything; updates...

    Wednesday, October 8, 2014 3:14 PM
  • It doesn't effect updates since the version number of an update will still be higher than the old one. It's just weird. I haven't contacted support because I haven't had a need to put out an update in a few months, so I don't know the cause of this issue.
    Wednesday, October 8, 2014 3:16 PM
  • I think the question was closed too early.

    Remember to mark reply as answer if it answers the question.
    Apps Request

    Wednesday, October 8, 2014 3:27 PM
  • No one knows why it is this way?
    Sunday, October 19, 2014 7:14 PM
  • Hi Andreas,

    While you generate the app package, could you validate if you fill in the correct version?

    As I can see from app bundle documentation, it should not modify your version number.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, October 20, 2014 3:28 AM
  • If I enter this:

    When I upload I get this:

    Monday, October 20, 2014 9:36 PM
  • Hi Andreas,

    Let's see if Publish forum can help you :)

    I'm not knowledgeable for publishing the app to the store.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    • Edited by Jamles Hez Tuesday, October 21, 2014 8:48 AM
    Tuesday, October 21, 2014 8:47 AM
  • Thanks for moving to correct forum =)

    But it seems strange right?

    Tuesday, October 21, 2014 6:52 PM
  • Hi there

    I am creating a new windows phone 8.1 app(windows run time), everything went smoothly until now.

    I created an app package using visual studio, the version number is 1.1.0.3 in app manifest. But after I uploaded the package to dev center, it shows a huge number "2014.1021.2052.4303" and I cannot edit it.

    What did I do wrong and what should i do now?

    Thank you

    Tuesday, October 21, 2014 9:17 PM
  • I just posted a same question then I saw your thread.

    Have you found a way to solve this?

    Tuesday, October 21, 2014 9:20 PM
  • Hello All,

    The Dev Center reads the version number from the app package.

    For more information on how version numbers are managed see: Versioning

    -Eric


    Windows and Windows Phone Dev Center Support

    Send us your feedback about the Windows Platform

    Wednesday, October 22, 2014 9:02 PM
    Owner
  • This is not the case. Our package version number is normal, the version number shows at dev center is just date:2014.1021......
    Wednesday, October 22, 2014 11:52 PM
  • Hello All,

    The Dev Center reads the version number from the app package.

    For more information on how version numbers are managed see: Versioning

    -Eric


    Windows and Windows Phone Dev Center Support

    Send us your feedback about the Windows Platform

    Then I would love to know where the Windows Phone Dev Centre is getting its version number from, because it's certainly not from my package. My code pulling package version numbers gets the right info. The right info is displayed during the package creation process. It's only when it's uploaded to Dev Centre does it suddenly change what looks like a build date.
    Wednesday, October 22, 2014 11:58 PM
  • if the option "Generate app bundle" set to "never", the version number will be normal.


    在現實生活中,你和誰在一起的確很重要,甚至能改變你的成長軌跡,決定你的人生成敗。 和什麼樣的人在一起,就會有什麼樣的人生。 和勤奮的人在一起,你不會懶惰; 和積極的人在一起,你不會消沈; 與智者同行,你會不同凡響; 與高人為伍,你能登上巔峰。


    Thursday, October 23, 2014 4:53 AM
  • I just posted a same question then I saw your thread.

    Have you found a way to solve this?

    No, I still have this problem...
    Sunday, October 26, 2014 10:20 PM
  • This is expected behavior for app bundle packages. They are always versioned based on date.

    The code package will have its set version information.

    If you list the packages on your Windows system in \Program Files\WindowsApps you'll see this is the case for all app bundle packages.

    --Rob

    Sunday, October 26, 2014 10:59 PM