locked
Connection string for ApplicationServerWorkflowInstanceStoreConnectionString not found RRS feed

  • Question

  • I have turned on persistence and pointed it to the configured sql provider. The service then fails to start up because the configuration for connection string ApplicationServerWorkflowInstanceStoreConnectionString cannot be found.

    If I open up IIS then I can see that configuration setting via web.config inheritance when using the configuration manager. The only way I could get this to work was to copy the config from the IIS configuration manager into the application web.config.

    It would be great if the config value would inherit into the applications web.config in order to maintain the separation of application and AppFabric.

    Any thoughts? 

    Tuesday, December 7, 2010 12:51 PM

Answers

  • It looks like the AppFabric installer has not correctly configured the machine.config with the connection strings for the database. I had to add the connection string in order for it to no be required in the application config.

    For example:

    	<connectionStrings>
    		<add name="LocalSqlServer" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient"/>
    	<add name="ApplicationServerWorkflowInstanceStoreConnectionString"
    		   connectionString="Data Source=localhost;Initial Catalog=AppFabric_Persistence;Integrated Security=True"
    		   providerName="System.Data.SqlClient" />
    	</connectionStrings>
    

    • Marked as answer by Rory_Primrose Friday, January 7, 2011 12:14 AM
    Friday, January 7, 2011 12:13 AM

All replies

  • Also, the AppFabric dashboard fails to display failures because it identifies that the same connection string key value is found in multiple places. I have to temporarily comment out the connection string in the application web.config to be able to use the AppFabric dashboard, then put the connection string back in order to use the application.
    Tuesday, December 7, 2010 10:57 PM
  • It looks like the AppFabric installer has not correctly configured the machine.config with the connection strings for the database. I had to add the connection string in order for it to no be required in the application config.

    For example:

    	<connectionStrings>
    		<add name="LocalSqlServer" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient"/>
    	<add name="ApplicationServerWorkflowInstanceStoreConnectionString"
    		   connectionString="Data Source=localhost;Initial Catalog=AppFabric_Persistence;Integrated Security=True"
    		   providerName="System.Data.SqlClient" />
    	</connectionStrings>
    

    • Marked as answer by Rory_Primrose Friday, January 7, 2011 12:14 AM
    Friday, January 7, 2011 12:13 AM
  • I've narrowed this one down further. I am running Windows 7 x64 but executing x86 applications in IIS. This starts to fail when I changed the apppool configuration to enable 32bit applications.

    This problem comes up because the AppFabric installer only configures the root web.config at 

    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config

    but not at

    C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config

    As soon as Enable 32bit applications is set in the apppool, the configuration is then read from the 32bit framework configuration rather than the 64bit configuration.

    Friday, January 21, 2011 10:41 AM
  • Another great way to get this error:

    add a <clear> in your web config's <connectionStrings> section, like so:

    <connectionStrings>
        <clear />
        <add name="...

    Explanation: AppFabric relies on connection strings from config files further up the directory tree.

    The <clear> will remove these and trigger the 'ApplicationServerWorkflowInstanceStoreConnectionString not found'

    error.


    Wednesday, October 31, 2012 10:27 AM