none
Submission package upload failure. "Invalid package family name" and "Invalid package publisher name" RRS feed

  • Question

  • Hey

    I've been struggling for a while now with this issue and nobody seems to know what the heck is going on. I was sent here, to post about my issue, by MS support person - who also couldn't find the answer to my problem.

    This is actually my second thread on MS forums. Firstly I tried on more general forum, without any success. I got told in that thread to contact MS support, which in the end got me here...Anyways, that's the thread: https://social.msdn.microsoft.com/Forums/windowsapps/en-US/3760cd40-c916-46f0-a985-befdf843dfb4/uwp-invalid-package-family-name-and-invalid-package-publisher-name?forum=wpsubmit#791a929b-1d65-4848-af12-5a16ddd77b35, if you feel like getting more insights on the problem.

    Long story short, I'm trying to submit an app to MS store and I'm getting stuck at uploading the package, with the following errors:

    Now, this seems to be pretty obvious (at least with the second error). I've got publisher name in the App Identity (in the MS dev dashboard) set to be "Mikolaj Kieres" and the publisher name in the package is "CN=Mikolaj Kieres". These two are not a match, hance the error. The problem though is that there's NO WAY to create a package with publisher name like I have (i.e. "Mikolaj Kieres") because in the light of the rules around Publisher Name, which are defined in here, my publisher name is incorrect.

    Digging a bit deeper, why my Publisher Name is even changing (because I assure you, that in the Package.appxmanifest I have Publisher attribute of the Identity set to "Mikolaj Kieres"). I found out, that Visual Studio, when bundling, automatically changes incorrect publisher names (e.g. "Mikolaj Kieres") and uses the one from the certificate - which is, I figure, what's happening for me. There even was a comment about it on the page with rules around app Identity:

    I guess it comes down, to the question, how I was able to set an incorrect publisher name in my dev dashboard and how to change it to something that's valid, so I could submit my app?

    Any suggestions?

    Thursday, March 1, 2018 11:42 AM

All replies

  • Hi Mikolaj Kieres

    Have you published other apps successfully?

    How about manually change the manifest file like delete the “CN=” after you have associated the app to store?

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 2, 2018 3:12 AM
    Moderator
  • Hi Roy,

    Yes, although it was few years ago, when the windows phone 8/8.1 was still around.

    The "CN=" prefix comes into play after I create a appxbundle - before that the manifest value for the publisher is "Mikolaj Kieres".

    Cheers

    Friday, March 2, 2018 3:25 AM
  • @ Mikolaj Kieres,

    This problem is strange. How about that create a new app in the dashboard and associate it with your project? Will it successfully submit the app ?

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 5, 2018 8:43 AM
    Moderator
  • Hi Roy,

    Thanks for your interest in my problem.

    I was thinking about it but I didn't want to make a mess in my dashboard with 'throw away' apps, because I don't know how to delete/remove them. Nevertheless, I will create new app and try submitting the bundle - once I'm done with that I will let you know 

    EDIT:

    Done. Unfortunately, same result...The publisher has not changed - it stayed at "Mikolaj Kieres", which I assume is incorrect.

    I associated the app using Visual Studio 2017 Community Edition (v 15.5.7) successfully. I tried uploading the appxbundle, with the same result as before:

    I'm not an expert on this but it would have seemed like I have an incorrect publisher name associated with my dev center account? Could that be a thing?

    Monday, March 5, 2018 11:38 AM
  • @Mikolaj Kieres,

    Please try again to change the publisher manually but in different ways.

    First associate your app and package your app.

    Then use makeappx.exe to unpack your package.

    Change the publisher and package the app again.

    At last sign the app.

    You could refer this link for the commands of makeappx.exe: https://msdn.microsoft.com/en-us/library/windows/desktop/hh446767%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 7, 2018 6:00 AM
    Moderator
  • Hi Roy

    Thanks for coming up with new ideas. Unfortunately, I already tried using MakeAppx. I even posted about it in my previous thread, which I pointed at in my first post in this thread - previous thread

    The result with MakeAppx is sort of expected. That's the quote from my previous thread:

    "Yes, I actually tried to pack my app with MakeAppx Tool, but it throws an error when I try to force the publisher to be "Mikolaj Kieres":

    "MakeAppx : error: Error info: error C00CE169: App manifest validation error: The app manifest must be valid as per schema: Line 10, Column 47, Reason: 'Mikolaj Kieres' violates pattern constraint of '(CN|L|O|OU|E|C|S|STREET|T|G|..."

    After failing to manually packing my app, I started to think that my publisher name in the dashboard is, for whatever reason, incorrect. 



    Wednesday, March 7, 2018 6:22 AM
  • @Mikolaj Kieres,

    Sorry to say I could only offer limited help for this. I suggest that you need to open a support ticket to check your account again.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 7, 2018 6:34 AM
    Moderator
  • Hi Roy,

    Thanks for your suggestions and for trying to find an answer to my issue.

    I must say though, I'm very dissatisfied with this situation. I've been going back and forth with threads on these forums, issuing tickets, back to forums and now you're asking me to open the ticket yet again...Don't get me wrong, I really appreciate your help - it's not personal. I'm just expressing my frustration over the situation - that nobody can find the solution to my problem. Can this be somehow escalated?

    Wednesday, March 7, 2018 11:22 PM
  • Hi Mikolaj,

    I am very sorry for inconvenience that has been caused for you.

    You said you have opened the support ticket, could you please share the support ticket number in here? Because I need to know your information about your developer account, in this way I can involve our engineering team to look at this issue. But it is not allowed to share customer's account information in our public forum in order to protect customer's privacy.

    Thanks for your understanding.

    Best Regards,
    Fang Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, March 8, 2018 3:19 AM
    Owner
  • Hi Fang

    Thanks for such a prompt reply.

    I haven't opened a new ticket (yet). I can provide you with the old one though. Actually I have two. The most recent one is: "SRX1404269382ID" - it's from November last year. There's also an older one, from December October: "SRX1400299236ID".

    If you still want me to open a new ticket, please let me know

    Cheers

    • Edited by Mikolaj Kieres Friday, March 9, 2018 4:35 AM Incorrect month
    Thursday, March 8, 2018 3:41 AM
  • Hi Mikolaj,

    Thank very much for your cooperation.

    I will forward your information to the related team, if it is still needed to open the support ticket, I will let you know.

    Thanks for your understanding.

    Best Regards,
    Fang Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, March 9, 2018 2:01 AM
    Owner
  • Hi Mikolaj,

    We have checked and found that your two SR have been archived, could you please create a new support ticket and share the support ticket number in here?

    Thanks for your understanding.

    Best Regards,
    Fang Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, March 9, 2018 3:55 PM
    Owner
  • Hi Fang,

    I just submitted a ticket. The number is 1418426877

    Cheers

    Saturday, March 10, 2018 1:53 AM
  • Hi Mikolaj,

    I have already forwarded your information to the related team, and they will contact you by using this support ticket#1418426877. Please feel free to share it here if you have got any update or feedback. 

    I will also keep update here.

    Thanks,
    Fang Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, March 12, 2018 3:02 AM
    Owner
  • I've the same problem. Could you share the solution?

    Thanks, Eduardo

    Friday, August 23, 2019 12:12 PM