none
[UWP][HTML] When bug is detected in an x-ms-webview (aka iframe) app crashes/freezes. Any workaround? RRS feed

  • Question

  • Is there a way for me to block JavaScript content within x-ms-webview or someway to avoid Visual Studio from debugging x-ms-webview as well?

    Currently when debugging and running the app, the app locks and freezes when there are bugs within the x-ms-webview, I'm not sure how the app would behave in production. I'm hoping not?

    Thanks for your help! :)


    • Edited by jamespaxi Saturday, June 13, 2015 9:42 PM
    Saturday, June 13, 2015 9:42 PM

All replies

  • Does this help at all?
    http://blogs.msdn.com/b/wsdevsol/archive/2012/10/18/nine-things-you-need-to-know-about-webview.aspx#AN10

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Monday, June 15, 2015 4:18 PM
    Moderator
  • Thanks for your help and reply :)

    Unfortunately I'm still getting an app freeze, here's the popup that greets me:

    If I click on "Continue" the app completely freezes.

    If I click on "Stop debugging" the app exits.

    Saturday, June 20, 2015 7:10 PM
  • Hi jamespaxi,

    the error is obiously: there is an error on the website.


    © 2015 Thomas Roskop
    Germany //  Deutschland

    • Proposed as answer by Jamles Hez Wednesday, June 24, 2015 9:57 AM
    Saturday, June 20, 2015 7:40 PM