The following forum(s) have migrated to Microsoft Q&A (Preview): Developing Universal Windows apps!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
DEP0700: Registration of the app failed. [0x80073CF6] Error 0x80070002: ESim API. RRS feed

  • Question

  • I'm trying to us ESim API, and I follow this help:
    docs.microsoft.com/en-us/uwp/api/windows.networking.networkoperators.esimmanager
    and add the custom capability required in this help:
    docs.microsoft.com/en-us/windows/uwp/packaging/app-capability-declarations#custom-capabilities
    `
    <Package xmlns="schemas.microsoft.com/appx/manifest/foundation/windows10"
    xmlns:mp="schemas.microsoft.com/appx/2014/phone/manifest"
    xmlns:uap="schemas.microsoft.com/appx/manifest/uap/windows10"
    xmlns:r="schemas.microsoft.com/appx/manifest/foundation/windows10/restrictedcapabilities"
    xmlns:uap4="schemas.microsoft.com/appx/manifest/uap/windows10/4"
    IgnorableNamespaces="uap mp r">
    .....
    <r:Capability Name="cellularDeviceIdentity" />
    <r:Capability Name="cellularDeviceControl" />
    <r:Capability Name="cellularMessaging" />
    <uap4:CustomCapability Name="Microsoft.eSIMManagement_8wekyb3d8bbwe"/>
    `
    but when I run this uwp, I got this error:
    DEP0700: Registration of the app failed. [0x80073CF6] Error 0x80070002: The system was unable to register the windows.capability extension when preparing to process the request: The system cannot find the file specified.
    Does this capability must be authoriazed ?
    Anyone can help me? Thank you so much.
    Sunday, June 2, 2019 2:14 AM

All replies

  • Hi,

    Since this forum discusses about Application Compatibility for Windows Desktop Development.

    And this thread is UWP related, I will move it to UWP Forum. Thank you for your understanding!

    Best regards,

    Drake


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, June 3, 2019 6:53 AM
  • Hi,

    I have some questions here. What's the OS version of your app? And what's the test device that you are using? Do you have a sim card or esim card in your test device? It needs more information about your question.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, June 3, 2019 8:22 AM
    Moderator
  • Sorry, I will move this to UWP Forum.

    Thank you.

    Thursday, June 6, 2019 2:18 AM
  • OS Vesion:

    Window 10 1809

    Test Device:

    Lenovo X390

    Esim:

    Yes, I have an esim card inside X390, with a porfile from Lenovo Connect.

    Thank you for your reply.

    • Edited by novrainn Thursday, June 6, 2019 2:26 AM
    Thursday, June 6, 2019 2:24 AM
  • Hi,

    Currently I don't have such a device here to test. So I'll ask the team about your question. There might be some time delay. Thank you for your patience.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, June 6, 2019 8:13 AM
    Moderator
  • Hi Li:

    Is there any other limited to use this API?

    Dose the app which call this API need to be signatured by MS or MNO?

    Monday, June 10, 2019 2:04 AM
  • Hi,

    Yes, according to the document, it needs privileged access by mobile network operators. But I'm not sure when using Visual Studio to debug. I'm wait for the team's response about this.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, June 10, 2019 7:51 AM
    Moderator
  • Hi Li,

    Sorry to bother you, is there any progress?

    Thank you!

    Wednesday, June 12, 2019 3:24 AM
  • Hi,

    I'm sorry to say no, I'm also waiting for the response for the team. Sorry for the inconvenience.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, June 12, 2019 9:13 AM
    Moderator
  • Hi Roy

    Still no response?

    Best regards

    Tuesday, June 25, 2019 4:54 AM
  • Hi,

    Yes, I'm still waiting for the engineer.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, June 26, 2019 2:39 AM
    Moderator