VS 2012 xdesproc.exe hangs RRS feed

All replies

  • There is a known issue that loading XAML designer may take long time and appear to be hang when the target platform is x64. Could you check if this is the case with your repro? If it is, the workaround is to set the target platform to be win32/x86. We are looking to fix this in future releases.

    Li Shao, MSFT 

    Li Shao

    Tuesday, August 21, 2012 4:05 PM
  • It's not project platform or langage dependent issue.

    XDesProc.exe seems to be hangin an ANY XAML related project.

    Tuesday, August 21, 2012 4:25 PM
  • Could you provide steps we could follow to repro this hang you are experiencing to allow us to investigate? I cannot repro this symptom with any new Store project using XAML or picking a random sample. If this is only occurring in WPF projects that would be useful to know as well.

    Splitting into a new thread in our Tools forum to track this issue. The original thread is regarding an old build of VS 2012.


    David Lamb

    Tuesday, August 21, 2012 10:15 PM
  • Unfortunately it's not possible to determine exactly steps to reproduce this isssue. It's just happens any time I'm working with XAML. I just can say it's NOT happens when no XAML sources opened and such kind of hanging could be stopped by killing XDesProc.exe process. If I'll found exact steps I'll make a notice here. Thank you.
    Wednesday, August 22, 2012 5:36 AM
  • Thanks Alexander. I was under the impression it was hanging every time you opened any XAML project.

    David Lamb

    Wednesday, August 22, 2012 10:55 PM
  • I have same issue. Its really annoying.
    Wednesday, January 16, 2013 7:22 AM
  • We have made some significant investments in improving the reliability and stability of the XAML designer in the next update to Visual Studio [Update 2]. This (CTP 2) should be publicly available very soon.  If you still run into these issues after installing the CTP, do let me know. I would really like to investigate this issue further. You can contact me directly @ harikm@microsoft.com.


    Thursday, January 17, 2013 2:20 AM
  • I face the same problem.

    When I click on Smart Tag of any WPF control in Designer, VS2012 hangs :(

    Is there any recent patch updates provided for this issue in VS2012 by Microsoft?
    • Edited by DineshArun Friday, February 8, 2013 9:57 AM Added content
    Friday, February 8, 2013 9:19 AM
  • Here you go http://support.microsoft.com/kb/2797912?wa=wsignin1.0. This is a new update to VS (CTP). Let me know if you still run into issues after installing this.


    Friday, February 8, 2013 5:44 PM
  • Hi,

    I can confirm that this update did not fix this problem.

    It is still there and I'm going to rename this file until there is a fix. It is a bit super anoying. I cannot develop this way.

    I noticed that this is a bug marked as closed?

    • Edited by Dev Edward Wednesday, May 29, 2013 2:31 PM incomplete
    Wednesday, May 29, 2013 1:48 PM
  • Same problem here, running Visual Studio Premium 2012, Version 11.0.60610.01 Update 3.

    So far I only noticed it in WPF projects while pressing F5.

    Tuesday, July 30, 2013 12:27 PM
  • Ditto here: I have VS 2012 Ultimate with Update 3. I use "Always open documents in full XAML view" checked. All it takes is to open a XAML view and then click the Design tab. XDesProc.exe runs pretty much forever after that using more than 10% CPU. However the effect is that it almost completely freezes VS. If you kill it, you get an exception in the designer (to be expected), but at least you can continue using VS. This morning I have very few XAML files I can view in design mode. If I wait long enough some of them display but XDesProc does not stop running, it simply stops occupying CPU.

    Using ProcMon, XDescProc generated hundreds of thousands events (over 800,000 in one test) in 3 minutes before displaying a design and continued even after a design was displayed. It did a CreateFile, QueryBasicInformation and CloseFile thousands of times on the XAML file. Huh? It then proceeded to do the same thing on many other files on the system including files in assembly, System32, Microsoft.NET,SysWow64,Program Files(x86) and many of these were on files that have absolutely nothing to do with VS .NET. It may be related to the size of the solution (72 projects in this one), because it also touched every .cs file in the solution.

    It also did the same thing repetitively on registry keys (the same key over and over). There is undoubtedly an loop without some bounds checking in this EXE.

    If MSFT has somewhere to upload a ProcMon PML file, you can see what one of its procs does on my system.

    Hmm on closer examination of some of the stacks, this may be a lower level issue. The Kernel seems to be accessed by Microsoft.Expression.Utility.ni.dll and seems to be requesting security information for the files accessed.

    • Edited by WrayCMC Tuesday, August 6, 2013 5:48 PM
    Tuesday, August 6, 2013 5:05 PM
  • I have the same problem with VS2012 Update 3. I don't understand what exactly is going on here, this started happening yesterday morning. I'm wondering if it has something to do with Windows security patches for .Net. It was working fine last week, albeit slow (2012 has always been slower than 2010 in my experience), but this week it is completely unusable; opening *any* XAML document, even just XAML view (no designer), causes XDesProc to start and promptly do nothing at all. Since XDesProc and devenv use .Net Remoting, I wonder if it's a mismatched contract? I've run into a lot of problems - a **LOT** of problems - with that using WCF, eventually leading me to fall back on old-school pInvoke mailslots.

    I would love to see this be resolved. As it stands right now, this product is almost totally unusable - I've had to fall back on using the plain text editor for editing XAML.

    Please keep us all updated on this - we rely on your software to make a living.


    • Proposed as answer by Janet Benoit Friday, September 6, 2013 2:04 PM
    • Unproposed as answer by Janet Benoit Friday, September 6, 2013 2:04 PM
    Tuesday, August 20, 2013 1:51 PM
  • The same problem - one of more. VS 2012, update 3. Would you please stabilize VS? VS is more and more unstable, faulty and slow, but I need to make work on it. Thank you.
    Tuesday, October 29, 2013 7:27 AM
  • I have same problem with Update 4.

    It still not fixed.

    • Edited by csb232323 Friday, May 16, 2014 8:45 AM
    Friday, May 16, 2014 8:44 AM
  • Looks like they have fixed this in VS2013, and will not be doing so in VS2012:

    "Posted by Microsoft on 4/29/2014 at 12:30 PM

    Thank you for reporting this issue. This issue has been fixed in Visual Studio 2013. You can install a trial version of Visual Studio 2013 with the fix from: http://go.microsoft.com/?linkid=9832436"

    from http://connect.microsoft.com/VisualStudio/feedback/details/779658/xdesproc-exe-makes-vs-2012-in-windows-7-unusable

    Thursday, May 22, 2014 12:44 PM
  • Unfortunately I can confirm that this issue persists in Visual Studio Professional 2013 (Version 12.0.30501.00 Update 2) meaning I have to regularly resort to killing XDesProc.exe - I had to kill the process immediately after starting VS this morning!
    Thursday, June 5, 2014 8:24 AM
  • I too confirm that we are also facing the same issue on

    Microsoft Visual Studio Ultimate 2013
    Version 12.0.21005.1 REL
    Microsoft .NET Framework
    Version 4.5.50938

    Installed Version: Ultimate

    on Win7 Ultimate 64-bit

    I would appreciate if someone can help us solving asap.

    Thanks & Regards,


    -Vinay Pugalia
    If a post answers your question, please click "Mark As Answer" on that post or "Vote as Helpful".
    Web : Inkey Solutions
    Blog : My Blog
    Email : Vinay Pugalia

    Thursday, June 26, 2014 12:27 PM
  • Hello,

    I also have problems with the xaml designer.It's very slow when I need to drag controls to adjust their position.For test purposes I have created a new solution and in the main window,  I've placed 100 rectangles (using notepad++) then I loaded the window on visual studio and when I try to drag one of them it takes too long for the rectangle starts to move and follow the mouse. That happened on visual studio 2013 with update 3 and also on Blend. My operating system is windows 8.1 x64. Today, I installed windows 8.1 x86 and after visual studio install, everything works fine! There is no delay, no nothing.

    I would like someone tried to run his project on windows 32 bit to see if this is the solution, ie alternative.

    Bruno Moreira

    Wednesday, October 29, 2014 11:55 PM