The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Developing Universal Windows apps!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
[WP8.1]Error DEP4503 (You have installed the maximum number of development apps) while deploying app to phone with no developer apps installed RRS feed

  • Question

  • Hi,

    when I want to deploy new app to my phone I alway get this error for any app I want to deploy:

    "DEP4503 : You have installed the maximum number of development apps. These apps are installed to your device when you start them in Visual Studio or when you use the App Deployment Tool. Please uninstall one of them and then try again. 0x-2130509543: Exception from HRESULT: 0x81030119"

    There arent any developer apps installed on the phone and its unlocked for development.

    I have deployed some apps in the past on other phones but I dont have access to them right now.

    Can anyone have any idea ?

    Thanks for any replies

    @EDIT:

    I have noticed that although I have unlocked the phone using Windows Phone Developer Regsitration tool, it does not appear in the list of unlocked devices on the page of my developer account.

    @EDIT2:

    Also when I unplug the phone from usb and then plug it again, phone becomes locked again and I have to register it for development once more... Is this correct behavior ?


    Monday, October 31, 2016 10:57 AM

All replies

  • Hello Nedved83,

    Try renaming your phone and re-registering it. Also there is a limit to the # of apps so make sure you are signed in with the email addressed used to register your Dev Center account.

    I'm moving this to the tools forum since this is a tools issue. However, if you find that you are still seeing the message that you have installed the maximum # of apps and do not see your phone registered on your Dev Center account please contact Dev Center support. Please note that Dev Center support only supports your account and cannot assist with the device registration tool.

    -Eric


    Contact Dev Center Support

    Monday, October 31, 2016 2:25 PM
  • I have three issues that no one at support seems willing to resolve or attempt to help me with:

    1. I am simply trying to deploy an app to a Windows Phone 8.1. It is registered as unlocked and recently was reset and has no developer apps on it, but whenever I try to deploy the app it gives me an error message that I have exceeded the maximum number of developer applications and to delete them (when there are zero on the phone)

    2. I registered and paid for a developer account, but the Windows Dev Center dashboard does not list my device as being unlocked. It lists no devices.

    3. When I try to run Preview for Developers on my phone, it asks for a Microsoft login. It is the same account as my developer account, yet it will not recognize it and sends me to a page to purchase a developer's account.

    Beside the obvious issue of having people pay for an account then refusing to provide support to get it to work, I am sort of stalled here. Any help would be greatly appreciated.

    • Merged by Barry Wang Thursday, November 3, 2016 12:51 AM The same problem
    Monday, October 31, 2016 8:36 PM
  • Hi Team,

    I recently got a windows developer (individual) account to create and deploy windows apps. I have a windows build that I would like to deploy to my phone. I have tried the following:

    1. Reset my phone 

    2. Renamed my phone

    3. Register the pone through windows 8.1 registration tool ( which says the device has been successfully unlocked). However I dont see my device listed under the "Unlocked devices" in the dev center

    4. When I try to deploy the application using the windows 8.1 deployment application, I get this error message - "the maximum number of developer applications on this phone has exceeded".

    Though there are no developer applications that I can see installed in the device.

    5. When I raised a support ticket for the same, I was informed that windows 8.x devices are no longer supported and I have to write in the forum to get help from the technical team

    Can you please help.

    My phone details: Lumia 535 
    windows OS 8.1

    Do let me know if you need further information from me.

    NOTE:

    I created this build using intel xdk , which we are currently using to get android and ios builds(works fine). So we wanted to check if we can use the xdk to create a windows build and test on a device to see how we can start supporting windows phone.

    Regards

    RAMYA M


    • Edited by ramyam Tuesday, November 1, 2016 3:42 AM
    • Merged by Barry Wang Thursday, November 3, 2016 1:13 AM same issue
    Tuesday, November 1, 2016 3:37 AM
  • When I deploy the build to phone  , I got the following error message

    "You have installed the maximum number of development apps. These apps are installed to your device when you start them in Visual Studio or when you use the App Deployment Tool. Please uninstall one of them and then try again."

    But I have no development apps installed on my windows phone .

    I also tried by

    1.resetting my phone

    2. removing my phone from device list of my microsoft account

    3. Renaming my windows phone name and tried again

    Now Im unable to continue my work due to this issue.I have two phones lumia 920 and lumia 635 ,both are behaving in same way.

    Please help me.If anyone know the solution.Im strucked .

    Thanks in advance for quick reply


    dinez

    • Merged by Barry Wang Thursday, November 3, 2016 1:06 AM same issue
    Tuesday, November 1, 2016 5:07 AM
  • Hello MarkinSD,

    >>but whenever I try to deploy the app it gives me an error message that I have exceeded the maximum number of developer applications

    I want to make sure about the following: is this the same app that you've developed before?

    >>I registered and paid for a developer account, but the Windows Dev Center dashboard does not list my device as being unlocked. It lists no devices.

    By saying the above, do you mean that you've checked the following page:

    https://developer.microsoft.com/en-us/dashboard/Account/Devices

    And when you are developing with your old Windows Phone 8.1 device, do you mean you are using the same account? If you are using different accounts you cannot list them on your developer account page.

    To resolve your problem I think the key point is your original account which is used for unlock your device, if it is possible please check whether you can remember your original account.

    Then please make sure you've followed the steps here(from lance's post) http://stackoverflow.com/questions/16196318/the-maximum-number-of-developer-applications-on-this-phone-has-been-reached and remember that you need to be sure that you have restart your phone.

    >>When I try to run Preview for Developers on my phone

    I haven't used this tool yet. So after I checked the official page:https://developer.microsoft.com/en-us/windows/develop/devpreview It seems you can post your question on a pro forum:

    https://go.microsoft.com/fwlink/p/?LinkId=324361

    Best regards,

    Barry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 1, 2016 12:15 PM
  • I am simply trying to deploy an app to a registered unlocked Windows Phone 8.1, and I keep getting an error message saying it is unable to install because I have exceeded the maximum number of developer applications on the phone when a) I just reset to OEM and b) have never put a developer application on the phone. I have a developer account as well.

    In addition, my developer account fails to show my phone under unlocked devices on the Dashboard at the Dev Center. And whenever I try to open Preview for Developers on my phone, it asks me to log in but doesn't recognize my developer account. I have tried requesting support through the Dev Center but they sent me to these forums.

    Any help would be greatly appreciated.

    • Merged by Oscar_Wu Wednesday, November 2, 2016 5:24 AM the same content
    Tuesday, November 1, 2016 5:50 PM
  • Hello I used to deploy my app to a Nokia Lumia device, but recently I've got a new one.
    So I registered it and unlocked for dev.
    But altough I've tried it many times redoing the whole process I can't deploy.

    The error is
    0x81030119 You cannot install the application. You have reached the maximum number of applications being developed for the device can be installed on this development. Please uninstall a previous developer application.
    I
    also can't deploy it through "Windows Phone Application Development" (same error) , which make me think it is not a VS issue.
    I've also noticed that even though "Windows Phone Developer Registration" tool tells me that my device is unlocked, I cant see it in my dashboard at devcenter in "Unlocked devices" section. 

    What can I do? I've got here after a long and unsucessfull talk with windows phone dev support.

    • Edited by Orseni Tuesday, November 1, 2016 8:23 PM
    • Moved by Mattew Wu Wednesday, November 2, 2016 7:36 AM
    • Merged by Barry Wang Thursday, November 3, 2016 12:53 AM The same problem
    Tuesday, November 1, 2016 8:22 PM
  • I am having the same exact issue.  Was working as of a few hours ago and now it is not!  It actually won't even let me unlock a new device for development.   

    Wednesday, November 2, 2016 12:03 AM
  • Same exact issue here.  Just showed up this afternoon.
    Wednesday, November 2, 2016 12:58 AM
  • Thanks for trying to help resolve this issue.

    Yes, I am having trouble deploying the same app.

    Yes, I have checked the DevCenter account/device page and my device is not listed, nor has it even been listed even though the phone AND the developer account are registered to the same Microsoft username/password.

    There is no original account. It's all one single Microsoft account.

    I have reset the phone twice now, and keep getting the same error message.

    I have scanned the forums and found a few posts about this very problem, but no verifiable solutions yet. As you can see from another post in this forum, it is not just me. Very frustrating. And again, thanks for the help.

    Wednesday, November 2, 2016 7:34 AM
  • Hi Orseni,

    This forum is used to discuss about the Dev Center account registration issue, I will move your thread to technical forum so that you will be assisted best.

    Thanks for your understanding.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, November 2, 2016 7:36 AM
  • Hi,

    I am developing silver light app.

    When I am trying to install XAP file on my device using Application Deployment tool I am getting following error

    "The maximum number of developer applications on this phone has been reached.Please uninstall a developer application", even I deleted all applications on device and I reset the device, still same error. Please advice

    Regards,

    Winit

    • Merged by Barry Wang Thursday, November 3, 2016 12:55 AM same issue
    Wednesday, November 2, 2016 11:06 AM
  • To whom it may concern,

    I am having problem to sideload my developer app to my wm phone 8.1 Lumia 430 which has just reset to factory default and using wm 8.1 sdk to register and unlock it. then I deploy my app to the phone and it said maximum limit reach for developer account. I do purchase the individual developer subscription and I check my dashboard info where the device of wm phone is empty list. Contact support before and ask me to wait for 48 hours and now it is over and result still the same. Please help out. urgent. Thank you. Raymond, ray@me-web.net

    • Merged by Mattew Wu Thursday, November 3, 2016 7:20 AM same issue
    Wednesday, November 2, 2016 11:34 AM
  • Hi,

    I am getting below error while deploying windows phone 8 application on device Nokia Lumia 1520.

    "Unable to install application. The maximum number of developer applications on this phone has been reached. Please uninstall a developer application and try again."

    To resolve this issue, I have tried below steps.

    1. Reset the device (Setting > About > reset your phone)

    2. Created one fresh windows live profile allytestapp@.

    3. Registered my device with above windows live id.

    4. Tried to deployed app in device. Getting same error.

    "Unable to install application. The maximum number of developer applications on this phone has been reached. Please uninstall a developer application and try again."

    Please help me out to resolve this issue.

     

    • Merged by Mattew Wu Thursday, November 3, 2016 2:07 AM same issue
    Wednesday, November 2, 2016 1:10 PM
  • @All

    Thanks for reporting this problem. I've already reported this problem and this issue is being investigated. 

    Thanks for your patience.

    Barry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Barry Wang Thursday, November 3, 2016 1:01 AM
    Thursday, November 3, 2016 1:00 AM
  • 5. When I raised a support ticket for the same, I was informed that windows 8.x devices are no longer supported and I have to write in the forum to get help from the technical team

    Can you please help.

    My phone details: Lumia 535 
    windows OS 8.1


    Hello,

    Windows Phone 8.1 are supported for the developer unlock to develop app, for more information, please check this article:
    https://support.microsoft.com/en-us/lifecycle/search?alpha=windows%20phone%208.1 .

    Could you please share your Support Ticket Number<SR> to us, in this way we can look at your issue more clearly with the related team?

    >>You have installed the maximum number of development apps) while deploying app to phone with no developer apps installed

    @All,

    I am sorry for any inconvenience caused for you.

    The related team are diagnosing this issue, I will update it in here once there is any update.

    Thank you very much!

    Best Regard,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Thursday, November 3, 2016 2:21 AM
    Owner
  • Hi All,

    We have tried to implement the developer unlock for our Windows Phone 8.1 device and it is working now.

    Could you please try to unregister the Phone from the Dev Center and register Phone again to see if it works? Please report it here if it does not work for you.

    Thank you.

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Barry Wang Monday, November 7, 2016 3:15 AM
    Thursday, November 3, 2016 6:35 AM
    Owner
  • Trying to deploy app and i get this error;

    Unable to install application.  The maximum number of developer applications on this phone has been reached.  Please uninstall a developer application and try again

    I have had a developer account since 2013 - paid the full fee back then for account and subscriptions each year till MS decision to scrap charges

    There are no developer apps on the phone - phone is Win 8.1

    I last deployed successfully in March with VS 2015 Pro (trial expired) - currently using VS Community (On Win 10)

    I use the SDK to unlock the phone but it does not show in my developer account when i log in

    If i disconnect phone from PC i have to use the SDK to unlock again

    Please do not suggest hard resetting my phone - i dont have a day to spare!

    Any help greatly apprieciated

    • Merged by Mattew Wu Thursday, November 3, 2016 8:42 AM Same issue
    Thursday, November 3, 2016 6:36 AM
  • Worked for me now following these instructions.
    I'm gonna check now deloying through VS, even though I guess it will work as well.

    Thank you
    Thursday, November 3, 2016 10:52 AM
  • Works for me as well through visual studio.
    Thursday, November 3, 2016 11:21 AM
  • It works rigth now... (I havent done anything to solve it, it just solved by itself )

    I will try to sum up: (sorry for my english)

    1. What I had:

     - new phone without development apps installed

     - active developer account

     - unlocked phone for development

    2. Noticed problems:

     - phone didnt appear in the list of unlocked devices on the page of my developer account

     - after unplugging phone from usb port, phone becomes locked again and I had to register it for development once more

     - problem occured on different developer accounts, with multiples phones (Windows Phone 8.1), on different machines with Visual Studio installed

    3. What I tried and didnt solve the problem:

     - unregistering the phone by Windows Phone Developer Registration tool

     - renaming the phone and re-registering

     - resetting the phone

     - deleting all aplications installed that could be uninstalled from the phone

     - changing to different phone, changing to different machines with visual studio and sdk installed, changing to another develeper account

    4. Noticed differences from current state when it works compared to state when it didnt:

     - after registering the phone for development, it appears in the list of unlocked devices on the page of my developer account

     - after unplugging phone from usb port, it still remains unlocked for development

    5. Conclusion:

    It looks like the problem occured because of some issues with process of registering the phone for development, but I would be good if someone could provide the answer what caused it.

    regards,

    Nedved83

    Thursday, November 3, 2016 12:55 PM
  • Thank you, It's working fine.

    Thursday, November 3, 2016 2:21 PM
  • Though there may have been a delay in my account/ phone registration occurring this may solve YOUR issue as it did mine => in VS top right hand corner is yr personalization account name.  Click this and choose Account Settings.  In the window that opens look for your license information under Visual Studio version.  If the details look incorrect then click  "Check for an Updated license"  This caused an internet check and the product changing from evaluation to register to me.  I can now see my phone in the 'dev centre unlocked phones' and all apps deploy/work.

    This whole system seems complicated and complex and full of pit falls.  Can the forum Admin create a complete section on these issues and list the fixes that are reported as a possible solution?  It would save hours of internet searching (in my case 2days).

    • Proposed as answer by Speedywheel Thursday, November 3, 2016 4:43 PM
    Thursday, November 3, 2016 4:43 PM
  • Hi amy,

     again problem facing when deploy application(xap)  from Application deployment tool (xap) it's giving error  "the parameter is incorrect".please provide any solution.

    Thanks,

    Winit

    Tuesday, November 15, 2016 10:11 AM