locked
[Desktop Converter]What is Mininum OS Requirement for DesktopBridge Converted Apps ? RRS feed

  • Question

  • Hi,

    I have a WPF App, converted using DesktopBridge.  I am able to do install (Without Store) on Win10 OS.

    Now can I install this app on a Win8 or Win8.1 OS ?

    When I tried it throws some error.

    Add-AppxPackage : Deployment failed with HRESULT: 0x80080204, The Appx package's manifest is invalid.
    error 0x80080204: App manifest validation error: The document root element m:Package must be defined in the
    http://schemas.microsoft.com/appx/2010/manifest namespace.
    NOTE: For additional information, look for [ActivityId] 63df8476-35c1-0000-e085-df63c135d201 in the Event Log or use
    the command line Get-AppxLog -ActivityID 63df8476-35c1-0000-e085-df63c135d201

    Please advice.

    Regards



    Thursday, November 3, 2016 12:17 PM

All replies

  • Hi Richard Freytag,

    >>”Now can I install this app on a Win8 or Win8.1 OS ?”

    No. UWP package cannot be installed on windows 8 or 8.1.

    The minimum OS requirement should be the last release of the windows 10 Anniversary Update.

    It’s because desktop bridge involved “full trust capability”, it’s available from windows 10 Anniversary Update.

    More information, please refer to this article: Desktop Bridge – The bridge between desktop apps and the Universal Windows Platform 

    Best Regards,

    Xavier Eoro


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 4, 2016 6:27 AM