none
Kinect v2 keeps disconnecting after every 10 seconds on windows 10 1903 RRS feed

  • General discussion

  • I know there are other questions about this problem on previous windows version 1809 but it is still happening in windows 1903.

    I tried some solutions found around the web but they didn't work for me.

    My pc is HP Pavilion Power 15cb007nl with intel core i7 7700HQ with nvidia GeForce 1050.

    There are any solution on windows 1903?

    Sunday, July 28, 2019 8:22 PM

All replies

  • Same here, Using Kinect v2 with the Adapter to connect to the PC (Win10 1903).

    Turns on and Off when trying to use it.

    -Tried two different PC's, acts the same
    -Tried All possible SDK's,Visual studio, features updates and drivers
    -Audio settings for the Kinect, always on, listen to this device on and working (i can hear my voice)
    -Multiple other solutions on the internet forums.

    nothing works, I also have USB 3.0 yellow warning, but the device was installed successfully and only turns off when trying to check the depth sensor for example, turns on for a couple seconds. Dies. Reconnects to PC. Repeat.

    Really frustrating. I wanted to use it for some simple mocaps and play around with it, hardware is really well thought out, but the software side keeps me from using it :I

    Sunday, August 4, 2019 10:43 AM
  • Hello. I'm also trying to get a Kenect v2 (Kinect One?) to work on my computer as part of an interactive project. My desktop computer is running Windows version 1903 (OS Build 18362.10013) and the kinect disconnects repeatedly, as others have reported. I did install a USB add-in card, as I read somewhere that this might be the issue, but this didn't solve the problem. Interestingly, the Kinect works flawlessly on my surface which is also running Windows 1903, but the OS build is different (18362.239). Given the nature of the project I'm working on I really was hoping to do this on my desktop - I'm not sure how to go about changing to a different OS build or if that would even solve the problem - can anyone offer advice?
    Monday, August 12, 2019 7:53 PM
  • I fixed it for myself on 1903 just now. Had to go to "Microphone privacy settings" and turn on the switch for "Allow desktop apps to access your microphone". "KinectService.exe" should actually be listed on that setting panel, if your software setup is correct. Also in Device Manager, you should have "WDF KinectSensor Interface 0" with driver 2.2.1811.10000 (provided automatically). You should also see the Kinect as an enabled audio recording device, both in Device Manager, and under the advanced "Sound" settings menu. If it's disabled, in either place, it starts doing the 8-10 second disconnect loops again.

    I think the Kinect service is designed to test the microphone, and then, if it's not able to access the microphone, to repeatedly disconnect and reconnect the device until it has sound input. Which makes sense, because in Device Manager, the audio device portion of the Kinect ("Xbox NUI Sensor") is the one constantly disappearing and reappearing when the interruptions occur. At least, this was the issue in my case.

    Monday, September 16, 2019 5:48 AM
  • Did ABHelper's solution worked for anyone else that had issues after updating to 1903?

    Thanks.

    Bryan

    Thursday, September 26, 2019 6:43 AM
    Moderator
  • Yes. It did for me. And it's stupid. In my case I had disabled the array mic for privacy, and now just made it's levels 0.
    Monday, September 30, 2019 6:51 PM
  • FINALLY!!!!! I DO FIXED the problem after turning on the "Allow desktop apps to access your microphone" switch!!!!
    • Edited by imzhken Sunday, October 13, 2019 11:05 AM
    Sunday, October 13, 2019 11:04 AM