locked
To build Store App for Win8/8.1, which OS/VS combination is correct?

    Question

  • Hi,

    I'm confused about this situation. To build Store App for Win8 or 8.1, which OS/VS combination is correct?

    Let me complete this table. Could you correct or fill this?

    It will help to select the correct combination of OS and VS.

    BuildEnv/TgtApp StoreApp for Win8 StoreApp for Win8.1 (*1)
    Win8 + VS2012 OK NG
    Win8 + VS2012 + Win8.1 SDK OK NG
    Win8 + VS2013 Pro/Ent ??? ???
    Win8.1 + VS2012 ??? NG
    Win8.1 + VS2013 Pro/Ent Existing Project - OK
    Create New - NG
    OK
    Win8.1 + VS2013 Express ??? OK

    *1 'Store App for Win8.1' - Store App that use new Win8.1 API, XAML def, etc.

    best regards,

    Friday, June 28, 2013 4:05 PM

Answers

  • VS2012 can do Windows 8 apps on both Windows 8 and 8.1. VS2012 doss not support Windows 8.1 apps.

    VS2013 supports Windows Store apps only on Windows 8.1, not on Windows 8. VS2013 Express supports Windows 8.1 apps only, not Windows 8 apps (it can upgrade them). VS2013 pro, ultimate, etc. can open, but not create, Windows 8 upon Windows 8.1.

    BuildEnv/TgtApp StoreApp for Win8 StoreApp for Win8.1 (*1)
    Win8 + VS2012 OK NG
    Win8 + VS2012 + Win8.1 SDK OK NG
    Win8 + VS2013 Pro/Ent Not supported Not supported
    Win8.1 + VS2012 Supported NG
    Win8.1 + VS2013 Pro/Ent Existing Project - OK
    Create New - NG
    OK
    Win8.1 + VS2013 Express

    Not supported

    OK

    --Rob

    • Marked as answer by pnp0a03_MVP Friday, June 28, 2013 9:20 PM
    Friday, June 28, 2013 7:42 PM
    Moderator

All replies

  • VS2012 can do Windows 8 apps on both Windows 8 and 8.1. VS2012 doss not support Windows 8.1 apps.

    VS2013 supports Windows Store apps only on Windows 8.1, not on Windows 8. VS2013 Express supports Windows 8.1 apps only, not Windows 8 apps (it can upgrade them). VS2013 pro, ultimate, etc. can open, but not create, Windows 8 upon Windows 8.1.

    BuildEnv/TgtApp StoreApp for Win8 StoreApp for Win8.1 (*1)
    Win8 + VS2012 OK NG
    Win8 + VS2012 + Win8.1 SDK OK NG
    Win8 + VS2013 Pro/Ent Not supported Not supported
    Win8.1 + VS2012 Supported NG
    Win8.1 + VS2013 Pro/Ent Existing Project - OK
    Create New - NG
    OK
    Win8.1 + VS2013 Express

    Not supported

    OK

    --Rob

    • Marked as answer by pnp0a03_MVP Friday, June 28, 2013 9:20 PM
    Friday, June 28, 2013 7:42 PM
    Moderator
  • I could understand well, thanks to Rob.
    Friday, June 28, 2013 11:00 PM