none
Why I get errors "the system administrator has set policies to prevent this installation" in remote desktop sessions. RRS feed

  • Question

  • I used Azure Remote Desktop environment. 

    When I try to install a msi package, if I don't change EnableMsi settings, it will give me "the system administrator has set policies to prevent this installation" error.

    My questions: why by default RDP is rejecting msi installs? Is msi incompatible with remote desktops? Or just for a security reason.

    Friday, October 18, 2019 12:15 AM

Answers

  • Hi,

    Thanks for posting here.

    This setting is located at Local Group Policy Editor(Click Start > Run. Enter gpedit.msc) > Computer Configuration > Administrative Templates > Windows Components > Windows Installer:

    Turn off Windows Installer

    The description of this policy is "If you enable this policy setting, you can prevent users from installing software on their systems or permit users to install only those programs offered by a system administrator."

    Obviously, there is no mention of compatibility, nor is it totally all about security.  This policy setting affects Windows Installer only. It does not prevent users from using other methods to install and upgrade programs.

    Notice that if a process occupies the windows installer, other processes will not be able to use Windows Installer then.

    Best Regards,

    Drake


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by singer-neu Monday, October 21, 2019 10:29 PM
    Friday, October 18, 2019 3:15 AM
    Moderator