The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Developing Universal Windows apps!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
windows phone 8.1 install RRS feed

  • Question

  • I migrated my store app from Silverlight to Windows phone 8.1. If the app is updated direct from the store without uninstalling the previous app, the app after installation launches direct to the page where it was when the installation took place and bypasses the login.  As a result there is no data to show.  Some clients are experiencing app crashes directly after installation if the previous app is not uninstalled.  I have spent a lot of time with the suspend and resume functions in the App class trying to debug this.  Can you please help me as I don't know where I should look to rectify this.  I have also observed this for phone 8.1 to 8.1 app installs.
    Wednesday, February 11, 2015 1:01 AM

Answers

  • It sounds like it's logging in automatically because the credentials it uses are still in the app data folder.  You should create a flag to see if this is the first time they've run this version of the app, then force a login if it is.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Wednesday, February 11, 2015 4:06 PM