locked
unable to activate windows metro style application <guid> the metro style application does not support the contract specified it is not installed

    Question

  • I am getting the following error with my windows 8 app not after not touching it for a week or two any idears?

    Thanks

    Aaron

    Thursday, May 10, 2012 10:18 AM

Answers

  • I have not seen this error, but here are a couple of things that I would try.

    1. Uninstall the app from the Start screen and try again.
    2. Increase the build number in the manifest and try again.
    Monday, June 24, 2013 3:50 AM

All replies

  • Is this on DP or CP? 


    Matt Small - Microsoft Escalation Engineer - Forum Moderator If my reply answers your question, please mark this post as answered.

    Thursday, May 10, 2012 8:29 PM
    Moderator
  • I am having this issue with Release Preview. Anyway to get around this error?
    Thursday, August 2, 2012 10:07 PM
  • I am also seeing this but I'm using the full version of Windows 8. This just started happening after I linked the app to the store.
    Monday, June 24, 2013 3:40 AM
  • I have not seen this error, but here are a couple of things that I would try.

    1. Uninstall the app from the Start screen and try again.
    2. Increase the build number in the manifest and try again.
    Monday, June 24, 2013 3:50 AM
  • I checked the event viewer and I am seeing this message for the app in question:

    is not registered for the Windows.Launch contract or is not installed.

    Monday, June 24, 2013 3:57 AM
  • Tried both of those things and the problem still persists. There doesn't appear to be anything different from this app and my other apps in the package manifest or anything so its hard to tell what's wrong with it. The output window says that it deployed successfully.
    Monday, June 24, 2013 4:03 AM
  • Open the Package.appxmanifest click on the Packaging tab and change one digit of the Package name to any other digit (the Guid shown on the above image starts with 43....., change the 4 to 5 or some other number). You may have to re-associate your app with the store.

    Good luck,

    Hassan

    Monday, June 24, 2013 4:22 AM
  • that fixed it for me, raising the build number, thank you thank you thank you
    Saturday, August 10, 2013 3:00 PM