The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Developing Universal Windows apps!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
appxupload file is not generated RRS feed

  • Question

  • When I want to create app packages, compilation is successful, but the appxupload file is not created. The AppPackages folder contains only the App_1.0.0.0_Test subfolder. This happened after I installed Visual Studio 2015 Update 1. I have reproduced this problem on two physical PCs. I can run and debug the app on local machine normally. I tried to clean the solution and build the app in Release configuration to all three ARM, x86 and x64 platforms separately. It succeeds, but when I want to create a Store package, it is missing.
    Wednesday, December 2, 2015 8:32 PM

All replies

  • Same issue

    .appxupload is not created with Visual Studio Tools for Universal Windows Apps 1.2

    In prev. version of Visual Studio Tools for Universal Windows Apps 1.1.1 i can create .appxupload with "/p:AppxPackageIsForStore=true" like this
    "C:\Program Files (x86)\MSBuild\14.0\Bin\msbuild.exe" "C:\Users\user1\Documents\Visual Studio 2015\Projects\App1\App1.sln" /p:AppxPackageIsForStore=true /p:Configuration=Release

    UseDotNetToolChain is also set.

    Thursday, December 3, 2015 6:56 AM
  • I have discovered that this issue is somehow related to the project configuration. When I create a blank Universal Windows app, the appxupload package is generated. My project references one Windows Runtime Component and one Class Library and I don't target Any CPU platform. The Output window shows that An app bundle has been successfully built for Release (x86), Release (x64), Release (ARM). But the appxupload file is missing.
    Thursday, December 3, 2015 12:19 PM
  • I have recreated the solution file and all project files but the problem still persists. There are no errors during compilation. After removing all analyzers there left 3 warnings:

    1. Invalid IL detected in method 'System.Void System.Progress.InvokeHandlers(System.Object)' at IL offset 0x1.
    2. Method 'CreateLambda' within 'System.Linq.Expressions.Expression' could not be found.
    3. Method 'ParameterIsAssignable' within 'System.Linq.Expressions.Expression' could not be found.
    Saturday, December 5, 2015 1:59 PM
  • Hi,

    Based on your description, I try the following steps to reproduce this issue.
    1. Create a blank Universal Windows App.
    2. Create windows runtime component
    3. Create one library
    4. Add reference
    5. Don't target any CPU platform to package the app
    However, the appxupload pakcage is generated. I would suggest you to check more carefully and give more detailed steps for us to reproduce this issue.

    Best Regards,
    Jambor 

     

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, December 17, 2015 8:52 AM
    Moderator
  • Did you resolve the issue? Could you share your solution? I have the same problem
    Thursday, January 7, 2016 2:34 PM
  • To successfully generate the appxupload file we require that the project is associated with the Store app (Project > Associate with Store…) or use packaging wizard, and select ‘Yes’ when asked to associate the app with the store.

    Also, verify that the store association file is present in your project. The file needs to be present on disk and must be referenced in the appropriate .csproj; that’s where we get the file path.

    The content type of the file must be set to “None” and should look like this in the .csproj file:

    <ItemGroup>

                <None Include="Package.StoreAssociation.xml" />

    </ItemGroup>

    If using a build script, we recommend that you replace the flags “AppxPackageIsForStore” and “BuildAppxUploadPackageForUap” with the new flag “UapAppxPackageBuildMode=StoreUpload

    The BuildMode flag will set the other required flags and invoke the right validations (including checking for store association) to produce a .appxupload package.

    Hope this helps.


    Abdulwahab Suleiman

    Thursday, January 7, 2016 9:37 PM
  • Hi,

    I have the same issues. I can build appxupload files for all platforms (Windows Phone, Windows 8.1) but cannot for Windows 10. The build process always produces the folders mentioned by Václav. This started to happen after some VS update. At the moment I'm on Community 2015 v 14.0.24720.00 update 1.

    My app is associated with the store. The Package.StoreAssociation.xml is in the root of the project it's action is none and I had completely no troubles with building appxupdate files for Windows 10 in the previous version. Today I wanted to post a new version of my app but it seems there's no way and I must remove the Windows 10 packages and upload only Windows Phone and Windows 8.1 packages.

    I've also tried msbuild.exe and commandline and it builds with no errors, but also doesn't produce appxupload. Of course I've tried all the possible parameters like the abovementioned UapAppxPackageBuildMode=StoreUpload. 

    Please help me with that issue. My project is using Cordova Tools. Maybe some clue will be that the "Project / Store" menu has two disabled items: "Upload app package" and "Reserve app name". I did the process of building appxupload packages several times in the past. And I must say that you put so many obstacles for developers that I'm loosing my patience for the Windows platform. And today this new issue got me. I hope there's a quick solution that wouldn't require me to reinstall all these GBs of software once again.

    Regards,
    Rafal


    Monday, January 18, 2016 12:06 AM
  • Hi,

    Just found a solution... 

    I've removed 

    <None Include="$(MSBuildThisFileDirectory)Package.StoreAssociation.xml" />

    from CordovaApp.projitems

    and added it to the project file:

    CordovaApp.Windows10.jsproj

    as:

    <ItemGroup>
          <None Include="Package.StoreAssociation.xml" />
    </ItemGroup>

    and the msbuild have done the appxupload. Visual Studio also started to build appxupload for Windows 10 Mobile.

    • Proposed as answer by Cream Software Monday, January 18, 2016 1:15 AM
    Monday, January 18, 2016 1:13 AM
  • Hi Václav Dajbych,

    Does your issue has been fixed? Please feel free come back, if your find solution from above reply, please mark it as answer, if not, please give more information here.

    Best Regards,

    Jambor 


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, January 19, 2016 9:40 AM
    Moderator
  • Hi,

    We are also facing the similar issue. We could not generate appxupload file. We can't associate the app to store account, because we want to publish the app to "Sore for Business". If we select "yes" while creating package, it is asking for "Sign in to Windows Store". but It is not accepting our Windows Store Account which ends with "@andersencorp.com", not with Hotmail or anything. So we are keep generating packages by selecting "No" in the first step when it asks for "Do you want to Build Package To upload to the Windows Store". By doing that we are able to generate only AppxBundle or appx files. We could not able to generate "appxupload" file.

    We are crating package with options "Release" and "x64 platform" only.  By default "Compile with .NET Native Toolchain" is checked.  So, when we tried to upload appxBundle or appx into dev.windows.com site, We are getting the error

    "Package acceptance validation error: You cannot submit pre-compiled .NET Native packages. Please upload the Store appxupload file and try again."

    After that we un-checked "Compile with .NET Native Toolchain" in the project properties and created package. This time we got the error:

    "The declared package dependency does not exist.
    Dependency: Microsoft.NET.CoreRuntime.1.0. Minimum version: 1.0.23430.0. Please upload the .appxupload file generated by Visual Studio for the Store. <a href='http://go.microsoft.com/fwlink/?LinkId=620193' target='_blank'> Learn more"

    We tried so many ways and searched in the web to know how to solve this problem, but we couldn't fixed it. Please help us.


    Thursday, January 28, 2016 3:40 AM
  • Deleted
    Sunday, February 21, 2016 5:57 PM
  • Also running into this issue.
    Tuesday, March 29, 2016 2:40 AM
  • Seems the solution to my problem was that I had unselected 'compile using .Net native' in the project properties. I had unchecked this because it was causing a crash in my app. Fixing the crash (caused by an unsafe type conversation in a PCL) allowed me to compile with .Net native, and vuala. Sunshine, rainbows an unicorns.
    Tuesday, March 29, 2016 6:12 PM
  • I have followed all the steps and I have the same problem. Everything comples without errors and I can create app packages but it is still missing .appxupload or msixupload.
    Monday, February 25, 2019 11:10 PM