none
[WP8.1]Windows Phone 8.1 App not deploying on device RRS feed

  • Question

  • I have created an Mobile App for Windows Phone 8.1 using tools for Apache Cordova. When trying to sideload the app using the windows phone 8.1 application deployment tool i receive an error "Error - A packaging error prevented this application from installing". Does anyone know what this means, the cause and how to fix it? The process is inconsistent as there are times it works without issues and other times it doesn't work constantly any ideas.
    Thursday, April 14, 2016 1:22 PM

All replies

  • Have you developer unlocked the phone?

    http://pauliom.wordpress.com

    Thursday, April 14, 2016 1:54 PM

  • Hello Nathanael Dennis,

    >>"A packaging error prevented this application from installing"

    The error seems telling us your package is corrupt. What package did you create?

    >>The process is inconsistent as there are times it works withoutissues and other times it doesn't work constantly any ideas.

    For this I agree with pkr2000. And for more details please check whether there are differences between your above two scenarios.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 15, 2016 5:26 AM
    Moderator
  • yes my phone is unlocked for development
    Friday, April 15, 2016 10:38 AM
  • Hi thanks for your reply. When i created an app package i go through project/store/create app package on visual studio. The type of app i packaged is a Windows Phone(Universal) which creates an .appx file. Is this what you were referring to?
    Friday, April 15, 2016 10:45 AM
  • looks like i may have narrowed it down. when the app is unsigned it deploys correctly but when i sign the app using the "signtool" it fails to deploy. My conclusions are that creating an app that targets windows phone 8.1, signing using "signtool" from windows 10 sdk and deploying using the windows phone 8.1 application deployment has caused a corruption. Is this correct.
    Friday, April 15, 2016 3:00 PM
  • Hello Nathanael Dennis,

    Thanks for the reply.

    So the problem seems related to the signtool step. Do you have any specific certificate?

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 19, 2016 1:53 PM
    Moderator
  • hi yes i am using a Symantec enterprise certificate 
    Tuesday, November 29, 2016 2:04 PM