none
Windows Phone Developer Registration 8.1 - error 0x64 RRS feed

  • Question

  • I've recently beed trying to register my phone for developer usage via the Windows Windows Phone Developer Registration (8.1) tool and I stumble upon this error:

    "Status: Error communicating with the Windows Phone Dev Center. Set The correct date and time on the phone, check your Internet connection, and try again. (ErrorCode:0x64)"

    I hit retry twice and the tool hangs a while on:

    "Status: Logging into the Windows Phone DevCenter..."

    and then stops on error:

    "Status: Error logging into the Windows Phoen Dev Center. Check your Microsoft Account credentials and try again"

    My phone is Nokia Lumia 925 with Widnows Phone 8.1, and computer OS's I've tried are Windows 8.1 and Windows 10 - everything with the latest updates available.

    As suggested in similar situations found on the web I've tried multiple scenarios of trying to fix this problem, including:

    - switch off automatic date/time on phone
    - synchronize manually time, date, time zone, all languages on both computer and phone
    - reboot the phone
    - reboot the computer
    - reset the phone to system defaults
    - switch on/off localization, internet sharing, bluetooth
    - different computers
    - different WiFi networks
    - with/without SIM card
    - cellular data on/off
    - clear all data related to microsoft accounts in credential manager
    - sign out (in IE) from outlook, onedrive, microsoft accounts
    - check local hosts file for anything related to windows/microsoft
    - run fiddler to analyze the traffic during registration. What's interesting is that the response from deviceunlockservice.windowsphone.com:443 has status code 200. There were no error connections in fiddler
    - restart IpOverUsbSvc service
    - confirm that there is no proxy authentication on the network

    As of now, after a couple of days, I've run out of ideas what to try next. I know the problem has happened to others but all the solutions don't seem to work for me, I will be gratefull for any help


    • Edited by ijacek7 Monday, May 23, 2016 12:45 PM
    Monday, May 23, 2016 11:13 AM

Answers

All replies

  • I'm having the same problem. Was able to dev. unlock this phone multiple times, in the past.

    If they've decided that no one should be doing new work on WP 8.1 apps and simply won't allow these phones to be unlocked anymore, I'm throwing this phone in the river and buying an Android (as much as I hate Android)

    Monday, May 23, 2016 12:41 PM
  • Same problem.. Nokia 920 WP8.1 with Windows 10 PC. I tried many things (time, location, restart both, another PC), but still Error Code 0x64. It's annoying :(
    Monday, May 23, 2016 2:56 PM
  • Same problem. Windows phone 8.1 Lumia Denim 640 XL. Windows 10 PC. I've tried reset, change timezone, location...Nothing seem to work
    Monday, May 23, 2016 4:00 PM
  • I am having the same problem. I have been through all the steps and tried multiple computers, networks and phones with no luck.
    Monday, May 23, 2016 11:26 PM
  • Same problem.. I dont know, what to do now.. Lumia 535. Maybe error on Microsoft side..
    Monday, May 23, 2016 11:36 PM
  • Hi, I am having the same issue. Have tried all suggestions as well.
    Tuesday, May 24, 2016 1:25 AM
  • I have the same problem with a Lumia 625 (8.10.14219.341) and Windows 10 PC (10.0.10586) with Visual Studio 2015 Update 2. It used to work.


    • Edited by Erik____ Tuesday, May 24, 2016 9:19 AM
    Tuesday, May 24, 2016 9:04 AM
  • Same here and multiple attempts on multiple computers with multiple phones. To my luck i got a windows 10 phone lying around already unlocked.
    Tuesday, May 24, 2016 11:53 AM
  • Same problem.  Phone is WP 8.1, Update 2.   Tried 2 Dell OptiPlex (Win 10 / Win 8.1), and a Dell Inspiron (Win 10).  It looks like this problem hits about 10 developers per day, just in this one forum.  It makes it tough to write Windows Phone apps. 
    Tuesday, May 24, 2016 12:22 PM
  • I'm having the same problem. I tried on 3 different phones, 3 different PC with different Windows version, logged in 3 different microsoft account and also tried to fix this problem as you wrote. Nothing help me. Maybe error on Microsoft side?
    Tuesday, May 24, 2016 12:58 PM
  • Hello All,

    We identified the root cause and you should be able to unlock WP8.1 and up devices now (Please note that W10 devices are unlocked via the device's settings)

    If you still need assistance please open a support request.

    -Eric


    Contact Dev Center Support


    Tuesday, May 24, 2016 5:21 PM
    Owner
  • It works now! Thanks to Eric D and Microsofties.

    I've created and run a WP app on my USB-connected phone (HTC One M8; Windows 8.1 Update 2), so I think I'm good to go.

    P.S. I've got a Dell OptiPlex desktop that doesn't even support SLAT, but with the phone working, I can pass on the emulators until I upgrade the desktop PC (and get a Win 10 phone).

    Thanks again.

    Tuesday, May 24, 2016 11:43 PM
  • Ahh, thank you very much. It's really working... N920 Win8.1 and Win10 PC => registration complete:]
    Wednesday, May 25, 2016 5:02 PM