none
Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Question

  • I get this error when installing VS 2015 Community RC.  I'm installing on Windows 10 build 10074.  I tried uninstalling VS and tried performing the steps from other known issues... Change > Custom > Select feature > Update.

    I also get the other errors as well...

    Emulators for Windows Mobile 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Emulators for Windows Mobile 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Thursday, April 30, 2015 12:16 PM

Answers

  • Hi. I'm sorry you're running into these issues.

    We've fixed this issue, and have released an update as of 7PM PDT 30 April 2015.

    New installs of Visual Studio 2015 RC should expect to no longer encounter this problem, unless you lose your internet connection during installation. (That is, this error now indicates that the Windows SDK or Windows Emulator setup invoked by Visual Studio setup has lost internet connectivity and cannot download necessary files.)

    • To fix the issue, re-run setup and select the features "Universal Windows App Development Tools" and/or "Emulators for Windows Mobile" again.

    If you have already installed Visual Studio and encountered this problem, you can now modify your Visual Studio installation to successfully install.

    • Go to Program & Features, select Visual Studio 2015 RC, and select Change. Click Modify, then select the features "Universal Windows App Development Tools" and/or "Emulators for Windows Mobile", and click Update.
    • Note that "Universal Windows App Development Tools" will be already selected. This is expected. Keep it selected, and click Update.

    An alternate solution is to install the Windows 10 SDK and Windows Emulators separately. Go to https://dev.windows.com/downloads/windows-10-developer-tools. Scroll to the bottom of the page and install the Windows 10 SDK and Windows 10 emulators outside of Visual Studio setup.

    Thanks!

    -Paul

    (I'll update this post with additional information as I have it)

    Thursday, April 30, 2015 3:18 PM

All replies

  • Same here for the first error- on clean win 10 preview in a VM (vmware player).
    Thursday, April 30, 2015 12:28 PM
  • Same issue here, on a Surface Pro 3.

    I've tried all I can think of, including a full reinstall of the OS (10074). Basically it always fails with the errors below.

    Launching VS I do have the UAP templates installed, but not the emulators. I can create a new Windows Universal app no problem, however it shows up as a Windows 8.1 type in the properties pane. Missing lots of references so obviously nothing builds.

    Tried installing the tools separately (the ones linked by Paul Chapman in a separate thread). These installed fine, and gave me the emulators (at least in the drop down, haven't been able to verify they work as nothing else works). Proceeded to "repair" the VS install after this and at that point the install completed without errors, however nothing still works inside VS. Then proceeded to "modify" and remove any Universal app stuff, rebooted and reinstalled, only to get the same error again and back at square one.

    Tried, as far as I can remember, fresh installs from both the ISO and webinstaller (as there was some talk about the ISO containing older code and missing some tools).

    Spent a week trying to get a Win10 rig up now, to no avail. Previous builds (with CTP6) would give me a UAP mobile install error, which seemed linked to Hyper-V not working, however Hyper-V was working just fine...

    Oh, and obviously - No, I did not cancel the install myself.

    Here are some relevant lines from the install log,
    [060C:0CF0][2015-04-30T14:20:08]i000: MUX:  Source confirmed
    [060C:1994][2015-04-30T14:20:14]i000: MUX:  Finished connecting secondary installer pipe
    [060C:14D4][2015-04-30T14:20:19]i000: MUX:  Updating secondary installer progress display name: Windows 10 SDK 10.0.10069
    [060C:14D4][2015-04-30T14:20:25]i000: MUX:  Updating secondary installer progress display name: Tools for Windows 10 Universal Apps (Windows SDK 10.0.10069)
    [060C:044C][2015-04-30T14:28:13]i000: MUX:  ExecuteError: Package (VSSecondaryInstaller_box) failed: Error Message Id: 1603 ErrorMessage: Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294
    [0288:0054][2015-04-30T14:28:48]e000: Error 0x80048646: Process returned error: 0x80048646
    [0288:0054][2015-04-30T14:28:48]e000: Error 0x80048646: Failed to execute EXE package.
    [060C:044C][2015-04-30T14:28:48]e000: Error 0x80048646: Failed to configure per-machine EXE package.
    [060C:044C][2015-04-30T14:28:48]i000: MUX:  Installation size in bytes for package: VSSecondaryInstaller_box MaxAppDrive: 0  MaxSysDrive: 2063301632  AppDrive: 0  SysDrive: 2060471296
    [060C:044C][2015-04-30T14:28:48]i000: MUX:  ExecutePackageComplete for secondary installer
    [060C:044C][2015-04-30T14:28:48]i000: MUX:  Disconnecting secondary installer pipe
    [060C:044C][2015-04-30T14:28:48]i000: MUX:  Return Code:0x80048646 Msi Messages:Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294 Result Detail:0 Restart:None
    [060C:044C][2015-04-30T14:28:48]i000: MUX:  Set Result: Return Code=-2147187130 (0x80048646), Error Message=Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294, Result Detail=, Vital=False, Package Action=Install, Package Id=VSSecondaryInstaller_box
    [060C:044C][2015-04-30T14:28:48]i000: Setting string variable 'BundleResult' to value '0'
    [060C:044C][2015-04-30T14:28:48]w350: Applied non-vital package: VSSecondaryInstaller_box, encountered error: 0x80048646. Continuing...

    Think I'll go buy a Mac...

    Thursday, April 30, 2015 12:49 PM
  • Same here, tried repairing and updating both VS install and Tools for Window 10, even refreshed Windows install and tried again, every time the same error.

    I'll try web installer now, maybe it'll work for me...

    EDIT: Looks like the download page https://www.visualstudio.com/en-us/downloads/visual-studio-2015-downloads-vs.aspx is down. Maybe we'll get updated installer soon.



    Thursday, April 30, 2015 12:56 PM
  • Same problem here...

    Tried to install on an recently upgraded 10074 build (coming from 10061, last week build). Tried all sort of repair, uninstalls, and stuff. Finally, I reinstalled Windows 10 TP 10074 from scratch and still, I get the same errors...

    Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Emulators for Windows Mobile 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Emulators for Windows Mobile 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Thursday, April 30, 2015 1:07 PM
  • I'm getting the same error on three machines. I tried install the latest bits to three machines (Surface Pro 3 and two laptops). Two of the devices had the old bits (which I uninstalled first).  The final device was a fresh install.  I chose "Custom" install and made sure that the new Universal Apps was selected.  I also tried to re-install the Tools separately with no luck. 

    Emulators for Windows Mobile 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Emulators for Windows Mobile 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294


    • Edited by Bayprince Thursday, April 30, 2015 1:59 PM
    Thursday, April 30, 2015 1:58 PM
  • I'm having the same issue. I have tried so many different things. Hopefully, Microsoft knows about this and has a fix soon. They need to pay attention to this if they want us to start looking into building apps.
    Thursday, April 30, 2015 2:12 PM
  • Exact same issue for me. Windows 10 build 10074, VS 2015 Enterprise RC.
    Thursday, April 30, 2015 2:32 PM
  •   same here on surface pro and two laptops
    Thursday, April 30, 2015 2:44 PM
  • glad it's not just me. getting this on my desktop and Surface Pro 3.

    Thursday, April 30, 2015 3:03 PM
  • Exactly same problem with me. I tried on fresh 10074 installations on VMware machines and Surface pro 3...tried the ISO image, and the web installer, and all combinations to install the windows tools...still same issue. Funny that the thread  for Win10SDKToolsIssues  was "closed". The solution proposed there does not work (everyone in this thread has tried already...)

    Thursday, April 30, 2015 3:17 PM
  • Hi. I'm sorry you're running into these issues.

    We've fixed this issue, and have released an update as of 7PM PDT 30 April 2015.

    New installs of Visual Studio 2015 RC should expect to no longer encounter this problem, unless you lose your internet connection during installation. (That is, this error now indicates that the Windows SDK or Windows Emulator setup invoked by Visual Studio setup has lost internet connectivity and cannot download necessary files.)

    • To fix the issue, re-run setup and select the features "Universal Windows App Development Tools" and/or "Emulators for Windows Mobile" again.

    If you have already installed Visual Studio and encountered this problem, you can now modify your Visual Studio installation to successfully install.

    • Go to Program & Features, select Visual Studio 2015 RC, and select Change. Click Modify, then select the features "Universal Windows App Development Tools" and/or "Emulators for Windows Mobile", and click Update.
    • Note that "Universal Windows App Development Tools" will be already selected. This is expected. Keep it selected, and click Update.

    An alternate solution is to install the Windows 10 SDK and Windows Emulators separately. Go to https://dev.windows.com/downloads/windows-10-developer-tools. Scroll to the bottom of the page and install the Windows 10 SDK and Windows 10 emulators outside of Visual Studio setup.

    Thanks!

    -Paul

    (I'll update this post with additional information as I have it)

    Thursday, April 30, 2015 3:18 PM
  • Same issue here
    Thursday, April 30, 2015 3:31 PM
  • Thanks Paul. The page returns "The resource cannot be found.". Are you aware?

    Yves Dolce

    Thursday, April 30, 2015 4:01 PM
  • Here's the direct download for the Windows 10 SDK 10.0.10069:

    http://download.microsoft.com/download/A/1/7/A170091F-528C-485B-8120-76D71C205105/standalonesdk/sdksetup.exe

    I installed it using default options, rebooted,  and then ran repair on VS 2015. I created a blank Windows Universal project that I was able to build successfully.

    Thursday, April 30, 2015 4:07 PM
  • I tried the standalone Windows 10 SDK installer, which did appear to install everything correctly (according to the application).  The templates are still not in Visual Studio 2015 RC.  The template list has 8.1 templates and "Download Windows Universal Tools"

    • Edited by Bayprince Thursday, April 30, 2015 4:09 PM
    Thursday, April 30, 2015 4:08 PM
  • Original post had a period "." at the end of the url, try this one:

    https://dev.windows.com/downloads/windows-10-developer-tools

    Thursday, April 30, 2015 4:46 PM
  • In this case, try a repair of Visual Studio. If that doesn't work, email me at paul<dot>chapman<at>Microsoft.com and I'll send you instructions on how to provide us with setup logs for further investigation.
    Thursday, April 30, 2015 4:49 PM
  • Thank you for pointing this out. Fixed the URL in my reply.
    Thursday, April 30, 2015 4:50 PM
  • Same issue. Two diffrent computers. running Build 10074

    Getting Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294

    Tryed Repair, update reinstall, link

    https://dev.windows.com/en-us/downloads/install-dev-tools-visual-studio-2015

    But alwas getting this issue.

    From log file....

    [2140:1D74][2015-05-01T00:16:45]i000: MUX:  Updating secondary installer progress display name: Windows 10 SDK 10.0.10069
    [2140:1D74][2015-05-01T00:16:48]i000: MUX:  Updating secondary installer progress display name: Android SDK Setup (API Level 19 and 21, System Images)
    [2140:213C][2015-05-01T00:16:49]i000: MUX:  ExecuteError: Package (VSSecondaryInstaller_box) failed: Error Message Id: 1603 ErrorMessage: Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294
    [207C:2348][2015-05-01T00:17:21]e000: Error 0x80048646: Process returned error: 0x80048646
    [207C:2348][2015-05-01T00:17:21]e000: Error 0x80048646: Failed to execute EXE package.
    [2140:213C][2015-05-01T00:17:21]e000: Error 0x80048646: Failed to configure per-machine EXE package.
    [2140:213C][2015-05-01T00:17:21]i000: MUX:  Installation size in bytes for package: VSSecondaryInstaller_box MaxAppDrive: 0  MaxSysDrive: 7719936  AppDrive: 0  SysDrive: 6257664
    [2140:213C][2015-05-01T00:17:21]i000: MUX:  ExecutePackageComplete for secondary installer
    [2140:213C][2015-05-01T00:17:21]i000: MUX:  Disconnecting secondary installer pipe
    [2140:213C][2015-05-01T00:17:21]i000: MUX:  Return Code:0x80048646 Msi Messages:Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294 Result Detail:0 Restart:None
    [2140:213C][2015-05-01T00:17:21]i000: MUX:  Set Result: Return Code=-2147187130 (0x80048646), Error Message=Windows 10 SDK 10.0.10069 : The installer failed. User cancelled installation. Error code: -2147023294, Result Detail=, Vital=False, Package Action=Install, Package Id=VSSecondaryInstaller_box
    [2140:213C][2015-05-01T00:17:21]i000: Setting string variable 'BundleResult' to value '0'
    [2140:213C][2015-05-01T00:17:21]w350: Applied non-vital package: VSSecondaryInstaller_box, encountered error: 0x80048646. Continuing...

    • Edited by Pulpie Thursday, April 30, 2015 10:29 PM log info
    Thursday, April 30, 2015 10:23 PM
  • Having this issue as well.. Paul, I'd be happy to send over my logs if it helps you guys diagnose. I know we're all excited to get our hands on this!
    Thursday, April 30, 2015 10:27 PM
  • Same here. Is there anyone here that does this on a real PC? I'm on VMWare 11.

    Yves Dolce

    Thursday, April 30, 2015 10:32 PM
  • I followed Paul's advice on the separate installs and worked. Try those and see if it helps you.
    Thursday, April 30, 2015 11:27 PM
  • Hi Paul,

    Since you've fixed the main issue here, can you please look at this other issue we had

    https://social.msdn.microsoft.com/Forums/en-US/31a4bf3b-7983-4755-a23e-a393de32159f/visual-studio-2015-ctp-6-uninstall-on-windows-10-will-not-remove-its-start-menu-items?forum=vssetup

    It's when you want to upgrade from CTP 6 to RC and you uninstall the CTP 6, start menu items on Windows 10 under Visual Studio 2015 would not be cleared before installing the RC. So now I have some links named Visual Studio CTP 6 (like the link to Blend)


    Sadjad Bahmanpour

    Friday, May 1, 2015 8:13 PM
  • Same here. Rolled the dice and skipped the VM. Had to rebuild the machine. You guys testing your stuff before you push it out? 

    Not RTM but come on....


    Travis

    Saturday, May 2, 2015 1:33 AM
  • I have tried this even after the update or fix you have pushed out on the 30th of April and the issue still consists. I am now trying the alternate method you mentioned. I'll update this post when I see how it goes.

    Zack Bowling

    Thursday, June 11, 2015 4:35 PM
  • Did any of you try to install on Windows 8.1 first, fail, then update to Windows 10 hoping that would solve the problem? I took that path to get here. Same problem.
    Tuesday, June 30, 2015 7:51 PM
  • I Paul Still having the same problem

    Thursday, August 6, 2015 12:55 PM
  • Are you installing the RTM version?

    https://dev.windows.com/en-us/downloads

    Thursday, August 6, 2015 3:40 PM