none
[Desktop Converter]Desktop Bridge (DesktopAppConverter.exe) can not be found after installation and does not run

    Question

  • After trying to solve several problems with the Desktop Bridge app, I finally managed to uninstall it and re-install it from the Windows Store. It says it was installed successfully but when I click Launch, or just run it I get the following error:

    & : The term 'DesktopAppConverter.exe' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again

    I installed it on another PC where it does run (I know it should be used from PowerShell but from the other PC it starts and gives info about administrative use etc). I thought I should probably copy the installed files. But to my surprise, DesktopAppConvert.exe is located both in c:\users\MyName\Local\Microsoft\WindowsApps and in a subdirectory below it and is 0 bytes in both cases. There seems to be no proper repair option for Windows apps and I have no idea how to locate it or solve it. Even previous attempts to use my included paid incidents from ActionPack to have this solved were unsuccessful because nobody at Microsoft seems able or willing to help with this which is quite frustrating and makes you wonder what the value is of included paid incidents or Action Pack in general.

    Does anyone have an idea how to get this working again? And where is the app actually located if it can only be found as a 0 bytes .exe?


    Saturday, March 18, 2017 10:05 AM

All replies

  • Hello,

    In general, if you have installed the app from the Store, you should find in your start menu an item called “Desktop App Converter”. You could right click on that icon, choose More -> Run as administrator (since the DAC can’t work without admin rights). Then, the command prompt that will appear, you will be able to invoke it and use it.

    The Desktop App Converter is installed inside the folder C:\Program Files\WindowsApps (which is the location where all the apps downloaded from the Store are installed), but you shouldn’t try to copy and paste it from another machine. A regular installation from the Store should work just fine.

    Here, I want to know how you want to launch the version of the DAC? Did you want to launch the DesktopAppConverter.exe process from a regular command prompt?

    Best Regards,

    Xavier Eoro


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 20, 2017 9:30 AM
    Moderator
  • Hello Xavier,

    Thanks for your reply; I wasn't aware of the location and understand that on searching for the exe it remains hidden. You write "A regular installation from the Store should work just fine." but that is the problem. It doesn't. When I execute Take Ownership in this directory and then open it, all seems to be present. When I right click Run as Administrator from my laptop, I get SYNOPSIS DesktopAppConvert is a tool to.... and headers like USAGE and EXAMPLES. That looks like it works fine from there. When I do exactly the same in my desktop, I get the message below. So it looks like something is wrong with the desktop installation which is not solved by de-installing and reinstalling it.

    So the question is:what & why and how to solve?

    Dick

    & : The term 'DesktopAppConverter.exe' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
    At line:1 char:2
    + &'DesktopAppConverter.exe' --usage
    +  ~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (DesktopAppConverter.exe:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    PS C:\WINDOWS\system32>

    Monday, March 20, 2017 4:42 PM
  • Hello Dick,

    Thanks for your response. Can you please give us the build number of your desktop so that we can further investigate this issue.

    Cheers

    Tuesday, March 21, 2017 7:33 PM
    Moderator
  • Hello,

    That would be great. I have 14393.693. But the laptop where it is working without the above error has the same build number.

    Dick

    Wednesday, March 22, 2017 11:34 AM
  • Hey Dick,

    Is it possible for you try uninstalling the DAC and getting the latest Windows update on your Desktop?

    -Tanaka

    Wednesday, March 22, 2017 10:48 PM
    Moderator
  • Hello Tanaka,

    The first yes, the second no. I think KB4015438 is supposed to update to 14393.969 but of course it doesn't work. Ran the updates twice, both time Failed to install. I see in this forum this is a pretty common problem and as usual no clue in the message why it fails to install.

    Maybe it will install miraculously when I allow updates to run the next few days. Not sure if that will will help the Desktop App Converter.

    Maybe it will not and the good news there is that would probably save me from new features like the unwanted extra click on the lockscreen which could be switched of until a few updates back....

    Dick

    Thursday, March 23, 2017 11:29 PM