• I have a page which has SupportedOrientations="Portrait" Orientation="Portrait" when I rotate the emulator the the page turns into landscape mode. I have a second page with the same settings and rotating the emulator does not change the orientation. Am I missing something simple?
    Friday, October 15, 2010 3:21 PM

All replies

  • I'm surprised that the first page rotates.  To allow landscape, use:

    Friday, October 15, 2010 8:32 PM
  • Hi Xenacode,

    I've seen some odd behaviour that's resolved by restarting the emulator. Let us know if that helps.

    MSDN CTP, Beta, RTM Reference Forum (from Pre-launch)

    Friday, October 15, 2010 10:39 PM
  • No, unfortunately that doesn't make any difference, the same issue happens on a physical device too.
    Monday, October 18, 2010 11:05 AM
  • Can this issue be reproduced in an empty project?

    MSDN CTP, Beta, RTM Reference Forum (from Pre-launch)

    Monday, October 18, 2010 11:13 AM
  • has this ever been resolved since i have the same issue with a lumia 920 

    code is 

        SupportedOrientations="Portrait" Orientation="Portrait"

    however app rotates with phone to landscape.  This is preventing the app developing further so any assistance would be appreciated.


    Thursday, January 17, 2013 2:31 PM
  • Found the solution.

    If you build a default app using blend in the MainPage.xaml.vb page there is

        Public Sub New()

            SupportedOrientations = SupportedPageOrientation.Portrait OR LANDSCAPE


     option which overrides the SupportedOrientations="Portrait" Orientation="Portrait" on the *.xaml page

    simply delete the OR statement in the MainPage.xaml.vb and viola!

    • Proposed as answer by Prellyan01 Wednesday, January 23, 2013 3:25 AM
    Wednesday, January 23, 2013 3:25 AM