none
Why can't I create a developer account when selecting my region as New Zealand? RRS feed

  • Question

  • I'm re-posting Cris MacKay's question from the Microsoft Community forum back in February 2019; it received a lackluster response from the moderator. I too have the issue, which remains unsolved.

    https://answers.microsoft.com/en-us/windows/forum/all/unable-to-open-a-microsoft-developer-account-when/e53d1223-9d6b-4bd5-a427-f153be8c91b1

    "We are unable to open a Microsoft Developer Account when the location is set to New Zealand, I have tried various different details and credentials and have found that is the issue. Opening one with my location set to Australia works. The steps below to reproduce are:  Click "Sign up to Microsoft Developer Account Login with Microsoft Account Choose my Location (New Zealand) Choose type of account (Company) Put in my contact Details Put in Company Approver Details Click next and then I get the error message (Sorry, something went wrong. Please try again later.)"
    • Edited by chasnz Tuesday, July 16, 2019 12:10 AM
    Tuesday, July 16, 2019 12:10 AM

All replies

  • Hi chasnz,

    Since the registration problem contains a lot of private information, and forum is a public place that is not conducive to privacy protection, we cannot reproduce the problem with your information. So could you make a support ticket to ask the team for one-by-one help?(Steps: Contact us > dashboard issue as support topic > Account setup & management as issue type > submit an incident).

    If you don't get the response from the team after a few days, please put the ticket number here, we will help you to contact the team with the ticket number. By the way, could you check your registration steps with steps in this official document(Register your account in Microsoft Developer Center) before you make the ticket? 

    Best regards

    Daisy  Tian


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, July 16, 2019 2:28 AM
    Moderator
  • I'm also having this problem so it does appear to be a New Zealand localised issue and it still hasn't been fix. Please get on this Microsoft, having this still an issue after it was raised in February 2019 is not acceptable.
    Thursday, November 21, 2019 11:33 PM