locked
[UWP]Error When Opening Package.appxmanifest: "Unable to load one or more of the requested types" RRS feed

  • Question

  • I recently switched to Visual Studio 2015, but now I am getting the following error when I try to open my Package.appxmanifest file:

    Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

    I get this error with both previous solutions that I have from Visual Studio 2013 as well as new solutions I am working on creating in Visual Studio 2015. It lets me compile the projects with no problem, but I cannot open the manifest file. I get this error when attempting to open it with the editor or by right-clicking and selecting View Code. I have managed to find some brief stuff about this being related to missing *.dlls, but nothing very helpful about which ones or how to fix it. What is the problem here? Thanks.


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Monday, August 3, 2015 5:53 PM

Answers

  • removing the Apache Cordova Tools Package in visual studio 2015. it will run ok, open easy. if don't choose a way. you can right click on file, choose open with... and choose xml ( text) editor -> click ok. very easy and don't unstall anything.

    khacnguyen


    • Edited by bbnguyenbb Sunday, August 16, 2015 7:25 PM repair
    • Marked as answer by Nathan Sokalski Sunday, August 16, 2015 8:36 PM
    Sunday, August 16, 2015 7:22 PM
  • I think that fixed it, I found a good solution at:

    http://stackoverflow.com/questions/31729255/cant-open-package-appxmanifest-in-visual-studio-2015


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Sunday, August 16, 2015 8:36 PM

All replies

  • Hello Nathan Sokalski,

    Please use devenv /log to gather some logs so that we may know which package failed to load:

    https://msdn.microsoft.com/en-us/library/ms241272.aspx?f=255&MSPPError=-2147217396

    Actually if it is about missing dll, I think we can take the following steps:

    1. Manually install the package that contains the dll

    2. Manually put the dll to its location.

    3. Repair Visual Studio from control panel

    May I ask this question, have you get any error when installing Visual Studio 2015? What's your OS version?

    Maybe this case should be moved to Visual Studio Setup and Installation. But I need more details in order to help you troubleshoot this case.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, August 4, 2015 7:24 AM
  • Thank you for your help. I tried the /log switch, so I now have the logs. I don't recall getting any errors when installing Visual Studio 2015, and I am using Windows 10.

    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Tuesday, August 4, 2015 3:41 PM
  • @Nathan Sokalski,

    Would you mind to send your logs to us? It is called Activity.xml log and we can check it for some details.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, August 10, 2015 11:20 AM
  • I have uploaded the file to my OneDrive account, hopefully I did everything to create the log file correctly. Here is the link to the file:

    https://onedrive.live.com/redir?resid=A530643E44E725C3!492727&authkey=!ANh56CafBZXvINg&ithint=file%2cxml

    Thanks.


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Monday, August 10, 2015 4:06 PM
  • @Nathan Sokalski,

    I've checked your logs:

    1. Error Color Theme Service The color does not exist

    2. Error Extension Manager Extension will not be loaded because an extension with the same ID is already loaded at C:\PROGRAM FILES (X86)\COMMON FILES\MICROSOFT\EXTENSIONMANAGER\EXTENSIONS\MICROSOFT\WINDOWS KITS\8.1\DESKTOP SDK\

    3. Construction of frame content failed System.ArgumentNullException at Microsoft.XamlDiagnostics.UI.LivePropertyExplorer.Model.PropertyExplorerModel..ctor

    I'm afraid you have installation problem in your Visual Studio. What's the result if your repair Visual Studio?

    I may need to help you move your case to Visual Studio Setup and Installation forum.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, August 11, 2015 12:06 PM
  • Doing a Repair did not help, same problem, even though it says the Repair completed successfully.

    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Tuesday, August 11, 2015 5:36 PM
  • Hello,
    The same problem here.
    Reinstalling VS 2015 did not help. Repair did not help.
    It is possible to fix this issue but only temporarily. After several usages problem returns.
    Just reset your settings with CMD, devenv /resetsettings you may also try devenv /resetuserdata
    It must be some how related to user data. I'm using also VS 2013 on other machine.

    Wednesday, August 12, 2015 2:29 PM
  • Neither of those even did a temporarily for me. I also used to have Visual Studio 2013 on the same machine, although I tried to uninstall as much of it as I could before I did the Windows 10 upgrade or installed Visual Studio 2015 Community (but we all know that stuff always ends up getting left behind).

    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Wednesday, August 12, 2015 3:47 PM
  • removing the Apache Cordova Tools Package in visual studio 2015. it will run ok, open easy. if don't choose a way. you can right click on file, choose open with... and choose xml ( text) editor -> click ok. very easy and don't unstall anything.

    khacnguyen


    • Edited by bbnguyenbb Sunday, August 16, 2015 7:25 PM repair
    • Marked as answer by Nathan Sokalski Sunday, August 16, 2015 8:36 PM
    Sunday, August 16, 2015 7:22 PM
  • I think that fixed it, I found a good solution at:

    http://stackoverflow.com/questions/31729255/cant-open-package-appxmanifest-in-visual-studio-2015


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Sunday, August 16, 2015 8:36 PM