locked
Can not open Entity Data Model designer RRS feed

All replies

  • Additional info: i tried to uninstall ADO.Net Entity Framework Tools Beta 2 then i reinstalled VS2010 Beta 2. Now when i open my solution, i get the following error message:
    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    The 'Microsoft.Data.Entity.Design.BootstrapPackage.BootstrapPackage, Microsoft.Data.Entity.Design.BootstrapPackage, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' package did not load correctly.

    The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by running the application together with the /log parameter on the command line, and then examining the file 'C:\Users\...\AppData\Roaming\Microsoft\VisualStudio\10.0\ActivityLog.xml'.

    Continue to show this error message?
    ---------------------------
    Yes   No  
    ---------------------------

    And now i can not even see the icon of the edmx file in the solution explorer.

    Monday, February 22, 2010 5:31 PM
  • Hi Daniel -

    A few questions:

      * What version of VS did you have install?
      * What OS are you running?  Is it 32-bit or 64-bit?


    Here's what I recommend: 

    1.  uninstall VS
    2.  After VS uninstalls, run the following commands from an eleveated command prompt:

    REM
    REM
    REM Run these if you're running 32-bit windows
    REM
    REM
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\AutoLoadPackages\{adfc4e66-0397-11d1-9f4e-00a0c911004f} /v {7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB} /f
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\AutoLoadPackages\{93694fa0-0397-11d1-9f4e-00a0c911004f} /v {7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB} /f
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\Packages\{7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB} /va /f

    REM
    REM
    REM Run these if you're running 64-bit windows
    REM
    REM
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\AutoLoadPackages\{adfc4e66-0397-11d1-9f4e-00a0c911004f} /v {7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB} /f
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\AutoLoadPackages\{93694fa0-0397-11d1-9f4e-00a0c911004f} /v {7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB} /f
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\Packages\{7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB} /va /f 
     

    3.  Re-install VS (be sure to choose to install C# and/or VB langauges, otherwise the EF Designer won't be installed. 


    Let me know if this works,

    Thanks,

    Mike Kaufman
    Microsoft Corp.


    This posting is provided "AS IS" with no warranties, and confers no rights
    Friday, February 26, 2010 12:36 AM
    Moderator
  • Why am I receiving this same error with VS Ultimate RTMRel?????
    Friday, July 16, 2010 6:20 PM
  • Please notify me if anyone at MS cares to provide a solution that does not waste an hour of my time uninstalling/reinstalling.
    Friday, July 16, 2010 6:21 PM
  • I also got these irritating error messages about the BootStrapPackage, etc. and tampering with the registry (including a laborius unistall/reinstall) resulted in twice as much error messages for me.

    Then I found this link about MVC Template not showing up in Visual Web Developer, and soon suspected a close connection to my problem.

    So I followed these very simple instructions:

    1. From the Tools menu, select "Reset all settings" and then "Next"

    2. Choose if you want to save our old settings or not, then "Next"

    3. Select "Visual C# Development Settings" (or our own preference) and then "Finish".

    And thats all!

    Hope this will work for you too.

    Monday, January 31, 2011 7:15 AM
  • Nope, did not work for me.
    Sunday, February 6, 2011 1:35 AM
  • Worked for me. Thanks.
    Wednesday, February 9, 2011 10:06 AM
    1. From tools menu in VS2010 select Import and Export Settings...
    2. Select the last option, reset settings.
    3. Save them, why not :)
    4. Select a canned default, such as Visual C#.
    5. Post your differences here, so that you know what to re-enable, and Microsoft Connect people know what needs to be fixed.
    Thursday, March 24, 2011 3:44 PM
  • Worked for me too. Thanks.
    1. From tools menu in VS2010 select Import and Export Settings...
    2. Select the last option, reset settings.
    3. Save them, why not :)
    4. Select a canned default, such as Visual C#.
    5. Post your differences here, so that you know what to re-enable, and Microsoft Connect people know what needs to be fixed.

    Sunday, July 10, 2011 9:47 PM
  • Thanks for the Solution this really helped my problem that occured now had answered 2years earlier!!
    Sunday, March 11, 2012 3:00 AM