locked
Hosted Web App and Internally Hosted Websites

    Question

  • I am trying to generate a "Hosted Web App" using the Windows App Studio Beta for an internally hosted website.

    I can generate a the app just fine when pointing the URL to something the resolves to a public IP address.  E.g. https://google.com.

    If I generate the app for something that points to an internal IP address e.g. https://company.com when loading the application after installing with Windows App Studio I get "Uh oh, we cannot display this content: https://company.com/ Http status 404 Failure name: N/A".

    The URL loads fine in my browser.  The only difference is that I am trying to get this working for use on workstations inside our company and when we are on our network the ip adresss for the website in question resolves to a private ip instead of a public ip.

    Anyone have any insight into what is happening here or if there is an easy way to work around whatever is going on?

    Thursday, June 22, 2017 9:51 PM

All replies

  • Hello,

    According to the error message, the internal URL may not be supported by App Studio tool.

    I'd recommend you to use Visual Studio to create a hosted web app. You can refer to Convert your web application to a Universal Windows Platform (UWP) app .

    If you still want to use App Studio, you may consult windowsappstudio@microsoft.com to see if there exists any workaround for private IP address.

    Thank you.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, June 23, 2017 7:49 AM
    Moderator
  • Was kind of looking for reasons this might be happening.

    I'm not sure why it would care if the URL I give it resolves to a public IP address or an internal IP address.

    Does anyone:

    1. Know if this is intentional or expected behavior?
    2. Have useful insight into why this the case.
    3. URLs that resolve to private ip address work for you and I may just be doing something wrong.

    Short of that I guess I'm loading up visual studio to see if I have the same issues.

    Friday, June 23, 2017 4:20 PM
  • Just double checking a few things with the "Hosted Web App" generated with "Windows App Studio".

    I have verified that the same URL _does_ load within the same generated app if I run it from a Windows 10 system that is outside of our network.

    The only difference is that the dns resolves to a public ip rather than a private ip.  The server and the site behind the url is exactly the same.

    Friday, June 23, 2017 6:20 PM
  • This should explain:

    https://social.msdn.microsoft.com/Forums/en-US/02806afa-4069-4c73-b3d4-aeb573a0c522/uwp-project-westminster-hosted-web-app-issue-with-intranet-vs-internet-host?forum=wpdevelop

    Wednesday, June 28, 2017 1:48 AM